Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
quacka  
#1 Posted : Sunday, September 10, 2006 1:13:14 PM(UTC)
quacka

Rank: Member

Groups: Member
Joined: 1/17/2005(UTC)
Posts: 32

Hi, I had uploading problems for a while now. I thought it was Dundas so I moved from asp to ASP.NET and use native upload support. However I still get the same problem on a certain number of customers who try upload their images to us. Basically they upload and it gets to 100% and nothing gets saved. Here are my Image Uplaoder Settings:
Code:
<script language="javascript">
var iu = new ImageUploaderWriter("ImageUploader", 720, 500);
iu.activeXControlEnabled = true;
iu.javaAppletEnabled = true;

//For ActiveX control we specify full path for CAB file
iu.activeXControlCodeBase = "./components/ImageUploader4.cab";
iu.activeXControlVersion = "4,0,33,0";

//For Java applet we specify only directory with JAR files
iu.javaAppletCodeBase = "./components/";
iu.javaAppletCached = true;
iu.javaAppletVersion = "2.0.35.0";

iu.addParam("Layout", 2);
iu.addParam("FolderView", 0);					
iu.addParam("UploadView", 0);				

iu.addParam("UploadThumbnail1FitMode", 0);

iu.addParam("BackgroundColor", "LightGrey");
iu.addParam("PaneBackgroundColor", "White");

iu.addParam("ShowFileNames", "True");
iu.addParam("ShowDescriptions", "False");
iu.addParam("ShowButtons", "False");
iu.addParam("ShowStatusPane", "True");
iu.addParam("ShowDebugWindow", "False");
iu.addParam("EnableRotate", "False");
iu.addParam("RememberLastVisitedFolder", "true");
iu.addParam("EnableFileViewer", "true");
iu.addParam("PreviewThumbnailSize", "80");
iu.addParam("TimeOut", "0");


iu.addParam("LicenseKey", "**********;***********");

iu.addParam("Action", "ProcessUpload.aspx");
iu.addParam("RedirectUrl", "promotion.asp");
iu.addParam("FileMask", "*.jpg;*.jpeg;*.tif;*.tiff");
iu.addParam("FilesPerOnePackageCount", "1");
iu.addParam("AutoRecoverMaxTriesCount", "5");
iu.addParam("AutoRecoverTimeOut", "5000");


iu.addEventListener("UploadFileCountChange", "ImageUploader_UploadFileCountChange");
iu.addEventListener("ViewChange", "ImageUploader_ViewChange");
iu.addEventListener("Progress", "ImageUploader_Progress");

iu.addParam("AdditionalFormName", "UploadInfo");

iu.writeHtml();
And here is my processupload.aspx
Code:
    Inherits System.Web.UI.Page

    Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
        Dim postedFile As HttpPostedFile
        Dim savePath As String

        Try
            Response.Clear()
            If Request("UserFolder") Is Nothing OrElse Request("UserFolder") = "" Then
                Response.Write("Error: User Folder not specified.")
            ElseIf Request.Files.Count <= 0 Then
                Response.Write("Error: No files were uploaded.")
            Else
                savePath = Request("UserFolder")
                If IO.Directory.Exists(savePath) = False Then
                    IO.Directory.CreateDirectory(savePath)
                End If
                For i As Integer = 0 To Request.Files.Count - 1
                    postedFile = Request.Files.Get(i)
                    postedFile.SaveAs(IO.Path.Combine(savePath, IO.Path.GetFileName(postedFile.FileName)))
                Next
            End If
            Response.Write("0")
        Catch ex As Exception
            Response.Write("Error: " & ex.Message)
        Finally
            Response.End()
        End Try

    End Sub
As a note this only happens about 10% of the time and the people it happens on all seem to use windows xp sp2. 99% of our users use windowsxp sp2 so this cant be the problem. Also sometimes I go through troubleshooting step I tell them to test one image, and this one image takes them 2 second to send about 1MB which isn't right and not showing up in the end. Is there a way I can make a page for debugging uploader and I can send all these people to. When they upload the debug information will be emailed to me?

Edited by user Tuesday, February 19, 2008 1:50:51 PM(UTC)  | Reason: Not specified

Alex Makhov  
#2 Posted : Monday, September 11, 2006 6:55:35 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello, There is no such debug page. You could set the ShowDebugWindow property value to true to allow your users to get an error page returned from your server.

Edited by user Tuesday, February 19, 2008 1:52:14 PM(UTC)  | Reason: Not specified

Sincerely yours, Alex Makhov UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Similar Topics
HTML5 and ColdFusion Upload Problem (Discussions – HTML5/Flash Uploader)
by bamoroso 5/21/2015 11:39:07 AM(UTC)
HTML 5 upload problem (Discussions – HTML5/Flash Uploader)
by Nan 3/12/2013 6:02:39 PM(UTC)
Max 10 Files upload problem (Discussions – ActiveX/Java Uploader)
by Stormcatch 5/31/2011 4:24:54 AM(UTC)
Upload problem (Upload CMS Plug-ins (Photo Order 2.x for VM, Drupa)
by sky-3000 11/5/2010 1:01:23 AM(UTC)
Jpg thumbnail upload problem (Discussions – ActiveX/Java Uploader)
by Del 12/10/2009 1:41:44 AM(UTC)
Aurigma Upload and https/htpassword upload problem (Discussions – ActiveX/Java Uploader)
by spcosten 3/19/2008 12:09:29 AM(UTC)
Opera and redirecting after upload problem (Discussions – ActiveX/Java Uploader)
by zoki_57 3/29/2007 6:45:25 PM(UTC)
Upload problem with windows98 (Image Uploader)
by far41 12/11/2006 5:12:36 AM(UTC)
File upload problem (Image Uploader)
by Bomelin 10/16/2005 9:41:24 PM(UTC)
java : after upload problem (Image Uploader)
by ofer 9/21/2005 12:22:47 AM(UTC)
Upload problem (Image Uploader)
by Testuser 2/23/2005 10:29:00 PM(UTC)
Upload problem with Photoshop retouched image (Image Uploader)
by praxisinc 2/23/2005 1:20:00 AM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.