Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
dealerlens  
#1 Posted : Monday, January 23, 2006 5:50:53 AM(UTC)
dealerlens

Rank: Member

Groups: Member
Joined: 1/23/2006(UTC)
Posts: 4

I have my users limited to 15 images and I can load 15 images that total 3 or 4
megs and everything works great. I can try and upload 8 images that total 10+
megs and the uploader appears to runs successfully and the Upload Complete popup shows but no images are added to the server and no errors are returned. I am using ASP code
on IIS 6, Windows Server 2003 and the ActiveX version of uploader.

I have turned on the error message parameters and nothing is showing as failed
so I don't know what else it could be.

I have given the Network System account Full Control on the necessary folders.

I have changed the AspMaxRequestEntityAllowed setting in the MetaBase.xml file
to "1073741824" per the ASPSmartUpload documentation.

The process is taking less than a minute and I have the script timeout set to
120 seconds on IIS so it should not be timing out.

Again, I can load small collections of images everytime with no problems.

Here is my code for the uploader:

Code:
<script language="javascript"> 
var iu = new ImageUploaderWriter("ImageUploader", 770, 500); 
iu.activeXControlEnabled = true; 
iu.javaAppletEnabled = false; 
 
//For ActiveX control we specify full path for CAB file 
iu.activeXControlCodeBase = "ImageUploader3.cab"; 
iu.activeXControlVersion = "3,5,144,0"; 
iu.addParam("LicenseKey", "####-####-####-####"); 
 
iu.addParam("Layout","TwoPanes"); 
iu.addParam("UploadThumbnail1FitMode","Fit"); 
iu.addParam("UploadThumbnail1Width","120"); 
iu.addParam("UploadThumbnail1Height","120"); 
iu.addParam("UploadThumbnail1JpegQuality","60"); 
iu.addParam("ShowDebugWindow","True"); 
iu.addParam("AdditionalFormName","Form1"); 
iu.addParam("EnableRotate","True"); 
iu.addParam("BackgroundColor", "#345574"); 
iu.addParam("MaxTotalFileSize", "30000000"); 
iu.addParam("MaxFileCount", "15"); 
iu.addParam("MaxFileSize", "1500000"); 
iu.addParam("ShowDebugWindow", "True"); 
iu.addParam("MessageDimensionsAreTooLargeText", "The image [Name] cannot be 
selected. These image dimensions ([OriginalImageWidth]x[OriginalImageHeight]) 
are too large. The image should be smaller than 
[MaxImageWidth]x[MaxImageHeight]."); 
iu.addParam("MessageMaxFileSizeExceededText", "The file [Name] cannot be 
selected. This file size exceeds the limit ([Limit] Kb)."); 
iu.addParam("MessageMaxTotalFileSizeExceededText", "The file [Name] cannot be 
selected. Total upload data size exceeds the limit ([Limit] Kb)."); 
iu.addParam("MessageNoInternetSessionText", "No Internet session was 
established."); 
iu.addParam("MessageNoInternetSessionWasEstablishedText", "No Internet session 
was established."); 
iu.addParam("MessageNoResponseFromServerText", "No response from server."); 
iu.addParam("MessageServerNotFoundText", "The server or proxy [Name] not 
found."); 
iu.addParam("MessageUnexpectedErrorText", "Image Uploader encountered some 
problem. If you see this message, contact web master."); 
iu.addParam("MessageUploadCancelledText", "Upload is cancelled."); 
iu.addParam("MessageUploadFailedText", "Upload failed (the connection was 
interrupted)."); 
iu.addParam("MessageUserSpecifiedTimeoutHasExpiredText", "User-specified timeout 
has expired."); 
iu.addParam("FilesPerOnePackageCount", "-1"); 
iu.addParam("FileMask", "*.jpg;*.jpeg;*.jpe;*.bmp;*.gif"); 
iu.addParam("MessageMaxFileCountExceededText", "You can select not more then 15 
files."); 
 
iu.addParam("Action","AspSmartUpload.asp") 
 
iu.addEventListener("Progress", "ImageUploader_Progress"); 
 
iu.writeHtml(); 
</script> 

Edited by user Sunday, February 17, 2008 8:02:35 PM(UTC)  | Reason: Not specified

dealerlens  
#2 Posted : Monday, January 23, 2006 9:33:45 PM(UTC)
dealerlens

Rank: Member

Groups: Member
Joined: 1/23/2006(UTC)
Posts: 4

The problem is for some reason the uploader fails when loading 6 or more megs (give or take).

I have the Max limits set for more than 6 megs and I have adjusted the setting that ASPSmartUpload requires for ASP pages to process more than 200 kb.

It is not giving any errors but it is not loading the images.

This could be something on the server, but I am not sure where to look next.

Thanks
Alex Makhov  
#3 Posted : Tuesday, January 24, 2006 12:30:25 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups:
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

1. Troubleshooting;
2. TimeOut Property.

Edited by user Monday, October 27, 2008 10:40:45 PM(UTC)  | Reason: Not specified

Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
dealerlens  
#4 Posted : Tuesday, January 24, 2006 11:01:47 PM(UTC)
dealerlens

Rank: Member

Groups: Member
Joined: 1/23/2006(UTC)
Posts: 4

Thanks.

I don't see anything in the FAQ that helps because the uploader is not returning an error for me to debug or for me to search out.

Again, it appears to work, but does not write the images to the server.

Also, I added the timeout parameter and it still did not work.

Any other thoughts?

Thanks in advance.
dealerlens  
#5 Posted : Wednesday, January 25, 2006 2:59:50 AM(UTC)
dealerlens

Rank: Member

Groups: Member
Joined: 1/23/2006(UTC)
Posts: 4

I get the following error in the ImageUploader_Progress function at the end of the upload:
This is in the alert(StatusText)

Code:
Stack overflow at line: 0

function ImageUploader_Progress(Status, Progress, ValueMax, Value, StatusText){
    alert(StatusText);
    if (Status=="COMPLETE"){
	   // When upload is finished, we are redirecting to the PictureGalery.asp page
		window.location="Gallery.asp";
    }
} 

Edited by user Sunday, February 17, 2008 8:03:03 PM(UTC)  | Reason: Not specified

Alex Makhov  
#6 Posted : Wednesday, January 25, 2006 3:40:37 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups:
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

Could you give us the link to your page to test Image Uploader ant try to find the reason of the problem?
Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
lmginn  
#7 Posted : Saturday, February 18, 2006 2:54:07 AM(UTC)
lmginn

Rank: Member

Groups: Member
Joined: 2/18/2006(UTC)
Posts: 3

Hello,

Has this been solved? I am having the same problem. The uploader works fine until I try to upload images totaling > ~10MB

Is there a solution?

-LM Ginn
Alex Makhov  
#8 Posted : Sunday, February 19, 2006 1:42:00 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups:
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

Quote:
Is there a solution?


Yes. The most common reason of this problem is wrong server configuration which refuses too big files to be uploaded. Check your configuration. If you still encounter problems feel free to use FilesPerOnePackageCount property to send files one by one.

Edited by user Sunday, February 17, 2008 8:03:25 PM(UTC)  | Reason: Not specified

Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.