Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
bugware  
#1 Posted : Monday, January 09, 2006 10:57:53 AM(UTC)
bugware

Rank: Member

Groups: Member
Joined: 1/9/2006(UTC)
Posts: 6

I'm trying to create an installation setup for my app which employs GM ActX. Nice tools, but I can't get Installshield to register the system files properly so that the app works on the destination computer. It installs all the .ocx and .dll files in the program installation folder, and puts the codecs subfolder underneath the app's folder, but when the destination user runs, he gets the error message that the Graphics Mill .ocx file was not properly registered. Installshield recognizes the dependencies, but just does not seem to register these files with the system. I can do it manually using regsvr32.exe, but this obviously cannot be done on all destination computers. Does anybody have experience with Installshield and Graphics Mill for ActiveX? How can I get these files properly registered with the system? Thanks in advance.
Mitch
Andrew  
#2 Posted : Wednesday, January 11, 2006 2:09:35 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 863

Thanks: 2 times
Was thanked: 25 time(s) in 25 post(s)
Mitch, Since you can register the .ocx file manually with regsvr32 on the target machine, perhaps the problem is in your InstallShield configuration. For example, you could forget to mark it as self-registering file as described in InstallShield help. Hope this link helps.
bugware  
#3 Posted : Thursday, January 12, 2006 1:48:32 AM(UTC)
bugware

Rank: Member

Groups: Member
Joined: 1/9/2006(UTC)
Posts: 6

Thanks for your help! From that link I don't see anything obvious that helps me. I forgot to mention that I'm using Installshield Express. I'll try to find out how to self-register files, though I don't understand why all my other 3rd party files register OK, but not the Aurigma files. Is there an order that they should be registered? Hope I can resolve this, have invested a lot of time in this just to find this stumbling block at the end! Any other hints would be appreciated. thanks again, mitch
Quote:
Andrew (1/11/2006) Mitch, Since you can register the .ocx file manually with regsvr32 on the target machine, perhaps the problem is in your InstallShield configuration. For example, you could forget to mark it as self-registering file as described in InstallShield help. Hope this link helps.
Mitch
bugware  
#4 Posted : Thursday, January 12, 2006 10:16:24 AM(UTC)
bugware

Rank: Member

Groups: Member
Joined: 1/9/2006(UTC)
Posts: 6

Almost there. Have found how to self register files in Installshield Xpress, but get an error that the codecs dll fails to register. The program works properly, however, after this installation. If I omit this dll from the self register, then the images do not load. Any thoughts? It works, but I'll have to warn the end users to ignore the error message, would rather not do that. thanks, mitch
Mitch
Andrew  
#5 Posted : Thursday, January 12, 2006 12:39:27 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 863

Thanks: 2 times
Was thanked: 25 time(s) in 25 post(s)
Codecs dll should not be registered. It is not ActiveX component, it is a common DLL which should be placed in the proper folder on the client machine. See the Installation and Redistribution notes of Graphics Mill for more information what files should be distributed and what files should/should not be registered.

Edited by user Tuesday, December 15, 2009 10:32:36 AM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.