Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
rmajoran  
#1 Posted : Thursday, October 21, 2010 2:01:04 PM(UTC)
rmajoran

Rank: Newbie

Groups: Member
Joined: 10/12/2010(UTC)
Posts: 8

I followed the instructions on your site for creating my own theme and every time I compiled the new SWF file, when I went to add pictures, it got stuck on the Aurigma Image Uploader Flash percentage bar (and wouldn't insert pictures). So I tried recompiling your DefaultTheme.css file and had the same results. If I use the original DefaultTheme.swf file, everything works great. Note that when I compiled the CSS file, I received this message:

rmajoran$ /Users/rmajoran/Downloads/flex_sdk_4.1/bin/mxmlc /Users/rmajoran/Desktop/Themes/Default/DefaultTheme.css

Loading configuration file /Users/rmajoran/Downloads/flex_sdk_4.1/frameworks/flex-config.xml

/Users/rmajoran/Desktop/Themes/Default/DefaultTheme.css(103): Warning: Type 'Button' in CSS selector 'Button' must be qualified with a namespace.

{

/Users/rmajoran/Desktop/Themes/Default/DefaultTheme.swf (49564 bytes)

---

I then changed line 103 to .Button and the error went away... but it still doesn't fix the problem.

Thoughts?

Here is my code:

Code:
<script type="text/javascript" src="ClientScripts/aurigma.imageuploaderflash.js">  </script>
<script type="text/javascript">
	var fu = $au.imageUploaderFlash({
		
		id: 'Uploader1',
		width: '900px',
		height: '480px',
		licenseKey: 'XXXXXXXXXXXXXXXXXXXXX',
		flashControl: {
			codeBase: 'ClientScripts/aurigma.imageuploaderflash.swf',
			themeUrl: 'ClientScripts/Themes/Default/DefaultTheme.swf'
		},
		converters: [
			{mode: '*.*=Thumbnail', thumbnailFitMode: 'Fit', thumbnailWidth: '1200', thumbnailHeight: '1200', thumbnailJpegQuality: '60'},
			{mode: '*.*=Thumbnail', thumbnailFitMode: 'Fit', thumbnailWidth: '90', thumbnailHeight: '68', thumbnailJpegQuality: '60'}
		], 
		upload: {
			actionUrl: 'photoengineupload-v4.cfm?h=#session.d2#',
			redirectUrl: 'edit.cfm?step=2&status=1&mid=15&genre1=#genre1#&d=#session.d2#&RequestTimeout=9999'
		}
		
	});
		
	fu.restrictions({
		fileFilters: [
			['Images (*.jpg; *.jpeg; *.jpe)', '*.jpg;*.jpeg;*.jpe']
		],
		minFileCount: 1, 
		maxFileCount: #val(photosallowed)#,
		maxFileSize: 15728640, //15 MB in bytes
		minImageWidth: 150, 
		minImageHeight: 150
	});  
	 
	fu.messages({
		tooFewFilesError: 'You must select at least one file.',
		tooManyFilesError: 'You can select not more than #val(photosallowed)# files.',
		fileTooLargeError: 'You can add files not larger than 15 MB.',
		imageHeightTooSmallError: 'Image height should be larger than 150 pixels.',
		imageWidthTooSmallError: 'Image width should be larger than 150 pixels.'
	});
	
	
	
	fu.writeHtml();

</script>

Edited by moderator Monday, December 6, 2010 4:51:21 AM(UTC)  | Reason: Not specified

Arjan  
#2 Posted : Thursday, October 21, 2010 3:47:15 PM(UTC)
Arjan

Rank: Newbie

Groups: Member
Joined: 10/10/2010(UTC)
Posts: 7

Try using SDK 3.5. That worked for me :)
Dmitry.Obukhov  
#3 Posted : Thursday, October 21, 2010 8:34:12 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Member
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Ray,

Thanks for your report.

Unfortunately, version 4 of Flex does not support current CSS files of Image Uploader Flash now. You should use the Flex 3.

If you have any additional questions or problems, please feel free to let me know.

Best regards,

Dmitry Obukhov

Technical Support. Aurigma, Inc.

rmajoran  
#4 Posted : Monday, October 25, 2010 4:16:59 AM(UTC)
rmajoran

Rank: Newbie

Groups: Member
Joined: 10/12/2010(UTC)
Posts: 8

Flex 3.5 work great -- thanks!
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.