Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
idekkers  
#1 Posted : Thursday, June 3, 2010 4:12:49 AM(UTC)
idekkers

Rank: Advanced Member

Groups: Member
Joined: 2/27/2010(UTC)
Posts: 74

hello

is it possible to change the "name" attribute to an "id" attribute in the "tabs" region and the "layers" region ?

using "name" is not valid XHTML1 ?

is it possible to load an image directly in to the editor region ?

Tamila  
#2 Posted : Thursday, June 3, 2010 9:09:35 PM(UTC)
Tamila

Rank: Advanced Member

Groups: Administration
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hi,

Quote:
is it possible to change the "name" attribute to an "id" attribute in the "tabs" region and the "layers" region ?

using "name" is not valid XHTML1 ?

Our developers will prepare new version for you. It will be available next week.

Quote:
is it possible to load an image directly in to the editor region ?

Could you please describe this problem a bit detailed.

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

idekkers  
#3 Posted : Saturday, June 5, 2010 9:01:09 AM(UTC)
idekkers

Rank: Advanced Member

Groups: Member
Joined: 2/27/2010(UTC)
Posts: 74

thanks

about the second question:

instead of using an image from the "Images/Labels" folder, i want the user to be able to add his own image.

the loading of the image to the server is not a problem, just how do i add it directly as the bottom layer of the editor window ?

Tamila  
#4 Posted : Sunday, June 6, 2010 9:57:33 PM(UTC)
Tamila

Rank: Advanced Member

Groups: Administration
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hi,

Thanks to explanation.

Yes, it is possible. After your customer added own file, you should save it on your server. Now you can load this file as background in Gift Editor (PhotoLabelSample.aspx.cs Line:185):

Code:
photoLabel.BackgroundImage = file;
Where file is the path of uploaded file.

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

idekkers  
#5 Posted : Sunday, June 6, 2010 11:36:25 PM(UTC)
idekkers

Rank: Advanced Member

Groups: Member
Joined: 2/27/2010(UTC)
Posts: 74

thanks for the quick reply Tamila,

but i was talking about the active region not the entire background.

also how do i set a circular active region instead of a rectangular one ?

thanks again

andreym  
#6 Posted : Monday, June 7, 2010 2:01:59 AM(UTC)
andreym

Rank: Advanced Member

Groups: Administration
Joined: 6/16/2009(UTC)
Posts: 134

Was thanked: 8 time(s) in 8 post(s)
Hi!

This is example how you can add an image into region:

Code:

	protected void addImageBtn_Click(object sender, EventArgs e)
	{
		// Save uploaded file
		string filePath = MapPath("~/Saves/" + FileUpload1.FileName);
		FileUpload1.SaveAs(filePath);

		// Get current selected region
		Layer l = photoLabel.CanvasViewer.Canvas.CurrentLayer;
		RectangleRegion r = l.Region;
		
		// Create ImageVObject
		ImageVObject imgVObject = new ImageVObject(new FileInfo(filePath));
		
		// Resize image to fit into region
		float dx = imgVObject.Width / r.Width;
		float dy = imgVObject.Height / r.Height;
		if (dx < dy)
		{
			imgVObject.Width = imgVObject.Width / dy;
			imgVObject.Height = imgVObject.Height / dy;
		}
		else
		{
			imgVObject.Width = imgVObject.Width / dx;
			imgVObject.Height = imgVObject.Height / dx;
		}

		// Place image into region
		imgVObject.Location = new Aurigma.GraphicsMill.AjaxControls.VectorObjects.Math.PointF(r.Left, r.Top);
		
		// Set supported actions
		imgVObject.SupportedActions = VObjectAction.Drag | VObjectAction.ProportionalResize;
		
		// Add image to canvas
		l.VObjects.Add(imgVObject);
	}

Quote:
also how do i set a circular active region instead of a rectangular one ?

Unfortunately, only rectangular region supported.

idekkers  
#7 Posted : Monday, June 7, 2010 9:06:19 AM(UTC)
idekkers

Rank: Advanced Member

Groups: Member
Joined: 2/27/2010(UTC)
Posts: 74

thanks for the quick reply - working perfectly.

about the circle - is it going to be in the next version ?

also I've seen something about an ellipse region or something in the documentation,

and if we're talking about curved lines - is it possible to do curved text ?

thanks

Tamila  
#8 Posted : Monday, June 7, 2010 9:13:56 PM(UTC)
Tamila

Rank: Advanced Member

Groups: Administration
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hi,

Quote:
is it possible to change the "name" attribute to an "id" attribute in the "tabs" region and the "layers" region ?

using "name" is not valid XHTML1 ?

New version is already available. You can download it here.

Quote:
about the circle - is it going to be in the next version ?

also I've seen something about an ellipse region or something in the documentation,

and if we're talking about curved lines - is it possible to do curved text ?

Curved text is not supported too. Unfortunately we do not plan to add such functionality in the nearest future.

Edited by user Tuesday, June 8, 2010 1:22:33 AM(UTC)  | Reason: Not specified

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

idekkers  
#9 Posted : Wednesday, June 9, 2010 8:06:52 AM(UTC)
idekkers

Rank: Advanced Member

Groups: Member
Joined: 2/27/2010(UTC)
Posts: 74

strange thing:

as I've written above, the code to load an image as a background works great,

just one strange thing happening with it, the background image layer appears only after i add another layer.

how can i tell the layer view to update ?

andreym  
#10 Posted : Thursday, June 10, 2010 1:14:06 AM(UTC)
andreym

Rank: Advanced Member

Groups: Administration
Joined: 6/16/2009(UTC)
Posts: 134

Was thanked: 8 time(s) in 8 post(s)
Yes, it seems that after postback all items in the layers list are disappeared. We will fix it and update the sample on the forum.
idekkers  
#11 Posted : Friday, June 18, 2010 4:17:29 AM(UTC)
idekkers

Rank: Advanced Member

Groups: Member
Joined: 2/27/2010(UTC)
Posts: 74

hi again

just a quick one

which of the files have been changed for the removal of the "name" attribute to work ?

do i need to replace all the files for this to work or just some of them ?

thanks

Tamila  
#12 Posted : Sunday, June 20, 2010 2:32:01 PM(UTC)
Tamila

Rank: Advanced Member

Groups: Administration
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hi,

We recommend you to replace all files.

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.