Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Brainwrek  
#1 Posted : Wednesday, April 14, 2010 1:43:23 AM(UTC)
Brainwrek

Rank: Member

Groups: Member
Joined: 4/7/2010(UTC)
Posts: 12

Still trying to work out AS3 uploads. I think it's working for the most part. But I am receiving this error between each file as it's uploaded:
Code:
IUEmbed Warning:
Error occured during upload to Amazon S3 service. The service returned the following answer:

To be clear, all images are being uploaded, but this error pops up between each image (source, thumb1, and thumb2). Since the "answer" is blank, I'm not sure what I should be looking to troubleshoot. Any ideas?
andreym  
#2 Posted : Wednesday, April 14, 2010 1:50:59 AM(UTC)
andreym

Rank: Advanced Member

Groups: Member
Joined: 6/16/2009(UTC)
Posts: 134

Was thanked: 8 time(s) in 8 post(s)
Yes, it is a known issue. Since there is one file only allowed to upload to Amazon S3 per request we use the trick which uploads source file and its thumbnails in different requests. So we need to abort upload after each uploaded file, reconfigure uploader and start to upload again. To do so we return false from the PackageComplete event handler. And it produces this error. To hide this message set debugLevel value to zero.
Code:
// Disable debug messages
IUCommon.debugLevel = 0;
Brainwrek  
#3 Posted : Wednesday, April 14, 2010 10:39:21 AM(UTC)
Brainwrek

Rank: Member

Groups: Member
Joined: 4/7/2010(UTC)
Posts: 12

AhHa. That fixed it perfectly.
I saw that code in the AS3 Advanced demo, but I thought it was unrelated.

Thanks again.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.