Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
mcain  
#1 Posted : Friday, March 19, 2010 3:48:16 AM(UTC)
mcain

Rank: Newbie

Groups: Member
Joined: 10/30/2008(UTC)
Posts: 2

Is it possible to disable the use of WebResource.axd to serve the javascript files for the ImageUploader control?

I have two issues:

1) When I make modifications to the javascript files (I want to enhance the error message when the uploader is not installed on the client), I am not seeing those changes when developing/testing.

2) The .js files are being served unminified and uncompressed (as far as I can tell) -- I have my own code to serve .js files from cache that have been minified and compressed and would prefer to use it.

Edited by user Friday, March 19, 2010 3:57:13 AM(UTC)  | Reason: Not specified

Tamila  
#2 Posted : Sunday, March 21, 2010 4:15:40 PM(UTC)
Tamila

Rank: Advanced Member

Groups: Member
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hello,

As I understand you use Image Uploader ASP.Net control. In this case you need to use the following properties Image Uploader to allow to use .js scripts from some folder rather than from ASP.Net control:

Code:
ScriptsDirectory="Scripts" // folder with scripts
IUEmbedScriptUseCustomCodeBase="true"

In other hand you can embed Image Uploader using Embedding Scripts library. In this case javascript is used for Image Uploader embedding. Please read the following article:

Inserting Image Uploader into Web Page

I hope it helps you.

Edited by user Sunday, March 21, 2010 4:32:46 PM(UTC)  | Reason: Not specified

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

chuck  
#3 Posted : Monday, July 30, 2012 7:25:24 PM(UTC)
chuck

Rank: Newbie

Groups: Member
Joined: 7/24/2012(UTC)
Posts: 2

Tamila wrote:
Hello,

As I understand you use Image Uploader ASP.Net control. In this case you need to use the following properties Image Uploader to allow to use .js scripts from some folder rather than from ASP.Net control:

Code:
ScriptsDirectory="Scripts" // folder with scripts
IUEmbedScriptUseCustomCodeBase="true"

In other hand you can embed Image Uploader using Embedding Scripts library. In this case javascript is used for Image Uploader embedding. Please read the following article:

Inserting Image Uploader into Web Page

I hope it helps you.

I am trying to do the same thing in Image Uploader 7. I am not sure which version this reply was for, but neither of these properties appear to be visible in the version I am using. I have searched in object browser for:

Code:

ScriptDirectory
IUEmbedScriptUseCustomCodeBase

and

RegisterClientScripts (which is said to be the replacement in the 6->7 change log)

Any help is appreciated!

p.shirykalova  
#4 Posted : Monday, July 30, 2012 11:00:59 PM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Hi Chuck,

Could you please describe your task in more details? What exactly you need to do?

Best regards,

Pauline Shirykalova

Aurigma Technical Support

chuck  
#5 Posted : Tuesday, July 31, 2012 11:46:52 PM(UTC)
chuck

Rank: Newbie

Groups: Member
Joined: 7/24/2012(UTC)
Posts: 2

I need to suppress the generation of the script tag that includes script from WebResource.axd. The version of the control we're using (7.0.15) attempts to create/load an ActiveX object that has been blocked in the registry. We have a newer loader script, but the client attempts to load both. I was hoping that by loading the external loader script that any script included in the Axd would be ignored since the loader is already defined, but I guess not.
p.shirykalova  
#6 Posted : Wednesday, August 1, 2012 1:55:25 AM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Hi Chuck,

Please download Image Uploader 7.0.28 DLL from our site.

Please use DLL version 7.0.28 and JAR and CAB files from your private label (7.0.21). This combination should work (it works for us, we tested it locally).

I also would like to ask. Could you please post your problem description in a separate support ticket so we can easily correlate the problem with your previous tickets. Thank you for your understanding.

Best regards,

Pauline Shirykalova

Aurigma Technical Support

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.