Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
pikatxu  
#1 Posted : Saturday, October 17, 2009 8:07:26 PM(UTC)
pikatxu

Rank: Newbie

Groups: Member
Joined: 10/17/2009(UTC)
Posts: 7

Hello, I am testing this nice application, but with the opcion Php Library doesn't work. This show me this error (with Firefox doesn't show this error, but doesn' work too):

http://geriatrics.brinkster.net/images/imageuploader.jpg

I have tried with the sample example and it give me the same:

http://geriatrics.brinkster.net..._Library/OpenFileDialog/

and the example on documentation too:

http://geriatrics.brinkster.net...sidencia/editar/test.php

I don't know because it doesn't work. I've upload all file and the path "require_once "ImageUploaderPHP/ImageUploader.class.php";" is right.

I have tested with PHP_IUEmbed and it is working, but I'd rather work with Php Library if it is posible. The server has Windows 2003 IIS 6 and Php 5.

Thank's

Dmitry  
#2 Posted : Sunday, October 18, 2009 1:37:31 AM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello,

Have you initialized setScriptsDirectory property? I see in your script absolute paths to script files, ImageUploader6.cab and ImageUploader6.jar files that point to your local disk (C:/Sites/premium4/geriatrics/webroot/residencia/editar/ImageUploaderPHP/Scripts/...). It is not correct, you should specify relative path to your site to allow client computers to download required files.

Edited by user Sunday, October 18, 2009 1:38:24 AM(UTC)  | Reason: Not specified

Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

pikatxu  
#3 Posted : Sunday, October 18, 2009 7:19:24 PM(UTC)
pikatxu

Rank: Newbie

Groups: Member
Joined: 10/17/2009(UTC)
Posts: 7

Hello Dmitry,

Thank's for your answer, you have a reason, I hadn't initialized setScriptDirectory. I've copied the folder "Scripts" in the same location of "ImageUploaderPHP" and put the line "$iu->setScriptsDirectory("Scripts");" down of setLicenseKey.

But I don't know what are I doing bad, because the sample of documentation is working:

http://geriatrics.brinkster.net...sidencia/editar/test.php

but the sample of PHPLibrary (ImageUploaderPHP) doesn't work :(

http://geriatrics.brinkster.net...idencia/editar/index.php

I have the same setScriptsDirectory in both.

Thank's and sorry for my doubts

Dmitry  
#4 Posted : Monday, October 19, 2009 2:55:59 AM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello,

It is not a big problem.

Please, specify ScriptsDirectory for ShellComboBox too.

Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

pikatxu  
#5 Posted : Monday, October 19, 2009 10:23:47 PM(UTC)
pikatxu

Rank: Newbie

Groups: Member
Joined: 10/17/2009(UTC)
Posts: 7

Thank's I've iniatiliziated directoy script by ShellComboBox. It works!

It wasn't a big problem, my brain is a big problem Brick wall

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.