Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Chris Herrington  
#1 Posted : Saturday, April 18, 2009 8:57:34 AM(UTC)
Chris Herrington

Rank: Advanced Member

Groups: Member
Joined: 9/6/2005(UTC)
Posts: 106

Dmitry,

I am sending you two projects both are in 2008 VS. The c1Test will not work when I deploy it to a customer site.

The c1Test website works as expected and it is 4.5. I need to get this resolved as soon as possible please let me know.

Thanks

Chris

File Attachment(s):
Projects.zip (10,791kb) downloaded 7 time(s).
Dmitry  
#2 Posted : Sunday, April 19, 2009 2:44:50 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello Chris,

Could you explain what exact problem do you experience?

Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

Chris Herrington  
#3 Posted : Sunday, April 26, 2009 9:31:24 PM(UTC)
Chris Herrington

Rank: Advanced Member

Groups: Member
Joined: 9/6/2005(UTC)
Posts: 106

the 4.5 project will deploy just fine the other project gives me a runtime error
Tamila  
#4 Posted : Monday, April 27, 2009 2:25:07 PM(UTC)
Tamila

Rank: Advanced Member

Groups:
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Chris,

I just tried to compile your projects, but everything worked well.

Please provide me with screenshot of your error; it will be very helpful for me.

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

Chris Herrington  
#5 Posted : Monday, April 27, 2009 11:18:14 PM(UTC)
Chris Herrington

Rank: Advanced Member

Groups: Member
Joined: 9/6/2005(UTC)
Posts: 106

ok........

Here goes. These projects work great in development all day long. When you depoly them i.e Publish them to a webserver that is where it goes all wrong. I have sent many screen shots of the error I get. If you can do this set up a win xp box with iis on it then deploy these apps. You will see what I am talking about.

Thanks

Chris

Chris Herrington  
#6 Posted : Tuesday, April 28, 2009 8:46:16 AM(UTC)
Chris Herrington

Rank: Advanced Member

Groups: Member
Joined: 9/6/2005(UTC)
Posts: 106

When I publish the 5.1 this is what I get

Server Error in '/' Application.

--------------------------------------------------------------------------------

This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[COMException (0x800736b1): This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)]

[FileLoadException: Could not load file or assembly 'Aurigma.GraphicsMill, Version=5.1.266.0, Culture=neutral, PublicKeyToken=af7154c50c505858' or one of its dependencies. This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)]

System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0

System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +43

System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +127

System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +142

System.Reflection.Assembly.Load(String assemblyString) +28

System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +46

[ConfigurationErrorsException: Could not load file or assembly 'Aurigma.GraphicsMill, Version=5.1.266.0, Culture=neutral, PublicKeyToken=af7154c50c505858' or one of its dependencies. This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)]

System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +613

System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +203

System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +105

System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +178

System.Web.Compilation.WebDirectoryBatchCompiler..ctor(VirtualDirectory vdir) +163

System.Web.Compilation.BuildManager.BatchCompileWebDirectoryInternal(VirtualDirectory vdir, Boolean ignoreErrors) +53

System.Web.Compilation.BuildManager.BatchCompileWebDirectory(VirtualDirectory vdir, VirtualPath virtualDir, Boolean ignoreErrors) +175

System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath) +83

System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +261

System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +101

System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +126

System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +62

System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +33

System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +40

System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig) +160

System.Web.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +93

System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +155

--------------------------------------------------------------------------------

Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053

Tamila  
#7 Posted : Tuesday, April 28, 2009 1:47:00 PM(UTC)
Tamila

Rank: Advanced Member

Groups:
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Chris,

Thank you for the stack trace. It is a known problem. How to resolve it you can read here:

INFO: Could not load file or assembly Aurigma.GraphicsMill problem

NOTE: do not install both Redistributable Packages for x86 and x64 at once, just one of them. Installation process of DLLs is the same.

Edited by user Tuesday, April 28, 2009 1:48:14 PM(UTC)  | Reason: Not specified

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

Chris Herrington  
#8 Posted : Tuesday, April 28, 2009 8:37:55 PM(UTC)
Chris Herrington

Rank: Advanced Member

Groups: Member
Joined: 9/6/2005(UTC)
Posts: 106

I did what you suggested about the C++ now I get this message....

Server Error in '/' Application.

--------------------------------------------------------------------------------

This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[COMException (0x800736b1): This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)]

[FileLoadException: Could not load file or assembly 'Aurigma.GraphicsMill, Version=5.1.266.0, Culture=neutral, PublicKeyToken=af7154c50c505858' or one of its dependencies. This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)]

System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0

System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +43

System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +127

System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +142

System.Reflection.Assembly.Load(String assemblyString) +28

System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +46

[ConfigurationErrorsException: Could not load file or assembly 'Aurigma.GraphicsMill, Version=5.1.266.0, Culture=neutral, PublicKeyToken=af7154c50c505858' or one of its dependencies. This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)]

System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +613

System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +203

System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +105

System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +178

System.Web.Compilation.WebDirectoryBatchCompiler..ctor(VirtualDirectory vdir) +163

System.Web.Compilation.BuildManager.BatchCompileWebDirectoryInternal(VirtualDirectory vdir, Boolean ignoreErrors) +53

System.Web.Compilation.BuildManager.BatchCompileWebDirectory(VirtualDirectory vdir, VirtualPath virtualDir, Boolean ignoreErrors) +175

System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath) +83

System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +261

System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +101

System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +126

System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +62

System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +33

System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +40

System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig) +160

System.Web.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +93

System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +155

--------------------------------------------------------------------------------

Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053

Chris Herrington  
#9 Posted : Tuesday, April 28, 2009 8:57:18 PM(UTC)
Chris Herrington

Rank: Advanced Member

Groups: Member
Joined: 9/6/2005(UTC)
Posts: 106

Does not tell you that it requires a reboot but it does. That stack trace is gone now a new error.

The image will not load into the viewer. No error message just will not load. I am using an inpersonate to unc path on another computer this works great in 4.5 an earlier. Is there something that has changed that will not allow me to do this. The other thing is that I did not add the key for the relative file path private and public. I did not have to do this in 4.5. Any ideas?

Thanks

Chris

Tamila  
#10 Posted : Wednesday, April 29, 2009 6:27:21 PM(UTC)
Tamila

Rank: Advanced Member

Groups:
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hmm... it is a very strange behavior. Please try to run our sample web application. You can download it here:

Web Demos Bundle

If you have any problems with samples please let us know.

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

Chris Herrington  
#11 Posted : Wednesday, April 29, 2009 9:13:47 PM(UTC)
Chris Herrington

Rank: Advanced Member

Groups: Member
Joined: 9/6/2005(UTC)
Posts: 106

It is fixed!!!!!!!!!!!!!!!!!!!!!!! Now for my solution. I have been using GM since the time of initial development. I have been through many upgrades over the years. I have tons of error handling in my software. The way the new product is licensed caused me all of my real problems. I had been doing the licensing the same since version 3. I was not aware that I was not able to license it the same way I had in the past. The error handeling in my software prevented me from seeing these license errors. The older product would put a watermark on the image saying evaluation. The new product sends an alert but if you have error handeling in your software you will never see this message. It worked great on my development machine but when it was deoployed it did not work. I am just glad it is fixed. I only have one issue left and that is the AJAX control takes over the form I have posted a sample in the forum I just need someone to take a look at it.

Thanks

Chris

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.