Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
robelind  
#1 Posted : Monday, January 12, 2009 7:48:26 PM(UTC)
robelind

Rank: Newbie

Groups: Member
Joined: 1/8/2009(UTC)
Posts: 6

I'm having a problem with the BitmapViewer not showing the image.
I've narrowed the problem down to that the temporary aspx-file that the control uses is never created.
My scenario is that the web site is developed using a content management system and this seems to somehow prevent the BitmapViewer from creating the temporary aspx-file.
If I use the control in a standalone web site project everything works fine.

What can cause the BitmapViewer to fail to create the temporary aspx-file and how can I investigate it?
Tamila  
#2 Posted : Tuesday, January 13, 2009 5:55:25 PM(UTC)
Tamila

Rank: Advanced Member

Groups:
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hello,

Most likely you have this problem because of incorrect configuration of cache folder. How to do it you can read in these articles:
Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!
robelind  
#3 Posted : Tuesday, January 13, 2009 11:27:27 PM(UTC)
robelind

Rank: Newbie

Groups: Member
Joined: 1/8/2009(UTC)
Posts: 6

Hi.

No, I don't think it is an issue with the cache directory.
I do get images in the cache directory, it is the aspx-page which (I assume) should fetch the images from the cache folder that is missing.
And as I said, if I use the control in a stand-alone web project it works fine. Without any cache directory configuration.
Dmitry  
#4 Posted : Wednesday, January 14, 2009 12:22:29 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello,

Could you give the exact error message you get?
Sincerely yours,
Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!
robelind  
#5 Posted : Wednesday, January 14, 2009 4:59:56 PM(UTC)
robelind

Rank: Newbie

Groups: Member
Joined: 1/8/2009(UTC)
Posts: 6

I don't get any error message at all. All I get is a red 'X' on the web page where the image should've been displayed.
If I view the properties of the image on the web page, its URL is eg "http://localhost:1889/10B0C129D18B403395AC9927FCCD777B.aspx?id=c7cd0573-725f-4ad1-8e4e-ab6f22af2124.jpg". The "10B0C129D18B403395AC9927FCCD777B.aspx" file cannot be found amongst the temporary asp.net-files for the web site, which is the case if I use the bitmap viewer in a standalone web project.
Tamila  
#6 Posted : Wednesday, January 14, 2009 9:12:55 PM(UTC)
Tamila

Rank: Advanced Member

Groups:
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hello,

I think that you have the same problem like described in this article.

Edited by user Thursday, January 15, 2009 12:35:33 PM(UTC)  | Reason: Not specified

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!
robelind  
#7 Posted : Wednesday, January 14, 2009 10:39:32 PM(UTC)
robelind

Rank: Newbie

Groups: Member
Joined: 1/8/2009(UTC)
Posts: 6

Yes, configuring the cache directory did solve the problem. Without configuring, the cache directory was automatically created under the "App_Data" folder, which didn't work as previously described.
When configuring like:
<Aurigma.GraphicsMill.WebControls>
<add key="RelativePrivateCachePath" value="/GraphicsMillCache/Public" />
<add key="RelativePublicCachePath" value="/GraphicsMillCache/Private" />
</Aurigma.GraphicsMill.WebControls>
it works.
However, all files are stored in the "GraphicsMillCache" directory, i.e. the root directory, and nothing in either "Public" or "Private".
Dmitry  
#8 Posted : Sunday, January 18, 2009 6:17:33 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Try to add "/" to the path:
Code:

<Aurigma.GraphicsMill.WebControls>
  <add key="RelativePrivateCachePath" value="/GraphicsMillCache/Public/" />
  <add key="RelativePublicCachePath" value="/GraphicsMillCache/Private/" />
</Aurigma.GraphicsMill.WebControls>
Sincerely yours,
Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.