Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Andy Liao  
#1 Posted : Friday, July 25, 2008 8:05:22 PM(UTC)
Andy Liao

Rank: Newbie

Groups: Member
Joined: 7/25/2008(UTC)
Posts: 3

Hi,

We're trying to migrate an applicaiton coded with GraphicsMill 4.0 .net 2.0 to a new server running IIS7 on Windows Server 2008 x64. So far we have done following but still can't get even the incuded demo app to run..

1. Set managed pipeline to Classic

2. Enabled 32bit app

3. Installed .net 1.1 and sp1

4. Put msvcr71.dll in c:\windows\system32 and c:\windows\sysWOW64

After all these.. still getting this message... could someone give me a pointer on what to do? it is very much appreciated for any feedback... thanks!..

FileNotFoundException: The specified module could not be found. (Exception from HRESULT: 0x8007007E)]

System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0

System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +54

System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +211

System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +141

System.Reflection.Assembly.Load(String assemblyString) +25

System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +32

[ConfigurationErrorsException: The specified module could not be found. (Exception from HRESULT: 0x8007007E)]

System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +596

System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +211

System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +46

System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +177

System.Web.Compilation.WebDirectoryBatchCompiler..ctor(VirtualDirectory vdir) +267

System.Web.Compilation.BuildManager.BatchCompileWebDirectoryInternal(VirtualDirectory vdir, Boolean ignoreErrors) +39

System.Web.Compilation.BuildManager.BatchCompileWebDirectory(VirtualDirectory vdir, VirtualPath virtualDir, Boolean ignoreErrors) +429

System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath) +75

System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +582

System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +93

System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +111

System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +54

System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +31

System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +40

System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig) +139

System.Web.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +128

System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +161

Edited by user Saturday, July 26, 2008 12:52:36 AM(UTC)  | Reason: Not specified

Dmitry  
#2 Posted : Sunday, July 27, 2008 4:29:21 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello,

Here is the post HOWTO: Run Graphics Mill on x64 workstations describing how to use Graphics Mill 4.x on x64 paltforms. Please, follow these steps and let me know whether it helps.

Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

Andy Liao  
#3 Posted : Sunday, July 27, 2008 7:09:53 PM(UTC)
Andy Liao

Rank: Newbie

Groups: Member
Joined: 7/25/2008(UTC)
Posts: 3

Hi Dimitry,

I actually read that doc and many others on this forum, but pretty much all failed. We're running IIS7, so things are also a bit different.

1. Application pool is set to run 32bit app.

2. We had placed msvcr71.dll in both System32 and SysWOW64

3. 2.0 .Net's aspnet_regiis wouldn't run, claiming no IIS is installed. I assume this is because we're running IIS7.

Unfortunately, we're still stuck at this prolbem...

Dmitry  
#4 Posted : Monday, July 28, 2008 9:36:35 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello,

Thank you for your report, we will answer on this problem n several days.

Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

Dmitry  
#5 Posted : Wednesday, July 30, 2008 6:59:44 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello,

It is strange. I tested Graphics Mill 4.5 here in the office and it works okay. I did the following:

  1. Installed Windows Server 2008 x64 Web Edition from scratch;

  2. Installed IIS7 + APS.NET + IIS6 management compartibility (see the screenshot);

  3. Installed Graphics Mill 4.5 for .NET 2.0;

  4. Installed ASP.NET 2.0 AJAX Extensions 1.0;

  5. Deployed web sample GraphicsMillAjaxVB (Program Files(x86)\Aurigma\Graphics Mill 4.5 for .NET 2.0\Web Demos Source Code\GraphicsMillAjaxVB);

  6. Opened several Aurigma demos, e.g. Tiff Viewer;

It works… Could you deploy our web samples to your server and try to open them? It would be better if you walk through the steps I described (maybe except of installing clear Windows).

Edited by user Wednesday, July 30, 2008 7:01:49 PM(UTC)  | Reason: Not specified

Dmitry attached the following image(s):
Windows2008.jpg
Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

Andy Liao  
#6 Posted : Thursday, July 31, 2008 9:07:12 AM(UTC)
Andy Liao

Rank: Newbie

Groups: Member
Joined: 7/25/2008(UTC)
Posts: 3

Hi Dimitry,

Unfortunately we don't have GraphicMills 4.5, all we have is 4.0. Our IIS indeed installed IIS6 management compatibility. With GraphicMills 4.0 install file, it will insert sample code virtual directory under IIS. Unfortunately, those demo doesn't work either.

Dmitry  
#7 Posted : Thursday, July 31, 2008 6:44:37 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello Andy,

I reproduced the problem with version 4.0 on Windows 2008. To resolve it you need to upgrade to version 4.1.11. I sent you the links to download it via PM.

Edited by user Thursday, July 31, 2008 8:55:16 PM(UTC)  | Reason: Not specified

Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.