Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
marcvaz  
#1 Posted : Wednesday, April 30, 2008 2:37:40 AM(UTC)
marcvaz

Rank: Newbie

Groups: Member
Joined: 4/30/2008(UTC)
Posts: 3

Today we installed Visual Studio 2008 and build a test website using Graphics Mill and it seems that Graphics Mill for .NET 2 is not supported by .NET 2.0 SP1 framework. As soon as we give reference of Graphics Mill. All other code stopped working.

Anybody faced this? Or Can Aurigma People help me.
cpav  
#2 Posted : Wednesday, April 30, 2008 3:21:15 AM(UTC)
cpav

Rank: Advanced Member

Groups: Member
Joined: 12/17/2007(UTC)
Posts: 49

Hi marcvaz,
well if you try to download the trial version you will see
"Graphics Mill for .NET (evaluation version, .NET 2.0) "
That means no SP1 for .NET 2.0, so i guess is not supported, i mean if it was supported i would expect it to be written like "Graphics Mill for .NET (evaluation version, .NET 2.0 SP1)".

But since i am not from Aurigma but just one client/user, i guess you have to wait little bit for more accurate reply from someone from Aurigma!
Alex Kon  
#3 Posted : Wednesday, April 30, 2008 9:28:16 PM(UTC)
Alex Kon

Rank: Advanced Member

Groups: Member
Joined: 1/31/2005(UTC)
Posts: 458

Was thanked: 5 time(s) in 5 post(s)
Hello,

We have only one distributive for .NET Framework 2.0, with no division between SP1 and not SP1 versions.

marcvaz, could you provide us with more detailed information about the error? At least the following points:
  • Which OS do you use?
  • Which version of IIS do you use?
  • Are there any error messages or exceptions and so on?
  • Have you tried to work with Graphics Mill for .NET before? Or it is your first attempt?

    We have SP1 for .NET Framework 2.0 installed on our development machines and we never met such errors before. So it is very important error-report for us know - I will be looking forward for your answer.
  • Edited by user Wednesday, April 30, 2008 9:29:34 PM(UTC)  | Reason: Not specified

    marcvaz  
    #4 Posted : Thursday, May 1, 2008 2:04:04 AM(UTC)
    marcvaz

    Rank: Newbie

    Groups: Member
    Joined: 4/30/2008(UTC)
    Posts: 3

    Hello Alex,

    I have checked that there was only .NET Framework 2.0. We are not using trial version. We have purchased this component. And we are using this component from long time on one site and it was working perfectly. But now when we are upgrading the site to support .NET 2.0 SP1 framework its causing issues. Here are answers to your questions.

    Which OS do you use?
    Windows Server 2008 / Vista

    Which version of IIS do you use?
    IIS 7

    Are there any error messages or exceptions and so on?
    Well as soon as I give reference to Aurigma DLL in Visual Studio 2008. A lot of other code start shows error. Although I have find out what is the problem causing it to run it in Visual Studio 2008. But I am not 100% sure about this. But if you can give it a shot in VS2008 you will know that this might be the issue.

    It seems that Aurrigma DLL has taken a reference of "Namespace System" directly. Because if I remove the reference of Aurigma DLL and define namespaces in my programme as Imports System. It shows the same errors as I get when give reference to Aurigma DLL. Perhaps the VS2008 does not want to take SYSTEM namespace completely in any of the code. So if you can check that this is the issue than it might be any easy solution to work Graphics MILL with .NET 2.0 SP1

    Have you tried to work with Graphics Mill for .NET before? Or it is your first attempt?
    As mentioned above we were using Graphics Mill for .NET 1.1 before then we have upgraded it to 2.0 also. Never faced problem before.

    Thanks in advance.

    Alex Kon  
    #5 Posted : Thursday, May 1, 2008 6:08:05 PM(UTC)
    Alex Kon

    Rank: Advanced Member

    Groups: Member
    Joined: 1/31/2005(UTC)
    Posts: 458

    Was thanked: 5 time(s) in 5 post(s)
    Hello marcvaz,

    I am totaly confused - I have Vista and VS2008 installed on my development machine along with .NET Framework 3.0 (2.0 SP1 is prerequisite for 3.0) and never experienced such issues.

    As for System namespace - I am pretty sure that it is not the real reason - it will be senseless to deny using basic .NET namespace in .NET application.

    Please, could you check this points:
  • Will you get the same error even if you create new "hello world" web-app and add "Imports System"?
  • Will you get the same error with "Hello world" app which references to Graphics Mill for .NET assembly?
  • If everything works correctly in previous 2 cases - please, could you track what action introduces the error?
  • Is it possible to reproduce the same issue on Visual Studio ASP.NET development server (by running debug in Web application)?
  • Please, check standart Web samples which were installed with Graphics Mill for .NET. Do they work correctly?

    And one more. Could you submit case with simplest sample which reproduces the issue? I will try to test it in out environment.
  • Edited by user Thursday, May 22, 2008 2:47:55 PM(UTC)  | Reason: Not specified

    marcvaz  
    #6 Posted : Thursday, May 1, 2008 7:11:03 PM(UTC)
    marcvaz

    Rank: Newbie

    Groups: Member
    Joined: 4/30/2008(UTC)
    Posts: 3

    Hello Alex

    Please ignore my previous post. I think I have found the solution. It seems that when you do a fresh install of .net framework 2.0 sp1 or 3.0. Aurigma Mill doesn't work. To run Aurigma you have to put msvcr71.dll into windows/system32 folder (which is a part of .net framework 1.1 i guess). Aurigma Graphics Mill is taking reference of this DLL somehow in .net 2.0 also. Anyways I put this file in windows system32 folder. And it started perfectly.

    Thanks and Sorry for creating mess in forums.
    Alex Kon  
    #7 Posted : Friday, May 2, 2008 5:14:11 PM(UTC)
    Alex Kon

    Rank: Advanced Member

    Groups: Member
    Joined: 1/31/2005(UTC)
    Posts: 458

    Was thanked: 5 time(s) in 5 post(s)
    Hello,

    Oh, yes, I forgot to mention this dll too.

    Anyway feel free to post here any questions regarding to Graphics Mill for .NET.
    Users browsing this topic
    Forum Jump  
    You cannot post new topics in this forum.
    You cannot reply to topics in this forum.
    You cannot delete your posts in this forum.
    You cannot edit your posts in this forum.
    You cannot create polls in this forum.
    You cannot vote in polls in this forum.