Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Dmitry  
#1 Posted : Friday, February 1, 2008 2:41:01 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Description

Suppose you develop web application for ASP.NET 2.0 using Aurigma Graphics Mill 4.5 (or earlier) and AJAX or Web Controls for .NET Framework 2.0. You can notice that BitmapViewer control displays images correctly under ASP.NET Development Server on your developer machine. But when you publish your site from Visual Studio with pre-compilation (open your project in Visual Studio 2005, click Build menu, and choose Publish Web Site) BitmapViewer control does not display images on your production site.

Solution

We are working on this problem the update will be available with the next release. To solve the problem with Graphics Mill 4.5 you should set the private and the public cache up.

Web Controls

To set the image cache up, you should use Aurigma.GraphicsMill.WebControls section of the web.config file of your application. To do it, declare this section in the configSection tag. After that you should insert the Aurigma.GraphicsMill.WebControls section and put necessary keys as described further. As a result, the web.config should be looking like that:

Code:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  
  <configSections>
    <section name="Aurigma.GraphicsMill.WebControls" 
      type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
  </configSections>
      
  <system.web>

    <!--  
    ...
    other settings
    ...
    -->
  
  </system.web>

  <Aurigma.GraphicsMill.WebControls>

    <!--  
    ...
    Settings of web controls including cache options
    ...
    -->

  </Aurigma.GraphicsMill.WebControls>
  
</configuration>

To specify the path to the public and private cache use the following keys:

1. RelativePublicCachePath - URL to the public cache folder.

2. RelativePrivateCachePath[ - URL to the private cache folder.

These URLs should be specified relatively the site root and begin from the forward slash character (/).

Also, if you do not want to have the private cache inside the site root, and prefer to specify physical path, use the AbsolutePrivateCachePath key. However you cannot specify absolute path for the public cache, because it is sent to browser, and therefore should point to some folder inside your web site. If you specified relative path to the private cache, you should not use absolute path, and vice versa. Here is an example of these keys usage:

Code:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  
  <configSections>
    <section name="Aurigma.GraphicsMill.WebControls" 
      type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
  </configSections>
      
  <system.web>

    <!--  
    ...
    -->
  
  </system.web>

  <Aurigma.GraphicsMill.WebControls>
    <add key="RelativePrivateCachePath" value="/WebSite/PublicTemp/" />
    <add key="RelativePublicCachePath" value="/WebSite/PrivateTemp/" />    
  </Aurigma.GraphicsMill.WebControls>
  
</configuration>

Do not forget to set up proper permissions for these folders. Both of them should have modified permission for the user the ASP.NET process is running under. On Windows NT/2000/XP this is typically an internet user (IUSR_<machinename>) and ASPNET account. On Windows 2003 grant modify permission to NETWORK SERVICE group.

AJAX Controls

To set the image cache up, you should use Aurigma.GraphicsMill.AjaxControls section of the web.config file of your application. To do it, declare this section in the configSection tag. After that you should insert the Aurigma.GraphicsMill.AjaxControls section and put necessary keys as described further. As a result, the web.config should be looking like that:

Code:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  
  <configSections>
    <section name="Aurigma.GraphicsMill.AjaxControls" 
    type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
  </configSections>
      
  <system.web>

    <!--  
    ...
    other settings
    ...
    -->
  
  </system.web>

  <Aurigma.GraphicsMill.AjaxControls>

    <!--  
    ...
    Settings of web controls including cache options
    ...
    -->

  </Aurigma.GraphicsMill.AjaxControls>
  
</configuration>

To specify the path to the public and private cache use the following keys:

1. RelativePublicCachePath - URL to the public cache folder.

2. RelativePrivateCachePath - URL to the private cache folder.

These URLs should be specified relatively the site root and begin from the forward slash character (/).

Also, if you do not want to have the private cache inside the site root, and prefer to specify physical path, use the AbsolutePrivateCachePath key. However you cannot specify absolute path for the public cache, because it is sent to browser, and therefore should point to some folder inside your web site. If you specified relative path to the private cache, you should not use absolute path, and vice versa. Here is an example of these keys usage:

Code:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  
  <configSections>
    <section name="Aurigma.GraphicsMill.AjaxControls" 
    type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
  </configSections>
      
  <system.web>

    <!--  
    ...
    -->
  
  </system.web>

  <Aurigma.GraphicsMill.AjaxControls>
    <add key="RelativePrivateCachePath" value="/WebSite/PrivateCache/" />
    <add key="RelativePublicCachePath" value="/ WebSite/PublicCache/" />    
  </Aurigma.GraphicsMill.AjaxControls>
  
</configuration>

Do not forget to set up proper permissions for these folders. Both of them should have modified permission for the user the ASP.NET process is running under. On Windows NT/2000/XP this is typically an internet user (IUSR_<machinename>) and ASPNET account. On Windows 2003 grant modify permission to NETWORK SERVICE group.

Edited by moderator Sunday, June 10, 2012 9:05:51 PM(UTC)  | Reason: Not specified

Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.