Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Fedor  
#1 Posted : Tuesday, November 14, 2006 6:05:00 AM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,550

Thanks: 5 times
Was thanked: 59 time(s) in 58 post(s)
This article describes how to resolve a problem when Web server settings do now allow loading DLLs with unmanaged code due to security restrictions.

Description

After copying the Aurigma.GraphicsMill.dll to a destination folder and running a Web application that uses this library, the following error may appear:

Code:
Access is denied: 'Aurigma.GraphicsMill'.


Reason

This problem arises because the use of unmanaged code is disabled on the Web server by default. Core library of Graphics Mill is based on portions of unmanaged code, and therefore ASP.NET refuses to load it.

Solution
  1. Open the web.config file of your application.
  2. Find a <system.web> element in it.
  3. Add the following inside the <system.web> element:
    Code:
    <trust level="Full" />
However, this may not work, if the Web server administrator does not allow overriding of security settings. This is a typical scenario for hosted environment.

If you have an access to this server, and want to get Graphics Mill to work, you can allow to increase the trust level of your application. You can do it as follows:
  1. Open the machine.config file which is located in the %WINDIR%\Microsoft.NET\Framework\%FRAMEWORK_VERSION%\Config folder (for example, C:\Windows\Microsoft.NET\Framework\v1.1.4322\Config\machine.config).
  2. Find a <configuration> element in it.
  3. Add the following inside the <configuration> element:

    Code:
    <location path="Your Web site/Your application" allowOverride="true">
      <system.web>
        <trust level="Full" />
      </system.web>
    </location>

    Make sure you have inserted this code before the <location> element without a path attribute (this one contains overall settings).
If you have no permissions to administer the Web server you use, you need to contact your Web server administrator and ask him to carry out these steps for your application.

Edited by moderator Sunday, June 10, 2012 9:08:10 PM(UTC)  | Reason: Not specified

Best regards,
Fedor Skvortsov
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.