Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
philduhs  
#1 Posted : Wednesday, March 14, 2007 2:40:27 PM(UTC)
philduhs

Rank: Member

Groups: Member
Joined: 1/21/2007(UTC)
Posts: 6

I have implemented a Multiple Descriptions mode page but get the following error when using it in IE:

Line 42
Char 2
Error: 'o' is null or not an object
Code: 0

I have looked at what the values are in the JavaScript as it is running and the problem appears to be in the _createExpandoMethods(id) method in the iuembed.js file. If I put an alert(id) as the first line in this method it displays "ImageUploader" when the image uploader is loading - this is the name that I have given to my imageUploader instance and this is fine.

If I then select a photo and click the "Add" button the alert displays "Thumbnail0". I click OK and then I get the error described above. I click OK to make it go away and I get another alert displaying the same "Thumbnail0" again. I click "OK" and things seem to work fine - the thumbnail displays in my bottom pane and I can keep working.

Looking at the code I see that the first statement in the _createExpandoMethods(id) method (other than the alert(id) which I added) is to get a reference to document.getElementById(id) and the first time "Thumbnail0" is appearing this reference is null - which is why an error is generated further down the code. The second time "Thumbnail0" is displayed there is a valid object reference returned by the getElementByID...

Any suggestions as to what might be causing this? I have tried to look carefully at the sample page from your site to see anything that might be causing this and there's nothing obvious. I have even copied the source of that demo page (which doesn't come up with any such error) and the copied source running off my server has the same error.

All help appreciated.

Rgds,
Phil
Alex Makhov  
#2 Posted : Thursday, March 15, 2007 2:58:04 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello Phil,

The was such kind of error in one of the previous releases. You should get the last Image Uploader installation package from our site, install it and get the iuembed.js file from it. The new iuembed.js does not have such problem.
Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.