Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
scarabee  
#1 Posted : Monday, January 22, 2007 7:23:43 PM(UTC)
scarabee

Rank: Member

Groups: Member
Joined: 7/10/2006(UTC)
Posts: 18

Hi

We have a serious problem with version 4.1 we upgraded from version 4.0 because of the Vista support in 4.1, but we cant upload large files ( >100 MB ), but if I reinstall version 4.0 it works great??

Getting the message: Upload interrupted or Some exception occured.

Alex Makhov  
#2 Posted : Thursday, January 25, 2007 2:50:27 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups:
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

Sorry for the ling delay, it took us a long time to test the problem.

We have reproduced the specified problem. The reason is that there is an inner TimeOut value (about one minute) in WinInet which does not allow making large file amount uploads. We have successfully uploaded about 500 Mbytes but not more. That is a serious problem which will take us a lot of time to fix so by now use the version 4.0 and we will write you as soon as the bug to be fixed.
Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
Alex Makhov  
#3 Posted : Sunday, January 28, 2007 1:27:48 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups:
Joined: 8/3/2003(UTC)
Posts: 998

We have tested more and have few notes:
1) PHP samples work great if configuration of php.ini file is correct.
2) There are problems when uploading using ASP.NET 1.1 upload processing scripts. When aspnet_wp.exe process commits too much memory it is automatically closed so there is no ability to upload large amounts of data.
3) ASP.NET 2.0 upload processing mechanism looks to be smarter. It does non commit too much memory so it is possible to upload large amounts of data. We have successfully uploaded 700Mb and 800Mb files.

So use ASP.NET 2.0 to process large uploads.
If you still have such kind of problems or use another upload processing platform please send us the information about your operating system, upload processing platform, file sizes, upload processing scripts and Web-server name and we will check it.
Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
scarabee  
#4 Posted : Monday, January 29, 2007 5:20:25 PM(UTC)
scarabee

Rank: Member

Groups: Member
Joined: 7/10/2006(UTC)
Posts: 18

Hi, thank you for your reply!

We are using PHP, and I think the configuration is correct, do you have an example working configuration?

Since it is working great in ASP.NET 2.0, can we make the upload script i ASP.NET 2.0 and the redirect script in PHP is there any problems with that? We are running on a windows server so ASP.NET 2.0 should not be a problem, but do the image uploader support this? And do you think that could be a good solution?
Alex Makhov  
#5 Posted : Monday, January 29, 2007 6:34:53 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups:
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

I think it is not a good idea. Check carefully if the php.ini file configuration is correct. I think the reason of the problem is there.
Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
scarabee  
#6 Posted : Monday, January 29, 2007 6:39:15 PM(UTC)
scarabee

Rank: Member

Groups: Member
Joined: 7/10/2006(UTC)
Posts: 18

Ok, are there any more than this settings in the php.ini file that need to be changed:

- post_max_size
- upload_max_filesize
- max_execution_time
- max_input_time
- memory_limit
Alex Makhov  
#7 Posted : Tuesday, January 30, 2007 12:53:18 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups:
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

Using PHP5 we have set the following field values:
Code:
; Whether to allow HTTP file uploads.
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
upload_tmp_dir = C:\PHP\uploadtemp  ; temporary directory for HTTP uploaded files (will use system default if not specified)

; Maximum allowed size for uploaded files.
upload_max_filesize = 900M
After that we have successfully uploaded 800Mb files several times. Also note that php.ini file was in C:/PHP directory, not in C:/Windows.

Edited by user Tuesday, December 18, 2007 5:13:04 PM(UTC)  | Reason: Not specified

Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.