Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Angeruzzi  
#1 Posted : Tuesday, January 16, 2007 1:41:00 AM(UTC)
Angeruzzi

Rank: Member

Groups: Member
Joined: 10/2/2005(UTC)
Posts: 6

Hi,

I'm transferring a website that has the PhotoEditor, and occurred a problem:

Code:
[IOException: The device is not ready.]
   System.IO.__Error.WinIOError(Int32 errorCode, String str) +723
   System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean useAsync, String msgPath, Boolean bFromProxy) +888
   System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access) +43
   Aurigma.GraphicsMill.Codecs.FormatReader._CheckForSupport(String fileName) +64
   Aurigma.GraphicsMill.Codecs.FormatReader.CheckForSupport(String fileName) +47
   Aurigma.GraphicsMill.Codecs.FormatManager.CreateFormatReader(String fileName) +135
   Aurigma.PhotoEditor.Editor.CalculateParameters()
   Aurigma.PhotoEditor.Editor.OnPreRender(EventArgs e)
   System.Web.UI.Control.PreRenderRecursiveInternal() +62
   System.Web.UI.Control.PreRenderRecursiveInternal() +125
   System.Web.UI.Control.PreRenderRecursiveInternal() +125
   System.Web.UI.Control.PreRenderRecursiveInternal() +125
   System.Web.UI.Control.PreRenderRecursiveInternal() +125
   System.Web.UI.Control.PreRenderRecursiveInternal() +125
   System.Web.UI.Page.ProcessRequestMain() +1545


What would be causing it ?

Edited by user Tuesday, December 18, 2007 5:30:10 PM(UTC)  | Reason: Not specified

Alessandro S. Angeruzzi
Depto. Tecnologia
Webroom Soluções Interativas
Andrew  
#2 Posted : Thursday, January 18, 2007 4:40:12 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 865

Thanks: 2 times
Was thanked: 25 time(s) in 25 post(s)
Hi Alessandro,

This problem may mean that you are trying to read a file from some drive which does not exist. For example, if you hardcoded a full file name like:

Code:
objBitmap.Load("D:\files\image.jpg")


but on new server all files are stored on drive C:\ (and drive D:\ does not exist on this server), this problem may occur.

So I would recommend to check out what path you are trying to pass to PhotoEditor/Graphics Mill.

Edited by user Tuesday, December 18, 2007 5:29:53 PM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.