Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Daf  
#1 Posted : Friday, February 27, 2015 10:06:47 AM(UTC)
Daf

Rank: Member

Groups: Member
Joined: 6/16/2009(UTC)
Posts: 16

Thanks: 1 times
Was on 8.0.33
Upgraded to 8.1.15
Web app in ASP.net 2.0

Not done anything other than replacing the DLL and licence key.
Looked as if it was just working - but I seem to be getting an issue.

Main items include:

Within the uploader:

Code:
		<ClientEvents>
		    <aur:ClientEvent EventName="BeforeUpload" HandlerName="ImageUploader1_BeforeUpload" />
		    <aur:ClientEvent EventName="AfterUpload" HandlerName="ImageUploader_AfterUpload" />
		    <aur:ClientEvent EventName ="Error" HandlerName="errorHandler" />
		</ClientEvents>



JavaScript on the page:

Code:
function ImageUploader_AfterUpload(Page)
{
    window.location = Page;
}



At the end of the ASP.Net
protected void ImageUploader1_AllFilesUploaded(object sender, Aurigma.ImageUploader.AllFilesUploadedEventArgs e)

Function:

Code:
        Response.ClearContent();
        Response.Write("/Admin/Uploader/Import.aspx"); //get ID's from session.
        Response.End();




However when it gets to the Response.Write line the Uploader hangs showing the generic "Aurigma upload suite encountered some problem" red bar error.

Has something changed 8.0 -> 8.1 with this functionality ?

Essentially I want to a page redirect.
Daf  
#2 Posted : Friday, February 27, 2015 10:11:21 AM(UTC)
Daf

Rank: Member

Groups: Member
Joined: 6/16/2009(UTC)
Posts: 16

Thanks: 1 times
Sodd's law - it's now working when I don't Debug via attaching the process!
Daf  
#3 Posted : Monday, March 2, 2015 3:21:09 AM(UTC)
Daf

Rank: Member

Groups: Member
Joined: 6/16/2009(UTC)
Posts: 16

Thanks: 1 times
But getting it to work in Debug would be good.
Using Visual Studio 2005
Java uploader
Andrew  
#4 Posted : Wednesday, March 4, 2015 3:22:16 AM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 870

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
Well, it would be good to see the actual server response. If you reproduce the problem with Java uploader, you can see it in a Java console log. Or you can use Fiddler tool to see it.

For example, for some reason it may return some other HTTP code instead of 200 in the debug mode. Or it throws some exception. Or probably there is a timeout problem.

BTW, if you need a redirect, why not to use the RedirectUrl param? Or the URL is generated on the server and cannot be created before the upload?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.