Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
khurram  
#1 Posted : Thursday, August 10, 2006 4:36:50 PM(UTC)
khurram

Rank: Member

Groups: Member
Joined: 8/10/2006(UTC)
Posts: 2

i have read the devmanul.pdf shipped with the licsense version of the photoeditor. i m developing in the local machine haveing iis installed and .net 2003.I have foloowed all the steps in the manual and when i run the code it gives me the folllowing error:
Code:
Value not found for key: PhotoEditor_DiscardAndExit 
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.Exception: Value not found for key: PhotoEditor_DiscardAndExit

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace: 


[Exception: Value not found for key: PhotoEditor_DiscardAndExit]
   Aurigma.PhotoEditor.Data.ResourceManager.GetString(String strKey) +121
   Aurigma.PhotoEditor.Editor.InitFixPanel() +207
   Aurigma.PhotoEditor.Editor.InitResources() +12
   Aurigma.PhotoEditor.Editor.OnPreRender(EventArgs e) +1714
   System.Web.UI.Control.PreRenderRecursiveInternal() +62
   System.Web.UI.Control.PreRenderRecursiveInternal() +125
   System.Web.UI.Control.PreRenderRecursiveInternal() +125
   System.Web.UI.Page.ProcessRequestMain() +1489
Like wise if i copy and paste the sample project it runs ok but when i save the edited files it does not save . accutaly we want this control on our client website i.e www.snaptotes.com . and have to save the files inthe images sectio reply soon

Edited by user Wednesday, December 19, 2007 2:48:10 PM(UTC)  | Reason: Not specified

Andrew  
#2 Posted : Sunday, August 20, 2006 1:42:31 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 866

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
If such error occur, make sure that the resource PhotoEditor_DiscardAndExit is available in the translation file (Languages\en-us\Resources.xml). It should be looking like:
Code:
Discard And Exit
PaulCowan  
#3 Posted : Tuesday, September 12, 2006 7:54:38 PM(UTC)
PaulCowan

Rank: Member

Groups: Member
Joined: 9/12/2006(UTC)
Posts: 1

Hi Im also having a deployment issue (I think)... I followed the instructions in the devmanual.pdf, and everything seemed to be going fine, I wasn't too sure about the publickeytoken values in the configsections for the web.config so I left them as null, (PublicKeyToken=null). When I ran the project I got an error, so I put the license key for graphics mill that we received from you guys as the public key token for graphics mill, and the project ran fine, but now when i try access the page with photoeditor in it I get the following error (we have bought photoeditor, but the only keys I have been given are for graphics mill and the red eye reduction add-on):
Code:
Configuration Error 
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: An error occurred creating the configuration section handler for Aurigma.PhotoEditor: Could not load file or assembly 'System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

Source Error: 


Line 10: 		<section name="dataConfiguration" type="Microsoft.Practices.EnterpriseLibrary.Data.Configuration.DatabaseSettings, Microsoft.Practices.EnterpriseLibrary.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null"/>
Line 11: 		<section name="Aurigma.GraphisMill.WebControls" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=MYGRAPHICSMILLKEYHERE"/>
Line 12: 		<section name="Aurigma.PhotoEditor" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=null"/>
Line 13: 	</configSections>
Line 14: 	<connectionStrings>
Please help. Thanks in advance. Paul

Edited by user Wednesday, December 19, 2007 2:49:16 PM(UTC)  | Reason: Not specified

Andrew  
#4 Posted : Monday, September 25, 2006 12:56:31 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 866

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
Paul, As far as our developers tell, they are communicating you regarding problems with PhotoEditor deployment. Feel free to submit case if anything is still wrong.

Edited by user Thursday, May 22, 2008 9:37:53 PM(UTC)  | Reason: Not specified

Users browsing this topic
Similar Topics
photo editor configuration and deployment issues (Discussions – Graphics Mill)
by khurram 8/10/2006 4:39:44 PM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.