Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Bob_J  
#1 Posted : Friday, July 28, 2006 4:27:08 AM(UTC)
Bob_J

Rank: Member

Groups: Member
Joined: 3/20/2006(UTC)
Posts: 30

We're having some people report that when they try to upload largish files (about 1700kb and bigger), once they click upload, the little uploading window comes up, but it doesn't do anything -- doesn't start uploading. This is only happening to a few people -- others are having no trouble. Here's the JS code:
Code:
var iu = new ImageUploaderWriter("ImageUploader", 720, 500);
iu.activeXControlEnabled = false;
iu.javaAppletEnabled = true;

//For ActiveX control we specify full path for CAB file
iu.activeXControlCodeBase = "src/ImageUploader3.cab";
//iu.activeXControlVersion = "3,5,180,0";

//For Java applet we specify only directory with JAR files
iu.javaAppletCodeBase = "src";
iu.javaAppletCached = true;
//iu.javaAppletVersion = "1.1.81.0";

iu.addParam("Layout","ThreePanes");
iu.addParam("FileMask", "*.jpg;*.jpeg;*.jpe;");
iu.addParam("MaxTotalFileSize", "104857600");
iu.addParam("ShowDebugWindow","True");
iu.addParam("UploadSourceFile", "False");
iu.addParam("UploadThumbnail1FitMode", "fit");
iu.addParam("UploadThumbnail1Width", "800");
iu.addParam("UploadThumbnail1Height", "600");
iu.addParam("UploadThumbnail1JpegQuality", "100");
iu.addParam("PreviewThumbnailSize", "75");
iu.addParam("MaxFileCount", "5");
iu.addParam("EnableRotate","False");
iu.addParam("TimeOut", "90000");
iu.addParam("Action","upload_proc.php?sname=s236168390&op=new");
iu.addParam("DropFilesHereText", "Select 5 files for upload");
iu.addParam("ShowDescriptions", "false");
iu.addParam("ShowButtons", "false");

iu.addEventListener("Progress", "ImageUploader_Progress");
iu.addEventListener("UploadFileCountChange", "ImageUploaderID_UploadFileCountChange");

iu.writeHtml();

Edited by user Tuesday, February 19, 2008 1:49:20 PM(UTC)  | Reason: Not specified

Fedor  
#2 Posted : Sunday, July 30, 2006 1:13:47 AM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,548

Thanks: 5 times
Was thanked: 59 time(s) in 58 post(s)
Hello, Can you repeat this problem? What do you see in Java console?

Edited by user Monday, October 27, 2008 8:06:07 PM(UTC)  | Reason: Not specified

Best regards, Fedor Skvortsov
Bob_J  
#3 Posted : Tuesday, August 1, 2006 1:52:20 AM(UTC)
Bob_J

Rank: Member

Groups: Member
Joined: 3/20/2006(UTC)
Posts: 30

I have been able to repeat the problem, using Internet Explorer 6.0, on a Dell Inspiron B120 with a Celeron processor (1.40 ghz processor with half a gig of RAM). The java console shows this:
Code:

Java(TM) Plug-in: Version 1.4.2_11
Using JRE version 1.4.2_11 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\beta

Proxy Configuration: No proxy

----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
ImageUploader version: 2.0.29

Current document URL: http://create.realestateshows.com/create/upload.php?sname=s1611240124&showlen=1

Reading cookies

Cookies: _dmnid=149139_1146851928625; s514178141=30a0c0a1ddb4641644383f04f29e8d1b; s1611240124=eb47b8e413b3a80b94e77be4954d24c6

Reading referer

Referer: http://xxxx/create/upload.php?sname=s1611240124&showlen=1

Reading additional form content
I tried to upload 5 large images (all 1.5mb or larger). The upload box appears, but the preview area is blank, and the area where the little green upload bars appears is empty. I let it sit there for 10 minutes, and nothing happened. We have now had at least 10 people report this same problem -- this is turning into a major issue for us, and we really need to get it fixed, or we may have to remove this uploader from our system.

Edited by user Wednesday, December 19, 2007 3:34:37 PM(UTC)  | Reason: Not specified

Alex Makhov  
#4 Posted : Tuesday, August 1, 2006 12:42:53 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello Bob, Do the ImageUploader_Progress and ImageUploaderID_UploadFileCountChange event handlers present on the page with Image Uploader? Could you send us the full code of this page as private massage or submit case with it? Also could you send us few problem images?

Edited by user Thursday, May 22, 2008 10:33:15 PM(UTC)  | Reason: Not specified

Sincerely yours, Alex Makhov UserPostedImage Follow Aurigma on Twitter!
Bob_J  
#5 Posted : Thursday, August 24, 2006 7:18:58 AM(UTC)
Bob_J

Rank: Member

Groups: Member
Joined: 3/20/2006(UTC)
Posts: 30

Okay, so we're testing the ActiveX uploader, and I have to say, I'm not very happy. When we upload very large images (2mb or larger apiece), the estimated processing time is waaaay off. It says stuff like an hour and a half to do the processing, when it only takes a few seconds. What's up with that??
Fedor  
#6 Posted : Thursday, August 24, 2006 12:13:00 PM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,548

Thanks: 5 times
Was thanked: 59 time(s) in 58 post(s)
Hello,
Quote:
Okay, so we're testing the ActiveX uploader, and I have to say, I'm not very happy. When we upload very large images (2mb or larger apiece), the estimated processing time is waaaay off.
Let me describe the reason of it. The estimation of required time is based on thumbnail resizing speed as well as on connection speed. Before the upload Image Uploader resizes all images. At that moment it knows the speed of resizing but knows nothing about the upload speed. That's why it has to take into account some average value of upload speed. Later after upload starting it corrects the estimated time using real upload speed. Do you receive the wrong estimated time during "Prepairing data..." stage?
Best regards, Fedor Skvortsov
Bob_J  
#7 Posted : Friday, August 25, 2006 1:55:11 AM(UTC)
Bob_J

Rank: Member

Groups: Member
Joined: 3/20/2006(UTC)
Posts: 30

Quote:
Do you receive the wrong estimated time during "Prepairing data..." stage?
Yes. I would much rather that it did not show any time estimate until it starts uploading. Is there a way to make it only say "Preparing photos for upload" during the preparation stage, and then only show the estimate once it starts uploading? The way it is now, I can see our users saying "I'm not waiting an hour and a half to upload my photos!!" and clicking cancel. This is bad user interface design, IMO.
Bob_J  
#8 Posted : Tuesday, August 29, 2006 5:54:27 AM(UTC)
Bob_J

Rank: Member

Groups: Member
Joined: 3/20/2006(UTC)
Posts: 30

Guys, there's got to be a way to turn off the time estimate during the image processing. It's telling people that it will take 3 hours or longer to process the photos, when it actually only takes a minute. This looks really awful -- people are saying "I don't want to wait 3 hours to upload this!" and clicking cancel.
Alex Makhov  
#9 Posted : Friday, September 1, 2006 5:36:53 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello Bob, I have added a feature request to our bug tracking system. We will implement the ability to change the Estimated Time string while preparing and uploading. For example one will be able to set the value “Preparing…” when the Progress event is fired with status “START” or “PREPARE” and set the value “Uploading…” when the status is “UPLOAD”. This feature will be available in one of our future releases (both ActiveX and Java versions). If you want this feature to be implemented earlier feel free to write to sales@aurigma.com.
Sincerely yours, Alex Makhov UserPostedImage Follow Aurigma on Twitter!
codesmith  
#10 Posted : Monday, September 11, 2006 5:41:22 AM(UTC)
codesmith

Rank: Advanced Member

Groups: Member
Joined: 7/8/2005(UTC)
Posts: 40

We're running into this same problem. Folks are seeing an hour or more to upload and then just cancelling without seeing the speed up. We really need this. Fedor - any idea when it will be available?
Alex Makhov  
#11 Posted : Monday, September 11, 2006 6:42:56 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello,
Quote:
any idea when it will be available?
I think at the end of this autumn.
Sincerely yours, Alex Makhov UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.