Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
noahwsmith  
#1 Posted : Thursday, June 29, 2006 5:07:54 AM(UTC)
noahwsmith

Rank: Member

Groups: Member
Joined: 6/29/2006(UTC)
Posts: 4

Hi guys - I came across your product online, and it looks like just what I need for a project I am working on. Before I get the go-ahead to purchase the software, I have to get a demo working with the free version. So, I download the demo, and open the C# project in VS 2005. My laptop has IIS 5.1 running on it, so I figure I can build the application and run it straight out of the box. No such luck. Let's take the ApplyingEffects demo as an example - the page loads, but the image does not. I also get 6 javascript errors:
Code:
Error: initBitmapViewer is not defined
Source File: http://localhost/GraphicsMill35NET20WebCS/ApplyingEffects.aspx
Line: 173

Error: initRectangleRubberband is not defined
Source File: http://localhost/GraphicsMill35NET20WebCS/ApplyingEffects.aspx
Line: 290

Error: initPanNavigator is not defined
Source File: http://localhost/GraphicsMill35NET20WebCS/ApplyingEffects.aspx
Line: 296

Error: initZoomInNavigator is not defined
Source File: http://localhost/GraphicsMill35NET20WebCS/ApplyingEffects.aspx
Line: 302

Error: initZoomOutNavigator is not defined
Source File: http://localhost/GraphicsMill35NET20WebCS/ApplyingEffects.aspx
Line: 308

Error: initZoomRectangleNavigator is not defined
Source File: http://localhost/GraphicsMill35NET20WebCS/ApplyingEffects.aspx
Line: 320
I don't quite know wha tto make of all this, as I assume the ASP is working fine, but thats where those objects would come from, right? Secondly, right clicking on the (broken) image, I notice that it's location is: http://localhost/GraphicsMill35NET20WebCS/10B0C129D18B403395AC9927FCCD777B.aspx?id=7e89e86d-2ad0-463e-b470-1bdf7fe2ad37.jpg Is the script creating files at runtime? What permissions do I need to give the ASPNET user? Thanks in advance, and I'm really excited by the software - I just hope I can get it working...

Edited by user Wednesday, December 19, 2007 4:10:53 PM(UTC)  | Reason: Not specified

~Noah
Dmitry  
#2 Posted : Thursday, June 29, 2006 7:55:59 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello, Which internet browser do you use? Could you view source of page (e.g. http://localhost/GraphicsMill35NET20WebCS/ApplyingEffects.aspx), find the string like this "script src="/GraphicsMill35NET20WebCS/WebResource.axd?d= ..." type="text/javascript"? Then open new window of browser and try to load scripts by URL that you get on the previous step, in our example it will be: http://localhost/GraphicsMill35NET20WebCS/WebResource.axd?d= .... Please, keep me updated which results do you get.

Edited by user Saturday, December 19, 2009 5:50:11 PM(UTC)  | Reason: Not specified

Sincerely yours, Dmitry Sevostyanov UserPostedImage Follow Aurigma on Twitter!
noahwsmith  
#3 Posted : Thursday, June 29, 2006 11:16:41 PM(UTC)
noahwsmith

Rank: Member

Groups: Member
Joined: 6/29/2006(UTC)
Posts: 4

Alright, I find that line in the source, but I cannot find that file WebResource.axd in the root directory of the project (GraphicsMill35NET20WebCS). Is that where it is supposed to be? Is there another copy somewhere that I can copy into the folder? Thanks for the help so far...
~Noah
Fedor  
#4 Posted : Friday, June 30, 2006 1:26:38 AM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,545

Thanks: 5 times
Was thanked: 58 time(s) in 57 post(s)
IIS maps .axd extension to ASP.NET ISAPI filter. You can check it in IIS Management Console (Web Site Properties -> Home Directory -> Configuration...): UserPostedImage If you do not see it, then you should check your ASP.NET installation. Can you download the script if you directly enter in browser its url?

Edited by user Monday, December 21, 2009 3:01:37 AM(UTC)  | Reason: Not specified

Fedor attached the following image(s):
axd.png
Best regards, Fedor Skvortsov
noahwsmith  
#5 Posted : Friday, June 30, 2006 5:10:01 AM(UTC)
noahwsmith

Rank: Member

Groups: Member
Joined: 6/29/2006(UTC)
Posts: 4

Hmm well, I added .axd, and I tried a repair on my ASP.NET 2.0 installation, still no dice. To answer your second question, no, that file is not in the directory and not accessable in a browser. Any ideas?
~Noah
noahwsmith  
#6 Posted : Friday, June 30, 2006 5:14:37 AM(UTC)
noahwsmith

Rank: Member

Groups: Member
Joined: 6/29/2006(UTC)
Posts: 4

Furthermore, I searched my computer and it found no files *.axd So if that file was part of the installation package, I didn't get it. Where can I?
~Noah
Fedor  
#7 Posted : Friday, June 30, 2006 8:32:08 AM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,545

Thanks: 5 times
Was thanked: 58 time(s) in 57 post(s)
Quote:
Furthermore, I searched my computer and it found no files *.axd
It is virtual file, which doesn't exists actually in the file system. When IIS receive request to *.axd file then it is handled by ASP.NET ISAPI in any case.
Best regards, Fedor Skvortsov
Fedor  
#8 Posted : Friday, June 30, 2006 8:39:23 AM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,545

Thanks: 5 times
Was thanked: 58 time(s) in 57 post(s)
Quote:
Hmm well, I added .axd, and I tried a repair on my ASP.NET 2.0 installation, still no dice.
Please check whether Web Site is configured for ASP.NET 2.0: UserPostedImage Also to repair ASP.NET 2.0 installation just type: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis -i You can also try to open ASP.NET 2.0 samples using built-in VS 2005 web server (Casini).

Edited by user Monday, December 21, 2009 3:01:56 AM(UTC)  | Reason: Not specified

Fedor attached the following image(s):
aspnetversion.png
Best regards, Fedor Skvortsov
Users browsing this topic
Similar Topics
Java/ActiveX Demo not working??? (Discussions – ActiveX/Java Uploader)
by fashiongps 10/18/2013 7:48:04 AM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.