Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
janetsmith  
#1 Posted : Wednesday, May 31, 2006 9:13:36 AM(UTC)
janetsmith

Rank: Member

Groups: Member
Joined: 2/1/2006(UTC)
Posts: 40

Hi

I am ASP coder.
In my folder, I got 4 files:
default.asp
aurigma.asp
PersistsAspUpload.asp
PictureGallery.asp

1.)
In default.asp
I assign session variable as below
Code:
<%
session("UserID") = 1
session("Number") = 9
%>


2.)
In aurigma.asp, which I use to load ImageUploader, I assign additional session variable:
Code:
<%
Session("UserID") = 2
Session("Number") = 88
Session("yoyo") = "Test"
For Each x in Session.Contents
	Response.Write x & ": " & Session(x) & "<br>"
Next
%>

I also display value of all the session variable.
It seems ok. UserID = 2, Number = 88, and yoyo = Test

3.)
After I uploaded some files, the webpage will be redirected to PictureGallery.asp
Again, the code below shows the session variable in the current state.
Code:
<%
For Each x in Session.Contents
	Response.Write x & ": " & Session(x) & "<br>"
Next
%>

Now The UserID = 1, Number = 9, and yoyo = Test!

*****************************************
It seems like ImageUploader will load the default.asp automatically!
Or maybe it keep a copy of session variable in default.asp, and override the session each time we invoke it?

Is this a bug? How to get around this problem?

Edited by user Wednesday, December 19, 2007 4:35:40 PM(UTC)  | Reason: Not specified

File Attachment(s):
PhotoPrint.zip (783kb) downloaded 149 time(s).
Fedor  
#2 Posted : Wednesday, May 31, 2006 12:54:11 PM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,545

Thanks: 5 times
Was thanked: 58 time(s) in 57 post(s)
If you post in aurigma.asp the direct link to PictureGallery.asp:

Code:

....
    <a href="PictureGallery.asp">Picture Gallery</a>
  </body>
</html>


and follow this link, then you will receive totally the same result. You can even comment all Image Uploader object code in aurgma.asp to became totally sure that the problem is not concerned with Image Uploader, but with the server logic.

Edited by user Wednesday, December 19, 2007 4:35:49 PM(UTC)  | Reason: Not specified

Best regards,
Fedor Skvortsov
janetsmith  
#3 Posted : Wednesday, May 31, 2006 7:34:11 PM(UTC)
janetsmith

Rank: Member

Groups: Member
Joined: 2/1/2006(UTC)
Posts: 40

The files photoprint.zip is the simplify version of files which can help you debug the problem.
It can easily reproduce the problem.

Have you tested the file I sent u?
janetsmith  
#4 Posted : Thursday, June 01, 2006 9:48:12 AM(UTC)
janetsmith

Rank: Member

Groups: Member
Joined: 2/1/2006(UTC)
Posts: 40

Hi,

I have found the error.

It has nothing to do with Image Uploader.
It is not Image Uploader nor server script problem. It's HTML problem!!! I nvr expected that.

there's one line in the code
<img src=""> , which causes the problem. because I didnt specify the file for src, server will take the default one, which is default.asp. Thus it reload the default.asp page.

Edited by user Saturday, December 19, 2009 7:10:29 PM(UTC)  | Reason: Not specified

Fedor  
#5 Posted : Friday, June 02, 2006 11:31:18 AM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,545

Thanks: 5 times
Was thanked: 58 time(s) in 57 post(s)
I am glad that you resolved the problem. I have checked the problem, confirmed it, but has resolved only after you.

BTW, on Firefox it works perfectly.
Best regards,
Fedor Skvortsov
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.