Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
ZComplx  
#1 Posted : Wednesday, May 31, 2006 4:17:12 AM(UTC)
ZComplx

Rank: Member

Groups: Member
Joined: 5/31/2006(UTC)
Posts: 1

I'm working in C# for asp.net and created a simple scenario:

In the addphoto.aspx page I have:
Code:
<script language="javascript">
function ImageUploader_Progress(Status, Progress, ValueMax, Value, StatusText){
	if (Status=="COMPLETE"){
	// When upload is finished, we are redirecting to the PictureGalery.aspx page
	window.location = 'Story.aspx';  
	}
} 
</script>
<script language="javascript">
var element = document.getElementById( "wrapper" );
var width=500;
var height=770;
				
if( element && element.clientWidth )	width=element.clientWidth;
else if( element && element.innerWidth )	width=element.innerWidth;
								
var iu = new ImageUploaderWriter("ImageUploader", width, height);
iu.activeXControlEnabled = false;
iu.javaAppletEnabled = true;

//For ActiveX control we specify full path for CAB file
//iu.activeXControlCodeBase = "C:\Program Files\Aurigma\Image Uploader 1.1 for Java\Samples\ASPNET\ImageUploader3.cab";
//iu.activeXControlVersion = "3,5,180,0";

//For Java applet we specify only directory with JAR files
iu.javaAppletCodeBase = "../";
iu.javaAppletCached = true;
iu.javaAppletVersion = "1.1.81.0";

iu.addParam("Layout","TwoPanes");
iu.addParam("UploadSourceFile","True");
iu.addParam("ShowDebugWindow","True");
iu.addParam("AdditionalFormName","Form1");
iu.addParam("EnableRotate","True");
//iu.addParam("ExtractExif", "ExifDateTime");
iu.addParam("FileMask", "*.jpg;*.jpeg;*.jpe;*.jfif;*.gif;*.bmp;*.tiff;*.tif;*.png");
iu.addParam("Action","Upload.aspx")
				
iu.addEventListener("Progress", "ImageUploader_Progress");

iu.writeHtml();
</script>


I then created an Upload.aspx file with a Upload.aspx.cs file. The iu doesn't even seem to access the Upload.aspx file. I created a StreamWriter to create a log file when accessed to test this and it is not creating the log file. When I go to upload files, it seems to work by fully sending the file, it then reports, "Waiting for retry", fully resends the file, and then reports, "Image Uploader encountered some problem. If you see this message, contact web master". No debug window comes up as stated in the Help Files.

What's wrong here?

Edited by user Monday, February 18, 2008 3:39:01 PM(UTC)  | Reason: Not specified

Fedor  
#2 Posted : Wednesday, May 31, 2006 12:22:57 PM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,545

Thanks: 5 times
Was thanked: 58 time(s) in 57 post(s)
It seems you use Java version of Image Uploader. Please check and post here the content of Java console:

Image Uploader FAQ - Troubleshooting
Best regards,
Fedor Skvortsov
Users browsing this topic
Similar Topics
Trial version not working (Discussions – Graphics Mill)
by aDino 1/27/2009 1:47:35 AM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.