Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
akak1701  
#1 Posted : Thursday, December 08, 2005 5:08:49 AM(UTC)
akak1701

Rank: Member

Groups: Member
Joined: 10/25/2005(UTC)
Posts: 10

Does anyone know if the recent OS X Java update (J2SE 5.0 Release 3) has caused issues with Image Uploader? My tests with 10.4.x fail, but I have customers using 10.3.x with the issue as well.

The upload utility has been working great until the other day. Now I have several customers who can't upload from either Safari or Firefox on the Mac. We are still able to upload ok from a PC using IE and Firefox, so the receiving page is not the issue and the Java applet still works.

I have isolated it to that there are no files being sent across to the receiving page. The page is called, but the files collection is empty when you check for the files. I am capturing with Dundas Upload.

Has any one else seen this?

Also, if someone can tell me how to uninstall the update, I'll be glad to test further.

Thanks -- Greg
Alex Makhov  
#2 Posted : Sunday, December 11, 2005 7:41:00 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

Ask your clients to send Java console dump. It usually contains the reasons of all errors.
Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
akak1701  
#3 Posted : Monday, December 12, 2005 3:45:46 AM(UTC)
akak1701

Rank: Member

Groups: Member
Joined: 10/25/2005(UTC)
Posts: 10

I can recreate this on both of my Macs. Here is the dump from one of them.

Looking at the dump, it shows it's using Java 1.4.2_09 which is not 5.0/R3.

Code:
Java(TM) Plug-in: Version 1.4.2_09
Using JRE version 1.4.2_09 Java HotSpot(TM) Client VM
User home directory = /Users/gbenedict
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
Version checking for ImageUploader.jar, specified version is 1.1.02.0
Referencing classloader: sun.plugin.ClassLoaderInfo@89a406, refcount=1
Loading applet ...
Initializing applet ...
Starting applet ...
ImageUploader version: 1.1.02
Current document URL: http://192.168.1.219/esr/AdminPhotographer/Job/Photos/uploadwindow.asp?JobID=21450&JobName=Test+5
JSObject::eval(document.cookie), url=http://192.168.1.219, permission=true
JSObject::eval(ImageUploader_InitComplete();), url=http://192.168.1.219, permission=true
JSObject::eval(document.forms['Form1']), url=http://192.168.1.219, permission=true
JSObject::getMember: name=elements, url=http://192.168.1.219, permission=true
Uploading to http://192.168.1.219/esr/AdminPhotographer/Job/Photos/UploadCapture.asp?ClientSite=troyphoto&JobID=21450
Setting HTTP params: Host=192.168.1.219
Starting upload
Dec 12, 2005 2:36:40 PM org.apache.commons.httpclient.HttpMethodBase readResponse
INFO: Discarding unexpected response: HTTP/1.1 100 Continue
Status =[200]
Upload complete. Result page:

EndOf Result page
JSObject::eval(window.location = 'uploadcomplete.asp?JobID=21450&JobName=Test+5';), url=http://192.168.1.219, permission=true
Stopping applet ...
Stopping applet ...
Finding information ...
Releasing classloader: sun.plugin.ClassLoaderInfo@89a406, refcount=0
Caching classloader: sun.plugin.ClassLoaderInfo@89a406
Current classloader cache size: 1
Done ...
Joining applet thread ...
Destroying applet ...
Disposing applet ...
Quiting applet ...
Joined applet thread ...

Edited by user Sunday, December 23, 2007 4:44:35 PM(UTC)  | Reason: Not specified

akak1701  
#4 Posted : Monday, December 12, 2005 3:49:12 AM(UTC)
akak1701

Rank: Member

Groups: Member
Joined: 10/25/2005(UTC)
Posts: 10

Also, I am using Dundas Upload to capture, so I tested with ASPUpload. The same issue occurs on both.
akak1701  
#5 Posted : Monday, December 12, 2005 4:53:32 AM(UTC)
akak1701

Rank: Member

Groups: Member
Joined: 10/25/2005(UTC)
Posts: 10

I did a bit more research. I installed a patch for version 2.1.0.1 of ASPUpload and now it works. I downloaded the trial of 3.0 and it worked as well. Any clue why this works and neither Dundas 2.0.2.0 or ASPUpload 2.0.x work? What changed?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.