Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Andrew  
#1 Posted : Thursday, April 18, 2013 1:56:07 AM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 868

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
Description

After installing Java 7 Update 21, you may find out that Java uploader stopped working. This problem is reproduced with any uploader version.

Reason

The new security approach Oracle presented in Java 7 Update 21 made previous versions of Java uploader inoperable unless mixed code security verification is disabled in Java settings.

Solution

The problem is fixed in Upload Suite 8.0.33. Further steps depend on the version you have now.

You have version 7 or 8 with active maintenance subscription
Note, the version 8 is backward compatible with the version 7, so you can update without modifying your code.

You have version 7 or 8 but the maintenance subscription expired (or absent)
  • Contact us at info@aurigma.com or submit a support case to receive the license key.
    As this issue is really critical, we will do it for free.
  • Be sure to include your old license key, domain name or order ID so that we could identify you.
  • Update your uploader to 8.0.33 as explained above.
We also highly encourage you to restore the maintenance subscription. We have a special offer even if it is already expired. Just let us know if you are interested.

You have version 6.x

Just update your uploader to the version 6.5.27 which is available on the old versions download page.

It is highly recommended considering updating your uploader to the version 8.0.33. Contact us at sales@aurigma.com if you are interested.

You have version 5.x or earlier

This is VERY outdated version, so it is no longer supported. However the version 6 is backward compatible with all previous versions. That's why we recommend the following solution:
  • Upgrade your licenses. Contact us at sales@aurigma.com for a quote.
  • If you need to update it quickly, use the version 6.5.27 (we will provide you with old license keys if you upgrade).
  • When you have enough time to do it, update your code to make it compatible with the version 8.
Is temporary workaround available?

As a temporary workaround for a specific user, it will help to disable mixed code security verification in Java settings:

UserPostedImage

However please note, it is not recommended as it may reduce the security of the user's system. Use it only as a last resort.

Edited by moderator Wednesday, February 12, 2014 12:26:18 AM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.