Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
mmount  
#1 Posted : Wednesday, December 12, 2012 6:19:11 AM(UTC)
mmount

Rank: Advanced Member

Groups: Member
Joined: 11/30/2012(UTC)
Posts: 61

Thanks: 6 times
Hi,

For performance reasons I have switched to single pane view for the uploader. I am providing my own buttons to add files, remove, and upload. I have set EnableStatusPane = false but the status pane, while not displayed, is still consuming space at the bottom of the Upload Pane. You can tell by adding files and seeing that the thumbnail gets cut off before the bottom of the pane.

How do I get rid of it completely?

Thanks,

Mike
p.shirykalova  
#2 Posted : Wednesday, December 12, 2012 10:27:21 PM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Hi Mike,

I tried to disable status pane in one pane layout myself and got fine results. Please see the screenshot attached.

Could you please share the link to your page (login/password if any) or a screenshot and code of your solution?
p.shirykalova attached the following image(s):
capture.png
Best regards,
Pauline Shirykalova
Aurigma Technical Support
mmount  
#3 Posted : Thursday, December 13, 2012 6:36:22 AM(UTC)
mmount

Rank: Advanced Member

Groups: Member
Joined: 11/30/2012(UTC)
Posts: 61

Thanks: 6 times
Hi,

It appears to be IE only - looks like Firefox and Chrome both properly hide it. I suppose this means it's a bug in the ActiveX version. I have attached a screenshot.

Here is the relevant part of the page code if you need it:

Code:
    <div style="position: absolute; top: 28px; bottom: 0px; width: 100%; overflow-y: hidden ! important">
      <cc1:Uploader ID="Uploader1" runat="server" Height="100%" Width="100%" LicenseKey="" BorderStyle="None" EnableFileViewer="True" PaneLayout="OnePane" EnableStatusPane="False" EnableAutoRotation="True" TextColor="Gray">
        <ActiveXControl ClassId="" ProgId=""></ActiveXControl>

        <ContextMenu AddFilesText="Add photos..." ArrangeByModifiedText="Modified" />

        <Converters>
          <cc1:Converter ThumbnailHeight="1500" ThumbnailResizeQuality="High" ThumbnailResolution="100" ThumbnailWidth="1500" Mode="*.*=Thumbnail" ThumbnailCopyIptc="True" ThumbnailCopyExif="True" />
          <cc1:Converter ThumbnailHeight="600" ThumbnailResizeQuality="High" ThumbnailResolution="100" ThumbnailWidth="600" Mode="*.*=Thumbnail" ThumbnailCopyIptc="False" />
          <cc1:Converter ThumbnailHeight="175" ThumbnailResizeQuality="High" ThumbnailResolution="100" ThumbnailWidth="175" Mode="*.*=Thumbnail" ThumbnailCopyIptc="False" />
        </Converters>
        <AddFilesProgressDialog CurrentFileText="Processing photo: '[name]'" TitleText="Adding photos to upload queue" TotalFilesText="Total processed: [count]" WaitText="Please wait while your photos are added to the upload queue..." />
        <ClientEvents>
          <cc1:ClientEvent EventName="BeforeUpload" HandlerName="DoBeforeUpload" />
          <cc1:ClientEvent EventName="BeforeSendRequest" HandlerName="DoBeforeSendRequest" />
          <cc1:ClientEvent EventName="BeforePackageUpload" HandlerName="DoBeforePackageUpload" />
          <cc1:ClientEvent EventName="AfterUpload" HandlerName="DoAfterUpload" />
          <cc1:ClientEvent EventName="UploadFileCountChange" HandlerName="DoUploadFileCountChange" />
          <cc1:ClientEvent EventName="SelectionChange" HandlerName="DoSelectionChange" />
        </ClientEvents>

        <HeaderColor Color1="242, 246, 251" Color2="196, 222, 251"></HeaderColor>

        <Messages FileNameNotAllowed="The file '[name]' cannot be selected. This file has already been uploaded." />

        <PaneItem ShowFileNameInThumbnailsView="True" CheckedItemBorderColor="White" EnableFileNameTooltip="True" InactiveCheckedItemBorderColor="White">
          <CheckedHoverColor Color1="204, 232, 255" Color2="189, 224, 255"></CheckedHoverColor>

          <CheckedItemColor Color1="White" Color2="White"></CheckedItemColor>

          <CheckedSelectionColor Color1="204, 232, 255" Color2="189, 224, 255"></CheckedSelectionColor>

          <CheckedSelectionHoverColor Color1="204, 232, 255" Color2="189, 224, 255"></CheckedSelectionHoverColor>

          <HoverColor Color1="237, 247, 255" Color2="237, 247, 255"></HoverColor>

          <InactiveCheckedHoverColor Color1="204, 232, 255" Color2="189, 224, 255"></InactiveCheckedHoverColor>

          <InactiveCheckedItemColor Color1="White" Color2="White"></InactiveCheckedItemColor>

          <InactiveCheckedSelectionColor Color1="204, 232, 255" Color2="189, 224, 255"></InactiveCheckedSelectionColor>

          <InactiveCheckedSelectionHoverColor Color1="204, 232, 255" Color2="189, 224, 255"></InactiveCheckedSelectionHoverColor>

          <InactiveSelectionColor Color1="229, 243, 255" Color2="216, 237, 255"></InactiveSelectionColor>

          <SelectionColor Color1="229, 243, 255" Color2="216, 237, 255"></SelectionColor>

          <SelectionHoverColor Color1="204, 232, 255" Color2="189, 224, 255"></SelectionHoverColor>

          <UploadIndicatorColor Color1="White" Color2="225, 255, 230"></UploadIndicatorColor>
        </PaneItem>

        <Restrictions FileMask="*.jpg;*.jpeg;*.jpe" MinImageHeight="200" MinImageWidth="200" MaxFileCount="999" />

        <StatusPane>
          <Color Color1="247, 247, 247" Color2="239, 239, 239"></Color>
        </StatusPane>
        <UploadPane SortMode="Name" DropFilesHereMacText="" DropFilesHereText="(select Add Photos or Add Folder above or drop photos here)">
        </UploadPane>
        <UploadProgressDialog InfoText="Photos uploaded: [files]/[totalFiles] ([bytes] of [totalBytes])" PreparingText="Preparing photos for upload..." TitleText="Uploading photos to NFR" />
      </cc1:Uploader>
      <cc1:AmazonS3Extender runat="server" ID="AmazonS3Extender1" TargetControlID="Uploader1"
        AWSAccessKeyId="<%$ appSettings: s3.AccessKeyId %>"
        Bucket="<%$ appSettings: s3.Bucket %>"
        SecretAccessKey="<%$ appSettings: s3.SecretAccessKey %>"
        PolicyExpiration="6000">
        <cc1:FileSettings Acl="public-read" Key="large/${filename}" ContentType="image/jpeg">
        </cc1:FileSettings>
        <cc1:FileSettings Acl="public-read" Key="medium/${filename}" ContentType="image/jpeg">
        </cc1:FileSettings>
        <cc1:FileSettings Acl="public-read" Key="small/${filename}" ContentType="image/jpeg">
        </cc1:FileSettings>
      </cc1:AmazonS3Extender>
      </div>


Thanks,

Mike
mmount attached the following image(s):
uploader-statuspane-issue.jpg
p.shirykalova  
#4 Posted : Thursday, December 13, 2012 8:24:54 PM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Hi Mike,

Thanks! I was able to reproduce the issue in IE. Indeed this is a bug, I reported to our developers.
We will fix it in the next releases. Unfortunately I cannot estimate when the new release will be available.

Meanwhile as a workaround I could suggest you to use Java version in IE. Please set your Type property to "java".
Best regards,
Pauline Shirykalova
Aurigma Technical Support
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.