Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
p.shirykalova  
#1 Posted : Thursday, August 9, 2012 1:31:42 AM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Aurigma code signing certificates have expired on July, 26. We updated ActiveX/Java binaries for all products. Please make sure you updated your Aurigma upload solutions.

Upload Suite 8/Image Uploader 7
  • If you have active Maintenance Subscription please download the latest version of Upload Suite. Currently the latest version is 8.0.15. After unpacking the package on your server please do the following:
    • ASP.Net control
      Please update Aurigma.ImageUploader.dll in the /bin folder.
    • PHP Library
      Please overwrite the content of the /ImageUploaderPHP folder.
    • JavaScript libraryPlease update .cab, .jar and .js files from the /Scripts folder.
  • If you do not have a maintenance subscription or it has expired, download the same version of the product you currently use and unpack it on your server. For example, if you have Image Uploader 7.0.28, you will need to download Image Uploader SDK 7.0.28.
    • ASP.Net control
      Please update Aurigma.ImageUploader.dll in the /bin folder.
    • PHP Library
      Please overwrite the content of the /ImageUploaderPHP folder.
    • JavaScript library
      Please update .cab and .jar files from the /Scripts folder.
Image Uploader 6.x

Image Uploader 6 license holders should download Image Uploader 6.5.19.
  • ASP.Net control
    Please update Aurigma.ImageUploader.dll in the /bin folder.
  • PHP Library
    Please overwrite the content of the /ImageUploaderPHP folder.
  • JavaScript library
    Please update .cab and .jar files and iuembed.js file and set javaAppletVersion and activeXControlVersion properties:
    Code:
    …
    iu.javaAppletVersion = "6.5.19.0";
    iu.activeXControlVersion = "6,5,19,0";
    …
Image Uploader 5.x

Image Uploader 5 license holders should download Image Uploader 5.8.1.0.
  • JavaScript library
    Please update .cab and .jar files and iuembed.js file and set javaAppletVersion and activeXControlVersion properties:
    Code:
    …
    iu.javaAppletVersion = "5.8.1.0";
    iu.activeXControlVersion = "5,8,1,0";
    …
Image Uploader 4.x and older

Please contact Aurigma Technical Support for more details about older Image Uploader versions certificate updates.

For all versions

If you set caching Java applet to true a new applet would not be able to run because Java applets with old certificate are stored in the cache. Please disable Java applet caching by setting javaAppletCached property to false in your JavaScript or PHP code (ASP.Net control doesn't need this):
Upload Suite 8/Image Uploader 7 JavaScript
Code:
$au.uploader({
    javaControl: {
        //...other params...
        cached: false,
        //...other params...
    }
})

Upload Suite 8/Image Uploader 7 PHP
Code:
$uploader->getJavaControl()->setCached(FALSE);

Image Uploader 6.x/Image Uploader 5.x
Code:
iu.javaAppletCached = false;


After a while you might want to turn the cache on to let your customers use cached version and improve page performance. In this case please make sure you set your Java control cached property to true and version to "":
Upload Suite 8/Image Uploader 7 JavaScript
Code:
$au.uploader({
    javaControl: {
        cached: true,
        version: "",
    }
})

Upload Suite 8/Image Uploader 7 PHP
Code:
$uploader->getJavaControl()->setVersion("");
$uploader->getJavaControl()->setCached(TRUE);

Image Uploader 6.x/Image Uploader 5.x
Code:
iu.javaAppletVersion = "";
iu.javaAppletCached = true;

This is necessary to make Java use newly downloaded control with renewed certificate. If you don't update the version in source code, your end-users will continue seeing the certificate warning.

Edited by moderator Thursday, June 20, 2013 9:19:27 PM(UTC)  | Reason: Not specified

Best regards,
Pauline Shirykalova
Aurigma Technical Support
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.