Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Yuval  
#1 Posted : Thursday, August 2, 2012 11:12:48 AM(UTC)
Yuval

Rank: Member

Groups: Member
Joined: 7/15/2008(UTC)
Posts: 16

Hi,

Per your directions, I've upgraded the scripts and binaries for 7.0.28 but users still getting the warning. IE seems to be fine but I see the problem with FF and Chrome. Did not test Safari yet.

Any ideas?

Thanks,
Yuval
Dmitry.Obukhov  
#2 Posted : Thursday, August 2, 2012 11:45:01 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Yuval,

Please set javaControl.cached property to false:
Code:
javaControl: {
//...other params...
  cached: false,
//...other params...
}

Then restart the browser and open your page with Image Uploader.

Edited by user Tuesday, August 14, 2012 12:11:19 AM(UTC)  | Reason: Not specified

Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Yuval  
#3 Posted : Friday, August 3, 2012 11:41:14 AM(UTC)
Yuval

Rank: Member

Groups: Member
Joined: 7/15/2008(UTC)
Posts: 16

ok. It seems to have done the trick. Could you just explain - I did clear the cache before and it did not work but after adding the control, the problem was resolved.

Another follow up question is - do I need at some point change it to cache:true to improve performance?

Thanks for the help,
Yuval
Dmitry.Obukhov  
#4 Posted : Monday, August 6, 2012 1:56:47 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Yuval,

It seems that Java run the new applet but tried to accept the old certificate which was cached too (Control panel -> Java -> Security -> Certificates). Once you set cached to false, JRE had to download and launch new applet signed by the new certificate.
Quote:
Another follow up question is - do I need at some point change it to cache:true to improve performance?

Actually, there is no way to speed up loading the applet when cached property is set to false. Each time, the applet is downloaded anew. I would like to recommend you to leave this property setting to false for a week while all your users update Image Uploader Java applet on their machines. Then you can set it back to true.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Nfoto  
#5 Posted : Monday, August 13, 2012 12:28:22 AM(UTC)
Nfoto

Rank: Newbie

Groups: Member
Joined: 12/26/2007(UTC)
Posts: 2

Thats well and good, but how do I get the best of both worlds, let the users cache the jar and still have the browser download a fresh copy with a valid certificate?
Dmitry.Obukhov  
#6 Posted : Monday, August 13, 2012 1:36:22 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
You can set cached property to false for a while (e.g. for 2-3 weeks). This time should be enough to allow all users to get new applet. Then you can enable cashing.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Yuval  
#7 Posted : Monday, August 13, 2012 7:58:36 AM(UTC)
Yuval

Rank: Member

Groups: Member
Joined: 7/15/2008(UTC)
Posts: 16

I'm just about to switch back the cached to False - will let you know how things go.
Dmitry.Obukhov  
#8 Posted : Monday, August 13, 2012 8:50:03 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Okay. Feel free to contact me here.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Yuval  
#9 Posted : Monday, August 13, 2012 11:39:02 PM(UTC)
Yuval

Rank: Member

Groups: Member
Joined: 7/15/2008(UTC)
Posts: 16

Well, I turned the flag back but I'm now getting the certificate error again.
This is very strange!
Dmitry.Obukhov  
#10 Posted : Tuesday, August 14, 2012 9:15:49 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Yuval,

Please set version property to empty string:
Code:

javaControl: {
  //...other parameters...
  cached: true,
  version: ''
}
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Yuval  
#11 Posted : Wednesday, August 15, 2012 10:30:14 PM(UTC)
Yuval

Rank: Member

Groups: Member
Joined: 7/15/2008(UTC)
Posts: 16

Working now and seems more speedy with cached:true.
Dmitry.Obukhov  
#12 Posted : Wednesday, August 15, 2012 10:39:39 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Okay. Glad to know that it works.

If you have other questions or problems, please contact me.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.