Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
suchiate  
#1 Posted : Friday, July 6, 2012 1:15:25 AM(UTC)
suchiate

Rank: Newbie

Groups: Member
Joined: 7/6/2012(UTC)
Posts: 5

Thanks: 1 times
Hi,

Has any of you tried using a License Key for IP Address directly instead of a web domain?

I have generated a Free License Key from the site with my application IP address and copied it to generate the script.

My iPad is able to view the links, and use the installation link with no problem.

Once I click the Upload Images link, the App opens up specifying that there is no valid license key found.

Please help~
maxmax  
#2 Posted : Friday, July 6, 2012 1:42:58 AM(UTC)
maxmax

Rank: Newbie

Groups: Member
Joined: 7/6/2012(UTC)
Posts: 4

I did it. Works for me to get a local ip. Didn't try it though for an external or internet IP (in which case it will surely fail because of many things, virtual host, dns matching, hosts…).
suchiate  
#3 Posted : Friday, July 6, 2012 2:34:55 AM(UTC)
suchiate

Rank: Newbie

Groups: Member
Joined: 7/6/2012(UTC)
Posts: 5

Thanks: 1 times
I can get the license key and have also placed it in my aurup script link.

the aurigma app also opens up when I click the link, just that the license key generated from the site using my server IP address is not working.
p.shirykalova  
#4 Posted : Sunday, July 8, 2012 7:19:39 PM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Administration
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Hi Suchiate,

Current version of Aurigma Up doesn't support IP-based license keys, domain based only. However you can use your IP address as a domain name string. I mean you get the key for your IP (say, "10.0.0.1") and insert it in your Aurigma Up link. Please note that you also should insert your IP into uploadUrl and redirectUrl:
Code:
<a href="aurup:?uploadUrl=http%3A%2F%2F10.0.0.1%2Fupload.php&redirectUrl=http%3A%2F%2F10.0.0.1%2Fgallery.php&licenseKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXX">Upload Images</a>


Please make sure you are not using your domain name (www.mydomain.com) in any of your parameters.

If the problem still persists please provide me with your Aurigma Up link code.
Best regards,
Pauline Shirykalova
Aurigma Technical Support
thanks 1 user thanked p.shirykalova for this useful post.
suchiate on 7/9/2012(UTC)
suchiate  
#5 Posted : Monday, July 9, 2012 12:07:51 AM(UTC)
suchiate

Rank: Newbie

Groups: Member
Joined: 7/6/2012(UTC)
Posts: 5

Thanks: 1 times
Hi Pauline,

So if my web application sits on a IP-based URL with no domain name, what should I use for my license key?
p.shirykalova  
#6 Posted : Monday, July 9, 2012 12:41:25 AM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Administration
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
You should use your IP address.
Best regards,
Pauline Shirykalova
Aurigma Technical Support
suchiate  
#7 Posted : Monday, July 9, 2012 12:49:15 AM(UTC)
suchiate

Rank: Newbie

Groups: Member
Joined: 7/6/2012(UTC)
Posts: 5

Thanks: 1 times
Hi Pauline,

You mean the license key parameter in the aurup tag should be my IP address??

I'm referring to this parameter, licenseKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

I generated the free license key using my IP address but when the user click on it, it says the license key is invalid.
p.shirykalova  
#8 Posted : Monday, July 9, 2012 12:57:57 AM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Administration
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Suchiate,

You should use your IP address during license key generation. As I can see in your account, you already have the license key for your IP. Please use it.

Please make sure you inserted your IP into uploadUrl parameter. Please double check if there any misprints or extra symbols.

If nothing helps please provide me with your complete Aurigma Up link, I will check it.\
Best regards,
Pauline Shirykalova
Aurigma Technical Support
suchiate  
#9 Posted : Monday, July 9, 2012 9:44:14 AM(UTC)
suchiate

Rank: Newbie

Groups: Member
Joined: 7/6/2012(UTC)
Posts: 5

Thanks: 1 times
Hi Pauline,

After changing my uploadURL and redirectURL with the correct strings, the app is acting correctly now.

Thank you.
p.shirykalova  
#10 Posted : Monday, July 9, 2012 6:32:30 PM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Administration
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
No problem! Please feel free to contact us if you have any additional questions.
Best regards,
Pauline Shirykalova
Aurigma Technical Support
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.