Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
IRHM73  
#1 Posted : Sunday, February 19, 2012 7:00:47 AM(UTC)
IRHM73

Rank: Member

Groups: Member
Joined: 2/13/2012(UTC)
Posts: 21

Thanks: 1 times
I wonder whether someone may be able to help me please.

I'm trying to run the 'index.php' file which is contained within the 'Samples_ImageuploaderPHP' folder
from the v7.0.37 download pack.

I've added the complete content of the afore mentioned folder but when I run 'index.php' file
the IE window rendered is just a white background and when I run the 'debugging' in the 'developer
tools' I recieve the following error:

Quote:
<b>Fatal error</b>: Call to a member function xpath() on a non-object in <b>/homepages/2/d333603417/htdocs/development/Includes/demodata.php</b> on line <b>51</b><br />


This is the content of the 'index.php' file:

Code:
<?php
$host = $_SERVER['HTTP_HOST'];
$uri = rtrim(dirname($_SERVER['PHP_SELF']), '/\\');
header("Location: http://$host$uri/BasicDemo/index.php"); /* Redirect browser */

/* Make sure that code below does not get executed when we redirect. */
exit;


I am running Windows XP as Administrator and I have changed my php.ini file to allow_url _fopen and 'allow_url_include'

I just wondered whether someone else may have come against this, and perhaps have a solution for it.

Many thanks and kind regards

Dmitry.Obukhov  
#2 Posted : Sunday, February 19, 2012 7:40:30 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Chris,

XPath() method is supported since PHP 5.2. Please be sure that you have this version number of PHP. If you have some earlier version, please update it.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
IRHM73  
#3 Posted : Monday, February 20, 2012 8:31:58 AM(UTC)
IRHM73

Rank: Member

Groups: Member
Joined: 2/13/2012(UTC)
Posts: 21

Thanks: 1 times
Hi Dmitry, many thanks for this.

I can confirm that I am running PHP V5.2.17 and I've tried the files again and i'm still receiving the same error.

Many thanks and kind regards

Chris
Dmitry.Obukhov  
#4 Posted : Tuesday, February 21, 2012 12:46:21 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Chris,

Unfortunately, I still cannot replicate the problem with XPath() in our testing lab. I also looked through our records to find any similar reports from other our clients – there is nothing. I assume if the problem takes place in global case, we would get more complaints. I will keep on investigating it and if I find something I will inform you.

As far as I understand, Chris, you are in progress with deploying Image Uploader (CAS-8310). Please let me know about your results in the support ticket.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
IRHM73  
#5 Posted : Tuesday, February 21, 2012 8:04:48 AM(UTC)
IRHM73

Rank: Member

Groups: Member
Joined: 2/13/2012(UTC)
Posts: 21

Thanks: 1 times
Dmitry, that's fine, it's not hampering my development.

Sincere thanks for all your help.

Kind regards

Chris
Dmitry.Obukhov  
#6 Posted : Tuesday, February 21, 2012 10:28:08 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hi Chris,

Thank you :) If you have any questions or problems with Image Uploader, please feel free to let me know. I will assist you with pleasure.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.