Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Nikkelmann  
#1 Posted : Tuesday, November 29, 2011 6:38:58 AM(UTC)
Nikkelmann

Rank: Member

Groups: Member
Joined: 11/29/2011(UTC)
Posts: 10

Thanks: 2 times
Hi!

I've run into a problem with the Image Uploader.

This only happens for one of my images, so I don't know if this is an error in the image exif data or with the image uploader. Anyway, here goes.


The image Exif datetime is: 18-10-2011 10:09:36
The exif datetime recieved in my server code is: 19-10-2011 08:00:15

Somehow the datetime is extracted incorrectly from the exif data, since in Windows Explorer and Adobe Bridge the data is correct.

The image size is 480x640.

My script looks like this:
Code:

// Initialize image uploader
		var iu = $au.uploader({
			id: 'auIU',
			width: '100%',
			height: '600px',
			folderPane: {
				viewMode: 'Tiles'
			},
			restrictions: {
				fileMask: '*.jpg;*.jpeg;*.png;*.gif;*.bmp'
			},
			licenseKey: 'XXX-XXX-XXX-XXX',
			enableDescriptionEditor: false,
			enableAutoRotation: true,
			activeXControl: {
				codeBase: '/ImageUploader7/ImageUploader7.cab',
				codeBase64: '/ImageUploader7/ImageUploader7_x64.cab'
			},
			javaControl: {
				codeBase: '/ImageUploader7/ImageUploader7.jar'
			},
			uploadSettings: {
				actionUrl: 'upload/',
				redirectUrl: 'edit/'
			},
			converters: [
				{ mode: '*.*=Thumbnail', thumbnailFitMode: 'Fit', thumbnailWidth: '1000', thumbnailHeight: '1000', thumbnailApplyCrop: true },
				{ mode: '*.*=Thumbnail', thumbnailFitMode: 'Fit', thumbnailWidth: '500', thumbnailHeight: '500', thumbnailApplyCrop: true },
				{ mode: '*.*=Thumbnail', thumbnailFitMode: 'Fit', thumbnailWidth: '100', thumbnailHeight: '100', thumbnailApplyCrop: true }
			],
			metadata: {
				cookie: 'cookie_data',
				exif: 'ExifDateTime'
			}
		});

		//Localize the image uploader
		iu.set(da_localization);

		//Create installation progress.
		var ip = $au.installationProgress(iu);
		ip.progressHtml('<p><img src="{0}" /><br />Indlæser billede uploader...</p>');
		ip.commonHtml('');
		ip.progressImageUrl('/Content/images/loader_bigbar.gif');
		ip.progressCssClass('ip-progress');
		ip.instructionsCssClass('ip-instructions');

		// Add the image uploader html to the page
		$('#imageUploader').html(iu.getHtml());


Anyone else got this problem?
Maybe a solution?
p.shirykalova  
#2 Posted : Tuesday, November 29, 2011 8:41:43 PM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Hi Kenny,

Could you please attach test image to your reply?
I've tested Image Uploader locally and unfortunately failed to reproduce the problem.
Best regards,
Pauline Shirykalova
Aurigma Technical Support
Nikkelmann  
#3 Posted : Tuesday, November 29, 2011 11:33:06 PM(UTC)
Nikkelmann

Rank: Member

Groups: Member
Joined: 11/29/2011(UTC)
Posts: 10

Thanks: 2 times
Sure, here it is.
File Attachment(s):
CIMG1291.zip (209kb) downloaded 1 time(s).
Nikkelmann attached the following image(s):
CIMG1291.JPG
p.shirykalova  
#4 Posted : Wednesday, November 30, 2011 2:46:58 AM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Kenny,

Here is what I've discovered.
EXIF DateTime contains the date when the file was last modified. In your case this is 19-10-2011 08:00:15.
The date which you are seeing on the picture is DateTimeOriginal - the date when the image was taken/created.
That's why you get 19-10-2011 08:00:15 instead of the desired date.
Best regards,
Pauline Shirykalova
Aurigma Technical Support
thanks 1 user thanked p.shirykalova for this useful post.
Nikkelmann on 11/30/2011(UTC)
Nikkelmann  
#5 Posted : Wednesday, November 30, 2011 2:52:03 AM(UTC)
Nikkelmann

Rank: Member

Groups: Member
Joined: 11/29/2011(UTC)
Posts: 10

Thanks: 2 times
Thanks Pauline!

Is there any way I can force the Image Uploader to always use the "DateTimeOriginal" when extracting the exif date?
p.shirykalova  
#6 Posted : Wednesday, November 30, 2011 2:59:31 AM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
I guess you can send this property instead of ExifDateTime:
Code:
metadata: {
                cookie: 'cookie_data',
                exif: 'ExifDateTimeOriginal'
            }

and use its value on server side.
There is no default values for metadata fields sent along with the image - Image Uploader will send whatever you want it to send.
Best regards,
Pauline Shirykalova
Aurigma Technical Support
thanks 1 user thanked p.shirykalova for this useful post.
Nikkelmann on 11/30/2011(UTC)
Nikkelmann  
#7 Posted : Wednesday, November 30, 2011 5:30:27 AM(UTC)
Nikkelmann

Rank: Member

Groups: Member
Joined: 11/29/2011(UTC)
Posts: 10

Thanks: 2 times
Thank you!

What confused me was the api doc:
ExifDateTime: The date and time of image creation.
ExifDateTimeOriginal: The date and time when the original file was created.

Edited by user Wednesday, November 30, 2011 5:31:10 AM(UTC)  | Reason: Not specified

p.shirykalova  
#8 Posted : Wednesday, November 30, 2011 8:53:06 PM(UTC)
p.shirykalova

Rank: Advanced Member

Groups: Member
Joined: 7/13/2011(UTC)
Posts: 286

Thanks: 6 times
Was thanked: 31 time(s) in 31 post(s)
Hi Kenny,

Please see the EXIF specification, these descriptions are correct.
We will change the ExifDateTime and ExifDateTimeOriginal descriptions in our documentation.

Thank you for your assistance. Please feel free to contact me if you have any additional questions.
Best regards,
Pauline Shirykalova
Aurigma Technical Support
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.