Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
samg  
#1 Posted : Monday, October 24, 2011 8:03:50 AM(UTC)
samg

Rank: Member

Groups: Member
Joined: 10/24/2011(UTC)
Posts: 10

Thanks: 1 times
We have a web application that users log in to, and behind the scenes the ASP.NET uses cookies,viewstate,etc to persist the client-side reference to that server-side session - usual stuff.

But the Aurigma Up application gets its own session, which of course no user is logged in to, so our site rejects the upload.

We could workaround by passing a session ID (or equivalent) through Aurigma Up via the href. Doesn't this exposes a security issue though? E.g. someone could view source and get the session id, and use this to spoof requests?
hdemann  
#2 Posted : Monday, October 24, 2011 1:24:11 PM(UTC)
hdemann

Rank: Newbie

Groups: Member
Joined: 10/21/2011(UTC)
Posts: 3

Was thanked: 1 time(s) in 1 post(s)
Hello,

I think that the way to handle this would be to put an encrypted string in the querystring of your uploadURL. I would use a key based on the date or something else in the key to let you check the age of the string.

Anyway, on your handler page, you can validate against this data in the encrypted string.
thanks 1 user thanked hdemann for this useful post.
samg on 10/25/2011(UTC)
samg  
#3 Posted : Tuesday, October 25, 2011 2:35:02 AM(UTC)
samg

Rank: Member

Groups: Member
Joined: 10/24/2011(UTC)
Posts: 10

Thanks: 1 times
Thanks, that's the route I happen to be going down.

I also had other problems in this area.

Within IIS, Directory Security, I had to change Authentication Method from 'Integrated windows' to 'anonymous access', and had to change 'Secure Comms', unticking 'Require secure channel (SSL) (and browse to http: rather than https: on the ipad).

Is there a way of getting these working with Aurigma Up? Safari happily gives me a login dialog in these cases, but Aurigma Up just fails to upload images with an error.

Edited by user Tuesday, October 25, 2011 2:45:32 AM(UTC)  | Reason: Not specified

Dmitry.Obukhov  
#4 Posted : Tuesday, October 25, 2011 3:16:17 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Administration
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Sam,

Please clarify which error occurs when you try to upload files via Aurigma Up and how many files you add.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
samg  
#5 Posted : Tuesday, January 17, 2012 6:54:08 AM(UTC)
samg

Rank: Member

Groups: Member
Joined: 10/24/2011(UTC)
Posts: 10

Thanks: 1 times
Dmitry.Obukhov wrote:
Please clarify which error occurs when you try to upload files via Aurigma Up and how many files you add.


Sorry about the slow reply! I am only adding one file.

SSL

On accessing my site via https, Safari opens a window “Cannot Verify Server Idenitity: Safari cannot verify the identity of “<machine name>”. Would you like to continue anyway? Cancel, Details, Continue”, and Details shows “<machine name>, Not Trusted …” and an Accept button. Clicking Accept makes Safari work (my page appears).

On uploading image, Aurigma Up displays error “Upload Failure: Destination server is unreachable. Please contact the website technical team to resolve this problem.” There is no log from my web application, suggesting it was never reached.

Strangely, if I then access my site via http and upload an image, Aurigma Up displays error “Upload Failure: Redirect is not supported with this website (HTTP code 3xx received). Please contact the website technical team to resolve this problem.” Occasionally, the log from my web application suggests that the posted form data had PackageFileCount>0 but no “File0_0” set. (On unhandled exceptions, our web application logs them and redirects to an error page). In the end closing all the Safari tabs and Aurigma Up seems to 'clear' the error and I am able to upload images again.

IIS Authentication Method

On changing to Integrated Windows Authentication and refreshing Safari, Dialog appears ‘Authentication Required: <machine name>’. Entered username and password and clicking Login button works - my page is shown.

On uploading image, Aurigma Up displays error “Upload Failure: The upload has been interrupted due to some unexpected error. Please contact the website technical team to resolve this problem.” There is no log from my web application, suggesting it was never reached.

Changing back to Anonymous Access, and clicking ‘Start Upload’ in Aurigma Up immediately works again (photo uploads, brings correct page up in Safari, etc).
Dmitry.Obukhov  
#6 Posted : Wednesday, January 18, 2012 9:25:08 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Administration
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hi Sam,

Thanks for these details.

Quote:
On accessing my site via https, Safari opens a window “Cannot Verify Server Idenitity: Safari cannot verify the identity of “<machine name>”. Would you like to continue anyway? Cancel, Details, Continue”, and Details shows “<machine name>, Not Trusted …” and an Accept button. Clicking Accept makes Safari work (my page appears).

On uploading image, Aurigma Up displays error “Upload Failure: Destination server is unreachable. Please contact the website technical team to resolve this problem.” There is no log from my web application, suggesting it was never reached.

I assume that you will need to configure your server to make it work with https correctly setting valid certificate. In this case, you need to ask a person who is responsible for your server side, and discuss this thing with him.

Quote:
Strangely, if I then access my site via http and upload an image, Aurigma Up displays error “Upload Failure: Redirect is not supported with this website (HTTP code 3xx received). Please contact the website technical team to resolve this problem.” Occasionally, the log from my web application suggests that the posted form data had PackageFileCount>0 but no “File0_0” set. (On unhandled exceptions, our web application logs them and redirects to an error page). In the end closing all the Safari tabs and Aurigma Up seems to 'clear' the error and I am able to upload images again.

Please add this if-statement in the script which handles uploaded files:
Code:

if (Request.HttpMethod == "POST" && Request["PackageGuid"] != null)
{
  //… Saving files …
}

Quote:
On changing to Integrated Windows Authentication and refreshing Safari, Dialog appears ‘Authentication Required: <machine name>’. Entered username and password and clicking Login button works - my page is shown.

On uploading image, Aurigma Up displays error “Upload Failure: The upload has been interrupted due to some unexpected error. Please contact the website technical team to resolve this problem.” There is no log from my web application, suggesting it was never reached.

Changing back to Anonymous Access, and clicking ‘Start Upload’ in Aurigma Up immediately works again (photo uploads, brings correct page up in Safari, etc).


Unfortunately, Aurigma Up does not support any authentication set on the server.

If you have any additional questions, please feel free to let me know.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
samg  
#7 Posted : Thursday, January 19, 2012 2:14:17 AM(UTC)
samg

Rank: Member

Groups: Member
Joined: 10/24/2011(UTC)
Posts: 10

Thanks: 1 times
Dmitry.Obukhov wrote:
I assume that you will need to configure your server to make it work with https correctly setting valid certificate. In this case, you need to ask a person who is responsible for your server side, and discuss this thing with him.

I'll get our SSL expert to look into this further. What SSL setup is required for Aurigma Up to work? We setup our own Certificate Authority using Active Directory, rather than using a public authroity (Verisign, etc). Do you support such a setup?

Dmitry.Obukhov wrote:
Please add this if-statement in the script which handles uploaded files:
Code:

if (Request.HttpMethod == "POST" && Request["PackageGuid"] != null)
{
  //… Saving files …
}

What does this do / why is this necessary? Should we have an 'else' block? I notice similar code in the ASP.NET sample you can download, but not the sample on the site. The POST Fields 'PackageGUID' and 'PackageIndex' are not in the Aurigma Up API but are in the Image Uploader API.
Dmitry.Obukhov  
#8 Posted : Thursday, January 19, 2012 11:32:12 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Administration
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Sam,
Quote:
I'll get our SSL expert to look into this further. What SSL setup is required for Aurigma Up to work? We setup our own Certificate Authority using Active Directory, rather than using a public authroity (Verisign, etc). Do you support such a setup?

Aurigma Up supports uploading via HTTPS with valid certificates signed by real certificate authority only. If Safari says “Cannot Verify Server Idenitity:…”, it means that your certificate is not valid, and you cannot upload images with Aurigma Up. You should contact any certificate authority to get signed certificate.
Quote:

What does this do / why is this necessary? Should we have an 'else' block? I notice similar code in the ASP.NET sample you can download, but not the sample on the site. The POST Fields 'PackageGUID' and 'PackageIndex' are not in the Aurigma Up API but are in the Image Uploader API.

Sorry, I was wrong.

It seems that some cookies or sessions variables are lost during the upload process. Please check it.

Edited by user Thursday, January 19, 2012 11:33:20 PM(UTC)  | Reason: Not specified

Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
samg  
#9 Posted : Friday, January 20, 2012 1:45:49 AM(UTC)
samg

Rank: Member

Groups: Member
Joined: 10/24/2011(UTC)
Posts: 10

Thanks: 1 times
Dmitry.Obukhov wrote:
It seems that some cookies or sessions variables are lost during the upload process. Please check it.


How do I check this? I wasn't aware Aurigma Up used any cookies or session variables, I thought the information was passed to it in the query string and passed back in the POST data?
Dmitry.Obukhov  
#10 Posted : Friday, January 20, 2012 1:57:12 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Administration
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Could you please provide me with a link to your page where Aurigma Up is hosted (login/password if any) so that I will be able to test it myself?
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
samg  
#11 Posted : Friday, January 20, 2012 2:47:16 AM(UTC)
samg

Rank: Member

Groups: Member
Joined: 10/24/2011(UTC)
Posts: 10

Thanks: 1 times
I am afraid our site is not on the internet. I have attached the source code behind our page which processes the POST data in case this helps.
File Attachment(s):
ProcessAurigmaUpUpload.aspx.zip (1kb) downloaded 9 time(s).
Dmitry.Obukhov  
#12 Posted : Friday, January 20, 2012 2:55:04 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Administration
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Thanks. I will check it and reply you.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
gcd  
#13 Posted : Thursday, January 26, 2012 3:55:58 PM(UTC)
gcd

Rank: Newbie

Groups: Member
Joined: 1/23/2012(UTC)
Posts: 4

I'm also trying to get this to work using Forms authentication. I've entered the following location key in web.config that should allow access to the upload form without authentication.

<location path="AppleUpload.aspx">
<system.web>
<authorization>
<allow users="*" />
</authorization>
</system.web>
</location>

For some reason it still doesn't work, but if I redirect my site to another site that has Windows authentication and then redirect it back to my site it works. Do you know why?

Dmitry.Obukhov  
#14 Posted : Thursday, January 26, 2012 6:36:47 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Administration
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Quote:
I am afraid our site is not on the internet. I have attached the source code behind our page which processes the POST data in case this helps.

I have checked your code, and try it as a server-side script in ,my application. It worked fine for me. I got no problems while testing it. Could you please send me complete sample application so that I will be able to test it?

Quote:
I'm also trying to get this to work using Forms authentication. I've entered the following location key in web.config that should allow access to the upload form without authentication.

<location path="AppleUpload.aspx">
<system.web>
<authorization>
<allow users="*" />
</authorization>
</system.web>
</location>

For some reason it still doesn't work, but if I redirect my site to another site that has Windows authentication and then redirect it back to my site it works. Do you know why?


Please provide me with a link to your site with Aurigma Up (login/password if any). And also, please post code snippets of client and server side codes.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.