Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
toggy  
#1 Posted : Tuesday, September 20, 2011 3:13:15 AM(UTC)
toggy

Rank: Newbie

Groups: Member
Joined: 9/20/2011(UTC)
Posts: 8

Thanks: 1 times
Hi all,

Just started using this on a website of mine for my new granddaughter, after discovering fileupload in asp doesnt work on the iphone. Problem is the photo appears to upload but i cannot find it anywhere. I have tried various locations and permutaions. the html is:

<a href="aurup:?uploadUrl=http://aimee.is-very-sweet.org/upload.aspx&licenseKey=79FF1-0001F-CEFB0-00008-9623B-9B9FA8&redirectUrl=http://aimee.is-very-sweet.org/upload.aspx&redirectDelay=0&returnUrl=http://aimee.is-very-sweet.org/upload.aspx">Upload Images</a>


and the code in vb is:

Private Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)
Dim fileCount As Integer = Int32.Parse(Request.Form("PackageFileCount"))

For i As Integer = 0 To fileCount - 1
Dim path As String = System.IO.Path.Combine(Server.MapPath("/pics/Uploaded Images/"), Request.Form("SourceName_" & i))

Request.Files("File0_" & i).SaveAs(path)
Next
End Sub


the path is a virtual directory that holds all my images, but i have tried the web site folder etc etc.

This web page also holds an asp upload control for upload from my laptop.

any ideas greatly received.

Many thanks

Billy
Dmitry.Obukhov  
#2 Posted : Tuesday, September 20, 2011 10:06:39 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Billy,

Please check that the path you specify for uploaded images exists. Also, please be sure that the url is correct, and folders have write permissions.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
toggy  
#3 Posted : Wednesday, September 21, 2011 12:23:25 AM(UTC)
toggy

Rank: Newbie

Groups: Member
Joined: 9/20/2011(UTC)
Posts: 8

Thanks: 1 times
Hi Dmitry,

The URL's are working fine and aurigima will redirect to them. The folders are also used for an asp file upload control and they are written to without any problem.

any help much appreciatted.

Cheers

Billy
Dmitry.Obukhov  
#4 Posted : Wednesday, September 21, 2011 1:45:23 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Billy,

Probably you experience this problem because of some server-side limitation such as length of POST request. Please learn additional information on it in this topic and follow the instructions to configure your server. After that, please test uploading images again. Also please try to test uploading small size files (several Kb). Then please let me know about your results.

P.S. I attached our VB sample to my post. Please download and try it out.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
toggy  
#5 Posted : Wednesday, September 21, 2011 2:16:23 AM(UTC)
toggy

Rank: Newbie

Groups: Member
Joined: 9/20/2011(UTC)
Posts: 8

Thanks: 1 times
Dmitry,

Thanks again for this, i have adjust the values you quoted with no effect, i understand what you are saying in regards to post length but i had already adjusted these for the asp upload control.

I am wondering if my coding is wrong, I cannot see your VB sample, this may be helpful.

Kindest regards

Billy
Dmitry.Obukhov  
#6 Posted : Wednesday, September 21, 2011 2:27:32 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Sorry. Here is sample :)
File Attachment(s):
Samples_iPhoneUploaderJavaScript_vb.zip (196kb) downloaded 26 time(s).
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
toggy  
#7 Posted : Friday, September 23, 2011 5:55:04 AM(UTC)
toggy

Rank: Newbie

Groups: Member
Joined: 9/20/2011(UTC)
Posts: 8

Thanks: 1 times
Thanks again Dmitry,

Sorted one problem out.....after some frantic debugging, i discovered the page_load event wasnt firing, "autoeventwireup" was set to false......Doh!!!!!


After a quick change, fired it up, however i am getting an error on the first line. "Value cannot be null. Parameter name : string" triggered from this line "Dim fileCount As Integer = Int32.Parse(Request.Form("PackageFileCount"))"

Checked file size etc again and advice from above but to no avail.

Any ideas?

Billy
toggy  
#8 Posted : Friday, September 23, 2011 6:35:45 AM(UTC)
toggy

Rank: Newbie

Groups: Member
Joined: 9/20/2011(UTC)
Posts: 8

Thanks: 1 times
OK, apologies, despite the error its uploading the files beautifully....very easy to use (despite my extremly rubbish coding).
Works well over lan.
just need a blackberry and android version now :)

But any ideas to resolve the error much appreciated

Billy
Dmitry.Obukhov  
#9 Posted : Sunday, September 25, 2011 6:19:03 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Billy,

Please try to use this line:
Code:
Dim fileCount As Integer = Integer.Parse(Request("PackageFileCount"))

Instead of this one:
Code:
Dim fileCount As Integer = Int32.Parse(Request.Form("PackageFileCount"))
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
toggy  
#10 Posted : Monday, September 26, 2011 3:01:28 AM(UTC)
toggy

Rank: Newbie

Groups: Member
Joined: 9/20/2011(UTC)
Posts: 8

Thanks: 1 times
Hi Dmitry,

I have tried this, but to no avail. however, it seems to be saving images without any issues (apart from the error). I dont understand this as i have added a streamwriter in order to capture some data but this does not appear to be firing either, yet this code is before the save path, so i would have thought that it would have not followed any code as the error is on line 1?

Thanks again.....

Billy
Dmitry.Obukhov  
#11 Posted : Monday, September 26, 2011 8:42:55 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Billy,

Unfortunately, we cannot replicate it locally. We will check it again. If we research something, we will let you know about.

Edited by user Tuesday, September 27, 2011 2:27:50 AM(UTC)  | Reason: Not specified

Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
thanks 1 user thanked Dmitry.Obukhov for this useful post.
toggy on 9/27/2011(UTC)
toggy  
#12 Posted : Tuesday, September 27, 2011 2:22:22 AM(UTC)
toggy

Rank: Newbie

Groups: Member
Joined: 9/20/2011(UTC)
Posts: 8

Thanks: 1 times
Thanks Dmitry,

I will continue to look at this, and check out some asp forums. If i find the problem i will let you know.

Cheers

Billy
toggy  
#13 Posted : Tuesday, September 27, 2011 3:17:01 AM(UTC)
toggy

Rank: Newbie

Groups: Member
Joined: 9/20/2011(UTC)
Posts: 8

Thanks: 1 times
Sorted!!!!


The redirect was the same as the upload page.....Doh, so when it was redirecting there was nothing in the package.

Many thanks for all your help

Billy
Dmitry.Obukhov  
#14 Posted : Tuesday, September 27, 2011 3:19:12 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Billy,

Thank you for your comment. I tested my page without redirect url. Here is the deference between our samples. Thank you very much for your assistance. If you have any questions or problems, please feel free to contact us.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.