Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
PatrickTT  
#1 Posted : Thursday, April 7, 2011 2:16:32 PM(UTC)
PatrickTT

Rank: Newbie

Groups: Member
Joined: 4/7/2011(UTC)
Posts: 9

Hi, I am trying to install Aurigma on a website developed using CakePHP 1.3 as the framework.

I have put all the classes into /app/vendors/ImageUploaderPHP and have put all the scripts into /app/webroot/js/ImageUploaderPHP.

I have imported the vendor into the controller where I want to display the uploader, and have set the scriptsDirectory as well.

The uploader gets as far as a grey box of the dimensions I gave it, but every time it says that the Applet is Not Initialized. There are no errors in the normal error console, and unfortunately in Firefox 4 there doesn't seem to be a Java Console so I can't check there.

I also have the following setting in core.php: Configure::write('Session.checkAgent', false);

Does anyone know how I can find out why the applet is not initializing and what I could do to fix it? I am using a trial license key, so not sure if that has anything to do with it.

Thanks

Patrick
Dmitry.Obukhov  
#2 Posted : Friday, April 8, 2011 2:59:12 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Member
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Patrick,

Please share the source code of the page with Image Uploader settings. I will look through it.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
PatrickTT  
#3 Posted : Sunday, April 10, 2011 7:55:58 PM(UTC)
PatrickTT

Rank: Newbie

Groups: Member
Joined: 4/7/2011(UTC)
Posts: 9

Hi Dmitry, I actually have managed to get it working in Firexfox through setting the following before render:
Code:
$uploader->getActiveXControl()->setCodeBase('/js/ImageUploaderPHP/Scripts/ImageUploader7.cab');
			$uploader->getActiveXControl()->setCodeBase64('/js/ImageUploaderPHP/Scripts/ImageUploader7_x64.cab');
			$uploader->getJavaControl()->setCodeBase('/js/ImageUploaderPHP/Scripts/ImageUploader7.jar');


It still isn't working from linux though. the full cakephp init code is as follows:

Code:
$uploader = new Uploader("ImageUploader");

//settings
$uploader->setScriptsDirectory('/js/ImageUploaderPHP/Scripts');

$uploader->getActiveXControl()->setCodeBase('/js/ImageUploaderPHP/Scripts/ImageUploader7.cab');
$uploader->getActiveXControl()->setCodeBase64('/js/ImageUploaderPHP/Scripts/ImageUploader7_x64.cab');
$uploader->getJavaControl()->setCodeBase('/js/ImageUploaderPHP/Scripts/ImageUploader7.jar');

$uploader->setWidth("650px");
$uploader->setHeight("480px");

// specify a license key
$uploader->setLicenseKey("XXXX-XXXX-XXXX-XXXX");

// configure upload settings
$uploader->getUploadSettings()->setActionUrl($html->url(array('plugin' => 'gallery', 'controller' => 'gallery_albums', 'action' => 'admin_images_upload'), true));
$uploader->getUploadSettings()->setRedirectUrl($html->url(Router::url($this->here, true)));

//configure uploaded files
$converters = &$uploader->getConverters();

// uploading thumbnail
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
// set thumbnail size
$converter->setThumbnailWidth(720);
$converter->setThumbnailHeight(480);
$converter->setThumbnailFitMode("Fit");
$converters[] = $converter;

// uploading thumbnail
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
// set thumbnail size
$converter->setThumbnailWidth(225);
$converter->setThumbnailHeight(150);
$converter->setThumbnailFitMode("Fit");
$converters[] = $converter;

$uploader->render();


So now in Linux, it says Applet Loaded, then Start: applet not initialized. I'm not sure this is such a major issue, but would be nice to fix.

Real question is how to get it to use the callbacks. Will make a new post for that.

Thanks
Dmitry.Obukhov  
#4 Posted : Monday, April 11, 2011 11:54:39 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Member
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Patrick,

Could you please provide me with Java console output when Image Uploader is loaded? Also, please let me know in which browser on Linux you try to load applet.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
PatrickTT  
#5 Posted : Tuesday, April 12, 2011 3:40:19 AM(UTC)
PatrickTT

Rank: Newbie

Groups: Member
Joined: 4/7/2011(UTC)
Posts: 9

Hi Dmitry, I am using Firefox 4 on Linux Ubuntu.

Code:
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.1) (6b22-1.10.1-0ubuntu1)
OpenJDK Server VM (build 20.0-b11, mixed mode)
Unable to use Firefox's proxy settings. Using "DIRECT" as proxy type.
Aurigma Image Uploader: version: 7.0.15.0
Aurigma Image Uploader: build date: 2010/12/17
Aurigma Image Uploader: current document URL: http://****/gallery/gallery_albums/admin_images/
java.lang.NoClassDefFoundError: IllegalName: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"><html xmlns="http://www.w3.org/1999/xhtml">
	at java.lang.ClassLoader.preDefineClass(ClassLoader.java:491)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:628)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
	at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader$CodeBaseClassLoader.findClass(JNLPClassLoader.java:1346)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.findClass(JNLPClassLoader.java:1088)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.loadClassExt(JNLPClassLoader.java:1105)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.loadClass(JNLPClassLoader.java:1008)
	at javax.xml.parsers.FactoryFinder.getProviderClass(FactoryFinder.java:113)
	at javax.xml.parsers.FactoryFinder.newInstance(FactoryFinder.java:144)
	at javax.xml.parsers.FactoryFinder.findJarServiceProvider(FactoryFinder.java:296)
	at javax.xml.parsers.FactoryFinder.find(FactoryFinder.java:221)
	at javax.xml.parsers.DocumentBuilderFactory.newInstance(DocumentBuilderFactory.java:121)
	at java.util.prefs.XmlSupport.loadPrefsDoc(XmlSupport.java:241)
	at java.util.prefs.XmlSupport.importMap(XmlSupport.java:375)
	at java.util.prefs.FileSystemPreferences$7.run(FileSystemPreferences.java:578)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.util.prefs.FileSystemPreferences.loadCache(FileSystemPreferences.java:571)
	at java.util.prefs.FileSystemPreferences.initCacheIfNecessary(FileSystemPreferences.java:554)
	at java.util.prefs.FileSystemPreferences.getSpi(FileSystemPreferences.java:531)
	at java.util.prefs.AbstractPreferences.get(AbstractPreferences.java:287)
	at com.aurigma.imageuploader.e.aa.d(Unknown Source)
	at com.aurigma.imageuploader.licensing.h.a(Unknown Source)
	at com.aurigma.imageuploader.licensing.h.a(Unknown Source)
	at com.aurigma.imageuploader.ImageUploader.d(Unknown Source)
	at com.aurigma.imageuploader.ImageUploader.init(Unknown Source)
	at sun.applet.AppletPanel.run(AppletPanel.java:436)
	at net.sourceforge.jnlp.NetxPanel.run(NetxPanel.java:69)
	at java.lang.Thread.run(Thread.java:679)


hmmm... just looking through this some more, the url it should be accessing is actually http://.../gallery/gallery_albums/admin_images/1

CakePHP does use sessions for the Auth, could this have anything to do with it? I have set the Configure::write('Session.checkAgent', false); in the core file, but I can't see where to set the preserveHttpCookies as mentioned in a different CakePHP thread. Could this be causing it to not work?

It definitely works in Firefox on Windows Vista

** EDIT **

Weird thing... if I start firefox using the terminal as root then aurigma loads... so there must be a permissions thing perhaps..

Edited by user Tuesday, April 12, 2011 5:20:51 AM(UTC)  | Reason: Not specified

andreym  
#6 Posted : Tuesday, April 12, 2011 7:49:04 PM(UTC)
andreym

Rank: Advanced Member

Groups: Member
Joined: 6/16/2009(UTC)
Posts: 134

Was thanked: 8 time(s) in 8 post(s)
Hi Patrick,

does the applet work on http://demo.aurigma.com/...7/BasicDemo/Default.aspx on the same machine with ubuntu where you get this error?
PatrickTT  
#7 Posted : Wednesday, April 13, 2011 12:09:54 AM(UTC)
PatrickTT

Rank: Newbie

Groups: Member
Joined: 4/7/2011(UTC)
Posts: 9

sure does, so must be something to do with the filepaths. still seems strange that mine would work as root user but not normally.
andreym  
#8 Posted : Thursday, April 14, 2011 5:58:21 AM(UTC)
andreym

Rank: Advanced Member

Groups: Member
Joined: 6/16/2009(UTC)
Posts: 134

Was thanked: 8 time(s) in 8 post(s)
Hi Patrick,

Quote:
sure does, so must be something to do with the filepaths.

That is good. Thanks for trying that.

I think, that java tries to connect somewhere else except to the ImageUploader7.jar. And getting the incorrect response from there breaks the applet loading. Can you post java console log one more time, but with maximum trace level (5) now. To do so press "5" in java console before applet loading.
Quote:
0-5: set trace level to <n>

Trace level set to 5: all ... completed.


You also can look at web server logs. May be some strange errors will be there.
PatrickTT  
#9 Posted : Tuesday, April 19, 2011 4:43:26 PM(UTC)
PatrickTT

Rank: Newbie

Groups: Member
Joined: 4/7/2011(UTC)
Posts: 9

not sure i can do that when just using the console log through the terminal? will try again though but no joy so far...
Dmitry.Obukhov  
#10 Posted : Wednesday, April 20, 2011 3:21:23 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Member
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Patrick,

Looking forward to your reply.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.