Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
eg_hch  
#1 Posted : Tuesday, January 18, 2011 12:40:58 AM(UTC)
eg_hch

Rank: Member

Groups: Member
Joined: 6/13/2006(UTC)
Posts: 22

Hi, I am Jerry.
Our company has been using Imageuploader 4 for years on our web application.
Now, we are trying to migrate the system to Windows Server 2008 64-bit, but then we found that it will have a HTTP 400 bad request error from the server every time when we click the upload button
I have tried the basic demo from the sample, the error still occurs.
It always display this error message: "Image Uploader encountered some problem. If you see this message, contact web master."

Do you have any recommendations for me in this issue? Or i have to buy the new version of Imageuploader to solve it?
Dmitry.Obukhov  
#2 Posted : Tuesday, January 18, 2011 2:18:35 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Jerry,

IIS 7.5 did not want to recognize POST requests sent by Image Uploader 4.x (to v6.1.4) as a properly formed and returned HTTP error 400.

Please read detailed information on this problem in the Compatibility of Image Uploader with New Microsoft Windows 7 and Windows 2008 R2 article on our blog.

The only way to resolve the problem is to update your version of Image Uploader to the v6.5.19 at least. Now Image Uploader 7 is available on our site.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Albertvdmeulen  
#3 Posted : Monday, January 31, 2011 4:12:08 AM(UTC)
Albertvdmeulen

Rank: Advanced Member

Groups: Member
Joined: 3/18/2009(UTC)
Posts: 46

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Hi Dmitry,

Overhere we have almost the same problem.
We had Windows 2003 with IIS6 and transfered to Windows 2008RC2 IIS7.
Small uploads are fine, but with the larger ones we'll get the same error message.

I've done an fresh install of joomla,virtuemart and the aurigma photoorder plugin, but still this error over here.

Could it have something to do with the web.config?
We have changed this in the web.config:

Code:
<configuration>

       <system.web>
             <httpRuntime executionTimeout="999999" maxRequestLength="585933" />
       </system.web>

       <system.webServer>
             <directoryBrowse enabled="false" />
                    <defaultDocument>
                           <files>
                                  <add value="index.php" />
                                  <add value="index2.php" />
                           </files>
                    </defaultDocument>

             <security>
                    <requestFiltering>
                           <requestLimits maxAllowedContentLength="600000000" />
                    </requestFiltering>
             </security>
             
             <!--<httpRuntime executionTimeout="999999" maxRequestLength="585933" />-->
       </system.webServer>
</configuration> 


If the file uploads within 120 seconds no problem, if the uploads takes more than 120 sec: error.
I even reduced the packetsize to 1 in the aurigma settings.

Hope you can help me out,
With kind regards,

Rob

Edited by moderator Tuesday, February 1, 2011 12:28:13 AM(UTC)  | Reason: Not specified

Dmitry.Obukhov  
#4 Posted : Monday, January 31, 2011 4:23:14 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Rob,

I think you need to configure your PHP.ini file. Please read detailed information here:
http://www.aurigma.com/d...ples.htm#Troubleshooting
Please pay attention to value of max_execution_time variable.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Albertvdmeulen  
#5 Posted : Monday, January 31, 2011 6:08:33 AM(UTC)
Albertvdmeulen

Rank: Advanced Member

Groups: Member
Joined: 3/18/2009(UTC)
Posts: 46

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Hi Dmitry,

We copied the php.ini settings from the old server these values are:
Code:

max_execution_time	1200	
max_file_uploads	250	
memory_limit	        500M	
upload_tmp_dir	        D:\DATA\Bestellingen FTP server\tmp	


Looks fine to me.

Regards,

Rob
Dmitry.Obukhov  
#6 Posted : Tuesday, February 1, 2011 2:00:45 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hi Rob,

Could you please clarify what version of Image Uploader you use?

If it is earlier than v6.1.4, it will not work on IIS 7. Please read info on it here. You need to update your version to Image Uploader 6.5.19 at least as it was suggested in my previous post of this thread.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Albertvdmeulen  
#7 Posted : Wednesday, February 2, 2011 2:17:01 AM(UTC)
Albertvdmeulen

Rank: Advanced Member

Groups: Member
Joined: 3/18/2009(UTC)
Posts: 46

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Dear Dmitry,

I've downloaded the latest Image uploader version.
Image Uploader 6 SDK (Express/Standard/Pro, Windows-only installer) 9/1/2010 6.5.19.0

Also what i did i made an fresh install of joomla, virtuemart and downloaded the trial version of the aurigma site (the latest version) but still ther same problem.

http://213.125.49.11/joomla
Is the fresh install.

If the file uploads within 120 seconds no problem, if the uploads takes more than 120 sec: error.

Hope to hear from you,
kind regards,

Rob
Dmitry.Obukhov  
#8 Posted : Wednesday, February 2, 2011 3:16:00 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Rob,

Thank you for the test link.

I checked it, and experienced the same problem as you did. It seems that it is caused by server-side limitation. Please clarify what values you set for post_max_size and upload_max_filesize variables in your php.ini.

Please do not remove this link. Probably, it will be necessary again :)
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Albertvdmeulen  
#9 Posted : Wednesday, February 2, 2011 4:42:32 AM(UTC)
Albertvdmeulen

Rank: Advanced Member

Groups: Member
Joined: 3/18/2009(UTC)
Posts: 46

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Dear Dmitry,

Code:

post_max_size	        500M
max_file_uploads	250
max_execution_time	1200
upload_max_filesize	500M


Nothing seems wrong, copied the php.ini settings from the old server.

Regards,

Rob
Dmitry.Obukhov  
#10 Posted : Thursday, February 3, 2011 3:13:41 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Rob,

Sorry that the problem is not resolved yet.

I tested your link today once again. I uploaded just one image (12 Mb). The upload failed when the server response is been waiting. It takes too much time. The parameters you set in your PHP.ini file is okay, and the behavior of Photo Order is strange.

So, I have to ask you ask about one thing else. Please provide me with php error log when the error occurs.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Albertvdmeulen  
#11 Posted : Thursday, February 3, 2011 5:58:15 AM(UTC)
Albertvdmeulen

Rank: Advanced Member

Groups: Member
Joined: 3/18/2009(UTC)
Posts: 46

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Hi Dmitry,

You have an PM.
Code:
[03-Feb-2011 14:03:16] PHP Notice:  Undefined variable: mosConfig_absolute_path in D:\wwwroot\onlinefotoservice\includes\ideal.php on line 20
[03-Feb-2011 14:03:16] PHP Warning:  require_once(/components/com_virtuemart/virtuemart_parser.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in D:\wwwroot\onlinefotoservice\includes\ideal.php on line 20
[03-Feb-2011 14:03:16] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/components/com_virtuemart/virtuemart_parser.php' (include_path='.;C:\php5\pear') in D:\wwwroot\onlinefotoservice\includes\ideal.php on line 20


Regards,

Rob

Edited by moderator Friday, February 4, 2011 1:38:11 AM(UTC)  | Reason: Not specified

Dmitry.Obukhov  
#12 Posted : Friday, February 4, 2011 3:35:54 AM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Rob,

Unfortunately, error log does not give any helpful information to find the reason of this problem.
There is one thing else you can try to change. It is IIS timeouts. Please open IIS, click FastCGI Settings, and increase the values of timeouts.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
thanks 1 user thanked Dmitry.Obukhov for this useful post.
Albertvdmeulen on 2/5/2011(UTC)
Albertvdmeulen  
#13 Posted : Friday, February 4, 2011 4:34:52 AM(UTC)
Albertvdmeulen

Rank: Advanced Member

Groups: Member
Joined: 3/18/2009(UTC)
Posts: 46

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Dear Dmitry,

UserPostedImage
http://213.125.49.11/joomla/images/fastcgi.jpg
Should we set the request timeout?

we have always set the cgi to 2880

UserPostedImage
http://213.125.49.11/joomla/images/cgi.jpg

With kind regards,

Rob

Edited by user Friday, February 4, 2011 4:38:24 AM(UTC)  | Reason: Not specified

Albertvdmeulen  
#14 Posted : Saturday, February 5, 2011 1:18:43 AM(UTC)
Albertvdmeulen

Rank: Advanced Member

Groups: Member
Joined: 3/18/2009(UTC)
Posts: 46

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
Dear Dmitry,

Thanks for this. This solved our problem.Applause
Changing the fast-cgi time-out settings to 2880 and all uploads are coming in.

We even had contact with Microsoft about this problem, but they couldn't figure it out.

You are our hero of todayApplause .

With kind regards,

Rob
Dmitry.Obukhov  
#15 Posted : Sunday, February 6, 2011 7:36:53 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Rob,

Thank you for your comment. I am glad that the problem has been resolved :)

Please feel free to let me know if you have any questions or problems.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.