Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
bharathn4u  
#1 Posted : Tuesday, October 19, 2010 2:07:51 PM(UTC)
bharathn4u

Rank: Newbie

Groups: Member
Joined: 10/19/2010(UTC)
Posts: 3

Hi

I am getting authentication issue while uploading the images using aurigma in firefox. Think

The authentication mode used is windows.

Can some one suggest how to retain the authentication cookie while uploading the images.

Any kind of suggestion or solution will be helpful

Thanks

Dmitry.Obukhov  
#2 Posted : Tuesday, October 19, 2010 4:32:40 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Member
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello,

Thanks for contacting us.

Could you explain more detailed what exact problem you have experienced please?

Please read additional information on how to add authentication in the Adding Authentication article, and how to preserve session and authentication in the Preserving Sessions and Authentication Tickets Passed in Cookies article.

Best regards,

Dmitry Obukhov

Technical Support. Aurigma, Inc.

bharathn4u  
#3 Posted : Friday, October 22, 2010 1:34:18 AM(UTC)
bharathn4u

Rank: Newbie

Groups: Member
Joined: 10/19/2010(UTC)
Posts: 3

Thanks for your resonse. We have dual license. We have this issue in Firefox but works fine with IE. We have setup IIS Server for Windows Authentication type NTLM. When we tried to upload images by clicking "Send" button in aurigma control, we got authentication window asking for username, password and domain information. After providing all the details, it tries to authenticate and pop-up the authentication window again. It means it is failing in authentication. This goes in a loop. It fails uploading if we cancel the authentication.

Please note that as per the URL you have provided, we have added the parameter "AuthenticationType" as "NTLM" with the Aurigma object parameter. But still the problem persists. We are not using session in our application. And as per the topic on "Preserving sessions and Authentication Tickets Passed in Cookies" link it looks like, we need to add cookie. But the sample shows adding cookie from Request.Cookies["ASP.NET_SessionId"].Value. We are actually supporting windows authentication and not form authentication. We are also not using Session. How do we go about it?

Thanks in Advance

Dmitry.Obukhov  
#4 Posted : Sunday, October 24, 2010 8:15:56 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Member
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello,

Thanks for your details.

It is a known problem. Unfortunately, it is not available to change this behavior in Image Uploader Java. At the first time when you enter login information, it is browser asks you, at the second time, it is Image Uploader. Since Image Uploader cannot take user credentials from browser due to Java restrictions, so you need to enter it twice.

If you have any additional questions or problems, please let me know.

Best regards,

Dmitry Obukhov

Technical Support. Aurigma, Inc.

bharathn4u  
#5 Posted : Tuesday, October 26, 2010 7:45:22 PM(UTC)
bharathn4u

Rank: Newbie

Groups: Member
Joined: 10/19/2010(UTC)
Posts: 3

Here the issue we are facing is not with the 2 pop ups. We are fine with 2 login popup screens. Browswer login pop-up authenticates the user information properly. When Aurigma control asks for login credentials, it is not validating with the windows Active directory as we have set the IIS as NTLM security mode. It gives error and again asks for login credentials in a popup screen. This goes in loop. If we cancel the authentication pop up screen, aurima control stops uploading and throws error.

Is there any configuration to make aurigma control authenticate with IIS in NTLM mode?

Please note that we have already set the property AuthenticationType="Ntlm" with ImageUploader control.

Thanks in Advance

Dmitry.Obukhov  
#6 Posted : Wednesday, October 27, 2010 2:36:17 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups: Member
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello,

To resolve your problem in timely manner, could you please provide me with a link to your site (login/password if any), where you experience the problem? If you do not want to post it on the public forum, please submit a new support ticket.

Best regards,

Dmitry Obukhov

Technical Support. Aurigma, Inc.

Users browsing this topic
Similar Topics
Aurigma Image Uploader issue in firefox (Discussions – ActiveX/Java Uploader)
by vimala 12/2/2010 11:54:37 PM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.