Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Del  
#1 Posted : Sunday, September 19, 2010 2:08:36 AM(UTC)
Del

Rank: Member

Groups: Member
Joined: 12/9/2009(UTC)
Posts: 10

Hello,

I have been working on this for days now and am having a problem which i cannot seem to solve!

I have ImageUploader 6.5.6 (IU) on my site which uploads images reliably to the server, into dynamic folders etc! All works fine!

Problem i am having is that, i have just changed development machines and i copied the code back to my computer from the server, and tried to test it there.

It is exactly as it is on the server, but it will not work at all on localhost! I just keep getting the error Server or Proxy cannot be found.

I have checked the help on here, and checked the location of the action file. It is a relative path and is pointing to the right place. I have tried moving it into the same, parent and a sub folder, each with the corresponding link, and none work!

Also, the form that gets submitted with the IU is not adding any of the paramaters to the form, like FileCount.


Am I missing something really basic that i should have done to enable IU to run locally?


If i access my live website, the image uploader works fine, so it is not a problem with the java install on my computer, or the code, as it is exactly the same as the server. therefore all i can think it that it is a problem with my dev machine setup.


Any help would be greatly appreciated!

Regards,

Del
Dmitry.Obukhov  
#2 Posted : Sunday, September 19, 2010 6:31:22 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Del,

The message “The server or proxy not found" states that the server with the name, specified in the Action parameter cannot be found. The reasons could be:
  • The Action property is specified incorrectly or contains misprints.
  • The specified server is down.
  • The specified server is accessible via proxy, but the proxy settings are not set in a browser.
  • If the previous reason is eliminated, and you still encounter this problem in Image Uploader Java try to configure Java to use proxy settings from the default browser. To do it, open Java Control Panel, click Network Settings..., and then click Use browser settings in the Network Settings window.
If you have any additional questions or problems, please feel free to let me know.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Del  
#3 Posted : Sunday, September 19, 2010 7:30:15 PM(UTC)
Del

Rank: Member

Groups: Member
Joined: 12/9/2009(UTC)
Posts: 10

Hello Dmitry,

I had seen this in the KB article, and have been through each point.

The action property is exactly as it is on the server, and i have attempted several alternatives and none work.

The server is not down as i was accessing it at the same time.

Proxy is not required by the server, and the java console uses the browser settings.


Now i'm at a loose end!!


The exact same code works perfectly on the live server.

Am I missing any other settings?



Regards,

Del
Dmitry.Obukhov  
#4 Posted : Monday, September 20, 2010 6:18:46 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Del,

Could you specify value of Action property as absolute URL just for testing purposes?
Code:
iu.addParam("Action", "http://www.mydomain.com/upload.aspx");

Also, please let me know do you experience this problem in both Image Uploader Java and ActiveX versions?
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Del  
#5 Posted : Monday, September 20, 2010 8:19:01 PM(UTC)
Del

Rank: Member

Groups: Member
Joined: 12/9/2009(UTC)
Posts: 10

Hello again Dmitry,

Thanks for your help on this.

I've tried the absolute url and other methods.


I've had a bit of a breakthrough!

It seems that the Request.Form is null.

Not sure if that is a permissions based thing on my computer or what, but it's driving me mental!


Cheers, Del
Del  
#6 Posted : Monday, September 20, 2010 11:15:02 PM(UTC)
Del

Rank: Member

Groups: Member
Joined: 12/9/2009(UTC)
Posts: 10

I've just found out some more information!

The Activex version in IE works fine.

The javascript version does not.

Am I right in thinking that the Action script is fine, as the same script is used in both javascript and Activex.


Also, the first time i ran the activex, it tried to redirect me to a [actionscript address]browserallowcookie=1

Cheers.

Del
Del  
#7 Posted : Monday, September 20, 2010 11:51:46 PM(UTC)
Del

Rank: Member

Groups: Member
Joined: 12/9/2009(UTC)
Posts: 10

Uploading to http://localhost/IUCode-Watermark.aspx
Cookies:[uks_viewpics=Region=Newcastle Upon Tyne;.ASPXFORMSAUTH=26028D4C3D82F88677CB53CC9F4D7747FCB1EE7EAA3E93C4EEEBAEAAB3E9B10E397D6A5BC9CA8910BF7137CCFFC168A455BD3089AC2F036FA692E080C7AD1C52;ASP.NET_SessionId=okf2sdiplpy1ux45lazfxj55]
network: Connecting http://localhost/IUCode-Watermark.aspx with proxy=DIRECT
Setting HTTP params: Host=localhost
Starting upload
network: Connecting http://localhost:80/ with proxy=DIRECT
###Error occurred###
Status=[ERROR]
Progress=[0]
ValueMax=[0]
Value=[2]
[ErrorPage]
localhost
[EndOfErrorPage]

Here is a copy of the Java console.

When I click upload in the Java version, it does all the usual processing, etc, then it tries to do the upload. It will attempt to upload or complete the download, and hang for around 2-3min each time, before eventually giving the "The server or proxy not found" error message.


As mentioned before, the Activex one works as it should.

Regards,

Del
Dmitry.Obukhov  
#8 Posted : Tuesday, September 21, 2010 3:30:04 PM(UTC)
Dmitry.Obukhov

Rank: Advanced Member

Groups:
Joined: 5/29/2010(UTC)
Posts: 1,310

Thanks: 8 times
Was thanked: 111 time(s) in 111 post(s)
Hello Del,

Thanks for details.

Could you attach your .aspx file where you imbed and configure Image Uploader? I need it to try reproducing the problem in our test lab locally. Also, it would be great if you send me page from URL of Action property.
If you do not want to attach your files on forum, you will be able to submit support ticket.

Looking forward to your reply.
Best regards,
Dmitry Obukhov
Technical Support. Aurigma, Inc.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.