Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
nkrisko  
#1 Posted : Sunday, September 12, 2010 3:04:53 PM(UTC)
nkrisko

Rank: Member

Groups: Member
Joined: 9/12/2010(UTC)
Posts: 15

hi, tried installing the plug-in as per installation guide on your website.
Copied all the files, put in the license key, etc.

When I then tried to upload the install.sql file in the admin panel, it returned this error:

Quote:
1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'products_options WHERE products_options_name='Photo'' at line 1
in:
[DELETE FROM zen_ products_options WHERE products_options_name='Photo';]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.


I'm installing on a DreamHost server, running ZenCart 1.3.9f.

Any ideas? the plug-in seems to install, just not sure what affect it'll have on it workig correctly?

Nathan
nkrisko  
#2 Posted : Sunday, September 12, 2010 3:10:07 PM(UTC)
nkrisko

Rank: Member

Groups: Member
Joined: 9/12/2010(UTC)
Posts: 15

okay, it did seem to have an effect.

photo category wasn't created.

also, trying to add a photo item results in:

Quote:
1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 0)' at line 1
in:
[INSERT INTO zen_products_attributes (products_id, options_id, attributes_price_base_included) VALUES (1, , 0)]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.
andreym  
#3 Posted : Sunday, September 12, 2010 9:45:07 PM(UTC)
andreym

Rank: Advanced Member

Groups: Member
Joined: 6/16/2009(UTC)
Posts: 134

Was thanked: 8 time(s) in 8 post(s)
Hello!

There was a small bug in the install.sql file. I put two spaces after DELETE FROM and before products_options statements. In most cases it was not an issue, but if your ZC tables has a prefix... then it fails Sick
Can you please download the updated version. It should work now.

Thanks!
nkrisko  
#4 Posted : Sunday, September 12, 2010 11:47:37 PM(UTC)
nkrisko

Rank: Member

Groups: Member
Joined: 9/12/2010(UTC)
Posts: 15

hi andrey, just saw that only a few minutes before your reply.
just DL'd it and it installed okay.

still didn't create the photo category, but once i did that manually, i could add photo items and seems to work okay.

now to test it out. thanks.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.