Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
photo_tom  
#1 Posted : Friday, December 05, 2003 9:45:00 PM(UTC)
photo_tom

Rank: Member

Groups: Member
Joined: 11/27/2003(UTC)
Posts: 29

When I use:

Code:
<PARAM NAME="FileMask" VALUE="*.jpg">
<PARAM NAME="FileMaskSeparator" VALUE="|">


I get no files returned in my list. When I use *.* for Filemask, I get all of them. I need to restrict my users to only being able to upload JPG files for now as the downstream app cannont handle (as of yet) tiff files.

Edited by user Thursday, December 20, 2007 6:38:34 PM(UTC)  | Reason: Not specified

Tom Thorp
Still waters, great photos
Andrew  
#2 Posted : Friday, December 05, 2003 10:05:00 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 866

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
You should specify only extension (without wildcard "*."):

Code:
<PARAM NAME="FileMask" VALUE="jpg">

Edited by user Thursday, December 20, 2007 6:38:56 PM(UTC)  | Reason: Not specified

Fedor  
#3 Posted : Friday, December 05, 2003 10:11:00 PM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,530

Thanks: 4 times
Was thanked: 53 time(s) in 52 post(s)
To show jpeg files with all possible extensions it is better to use:


Best regards,
Fedor Skvortsov
dairyman  
#4 Posted : Thursday, February 26, 2004 12:11:00 PM(UTC)
dairyman

Rank: Member

Groups: Member
Joined: 2/26/2004(UTC)
Posts: 4

:|

is the FileMask parameter something which works in later version?

I have demo version 1.8.2.12 which doesnt seem to recognize the


I want all the files in the folder to display. is 1.8.2.12 capable of uploading all the file types (non - image too) ? or like I see it is strictly a feature in the Version 2.0

thank you very much for your time
Andrew  
#5 Posted : Thursday, February 26, 2004 1:06:00 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 866

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
This feature is undocumented in the current version. Let me describe how does it work (it will work in the same way in version 2.0).

Image Uploader provides two ways to filter files. First one filters files analyzing its real type. It checks file content instead of just checking extensions. It prevents malicious people to rename executable files to *.jpg or some other "safe" file type. This filter is managed by FileFilter param. Possible values are "Image" (default one - allows only JPEG, GIF and BMP), "Known" (allows a bunch of "safe" file types, like images, mp3, some video formats, PDF, etc), and "All" (disables this filter).

After FileFilter, Image Upload applies FileMask which hides all files which have inappropriate extension. As default FileFilter value is "Image", FileMask is not applied to non-image files at all, that's why these files are invisible.

So if you want to display all the files, you should set FileFilter to All:

Code:
<param name="FileFilter" value="All">


Please let me know if you have any other questions.

Edited by user Thursday, December 20, 2007 6:39:14 PM(UTC)  | Reason: Not specified

dairyman  
#6 Posted : Thursday, February 26, 2004 3:52:00 PM(UTC)
dairyman

Rank: Member

Groups: Member
Joined: 2/26/2004(UTC)
Posts: 4

that worked like a charm. thank you so much for the quick reply.

One more small problem I was facing was - on the server side, I am getting the same file being sent twice ( like duplicates) .We have a server side JSP page which processes the uploaded files and it prints in the debug something like below (when I select only 2 files):

parseMultipart -> Fileupload for C:\test\file7\alt.asp
parseMultipart -> Fileupload for C:\test\file7\alt.asp
parseMultipart -> Fileupload for C:\test\file7\default.asp
parseMultipart -> Fileupload for C:\test\file7\default.asp

(please note that I am using Image uploader for non-image files)

I think the uploader is trying to send the image and a thumbnail? I am not sure.

Also how would I turn off the thumbnail and rotation features completely off (in the demo)and get a display something like this (maybe its a feature addeed in Version 2 ?).
http://www.aurigma.com/p...er/Screens20/Screen3.png
(which is btw a version 2 screen).

I should say Image uploader suits to my site so well that I cannot wait to buy it.

Thanks again.

:)

Andrew  
#7 Posted : Thursday, February 26, 2004 4:13:00 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 866

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
First of all, in your case it is better to use these settings:

Code:
<PARAM NAME="SourceImageFitMode" VALUE="self">
<PARAM NAME="UploadThumbnailFitMode" VALUE="off">


Just to make sure that you get original file without any thumbnails (in some case it sends an icon of a file instead of thumbnail if it fails to generate one). Besides, try to check if files are sent twice indeed in this way: save uploaded file with unique name (GUID or something like that) and compare these files. Please let me know what happens.

As for details list view mode, this feature is undocumented in the current version, however you can enable it by this param:

Code:
<PARAM NAME="UploadListDisplayMode" VALUE="Details">

Edited by user Thursday, December 20, 2007 6:39:37 PM(UTC)  | Reason: Not specified

dairyman  
#8 Posted : Thursday, February 26, 2004 5:08:00 PM(UTC)
dairyman

Rank: Member

Groups: Member
Joined: 2/26/2004(UTC)
Posts: 4

thanks you. the additional parameters really helped.

I also tried to check out what was happening with the files being sent multiple times, and noticed that, if I selected jpgs or gifs ( image files ) they are being sent only once (no icon or thumbnails as I switched them off ) and working fine. but when i selected any non-image file like say zip or pdf, they are being sent twice. I checked the content of the two files being sent - and they are exactly the same ( size and name ) so essentially every non-image file is being sent twice.

Any ideas about this?

thanks again


Andrew  
#9 Posted : Thursday, February 26, 2004 5:19:00 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 866

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
Could you send URL so that we could test (you can submit case if you do not want to publish it here)?

Edited by user Friday, May 23, 2008 4:17:22 PM(UTC)  | Reason: Not specified

dairyman  
#10 Posted : Thursday, February 26, 2004 7:40:00 PM(UTC)
dairyman

Rank: Member

Groups: Member
Joined: 2/26/2004(UTC)
Posts: 4

hi andrew emailed you the details of what was happening with the file duplication when uploading. thank you
Andrew  
#11 Posted : Thursday, February 26, 2004 7:46:00 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 866

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
I have forwarded it to the developer, as soon as we find out any details, I will contact you.

Thank you for this report.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.