Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
maurib80@gmail.com  
#1 Posted : Wednesday, May 5, 2010 11:21:12 PM(UTC)
maurib80@gmail.com

Rank: Member

Groups: Member
Joined: 4/6/2010(UTC)
Posts: 24

I have multilayerviewer1 with a image
and i have create a button with function undo and redo

Private sub Button1_click

MultiLayerViewer1.undo()

end sub

but when i click the button
Show this error message:

Undo/Redo functionality should be enabled before method call.

Because this message?

Sorry for my english

Thank you
Maurizio
Tamila  
#2 Posted : Thursday, May 6, 2010 3:22:50 PM(UTC)
Tamila

Rank: Advanced Member

Groups:
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hi,

To get worked Undo/Redo functionality you should enable it. For example:
Code:
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
	'Enable Undo/Redo functionality
	MultiLayerViewer1.UndoRedoEnabled = True
	MultiLayerViewer1.UndoRedoTrackingEnabled = True
End Sub

This sample for Win application. This code is called when the Form is loading.
Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!
maurib80@gmail.com  
#3 Posted : Thursday, May 6, 2010 5:22:21 PM(UTC)
maurib80@gmail.com

Rank: Member

Groups: Member
Joined: 4/6/2010(UTC)
Posts: 24

ok Tamila
work ok :)

Thank you
for reply

Edited by user Thursday, May 6, 2010 5:24:52 PM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.