Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
dane  
#1 Posted : Tuesday, February 16, 2010 4:36:05 PM(UTC)
dane

Rank: Member

Groups: Member
Joined: 1/6/2010(UTC)
Posts: 15

This code should remove a field from the upload POST array, but it does not. It iterates fine, displays the alert when I uncomment it, so I know the correct field name to remove is being defined. It does not work. I stripped down the code; the original also defined custom fields using iuobj.AddField('user_id', '<?php echo $user_id; ?>'), which also works just fine.

After reporting several bugs yesterday in another forum post, and a couple more as a support case, and receiving confirmation of their bug status, I'm beginning to doubt my ability to code. I can't tell if I'm writing the code properly, or I am but the actual software API is buggy. This is frustrating, to say the least, if this is another broken method. I hope I'm just writing incorrect code.

Code:

iu.addEventListener("BeforeUpload", function() 
{
	var iuobj = getImageUploader("ImageUploader1");
	
	// iterate through files--pad with 1 as filename conventions do not start from 0 (1-based)
	var total_files = iuobj.getUploadFileCount()+1;
	var r = '';
	for (var i = 1; i < total_files; i++)
	{
		r = 'Width_'+i;
		//alert('Remove this: '+ r);
		iuobj.RemoveField(r);
	}
});

Edited by user Tuesday, February 16, 2010 5:40:21 PM(UTC)  | Reason: Not specified

dane  
#2 Posted : Wednesday, February 17, 2010 3:15:12 AM(UTC)
dane

Rank: Member

Groups: Member
Joined: 1/6/2010(UTC)
Posts: 15

Anyone?

Here are the specs:

--

IU Version: 6.5.1.0

Windows XP SP2

[latest versions]

Chrome: 4.0.249.89

Firefox: 3.6

Safari: 4.0.4

Flock 2.5.6

Opera 10.10

[latest version]

Java: version 6 update 18 (build 1.6.0_18-b07)

Edited by user Wednesday, February 17, 2010 3:15:57 AM(UTC)  | Reason: Not specified

Dmitry  
#3 Posted : Wednesday, February 17, 2010 7:10:32 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
Hello,

We confirm this problem. It will be fixed in the next 6.5.x minor release. Thanks for your report.

Edited by user Wednesday, February 17, 2010 7:11:04 PM(UTC)  | Reason: Not specified

Sincerely yours,

Dmitry Sevostyanov

UserPostedImage Follow Aurigma on Twitter!

dane  
#4 Posted : Saturday, February 27, 2010 8:56:30 PM(UTC)
dane

Rank: Member

Groups: Member
Joined: 1/6/2010(UTC)
Posts: 15

This is now fixed in 6.5.6.0 released on February 25, 2010. Thank you.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.