Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
fregas  
#1 Posted : Tuesday, September 1, 2009 6:49:21 AM(UTC)
fregas

Rank: Newbie

Groups: Member
Joined: 8/30/2009(UTC)
Posts: 3

My environment:

IE 8.0, windows 7, asp.net mvc

I'm using the following javascript to embed Image Uploader on the page:

Code:
<script type="text/javascript" language="javascript">
			//<![CDATA[
			//Create JavaScript object that will embed Image Uploader to the page.
			var iu = new ImageUploaderWriter("ImageUploader1", 650, 400);

			//For ActiveX control full path to CAB file (including file name) should be specified.
			iu.activeXControlCodeBase = "../Scripts/imageuploader/ImageUploader6.cab";
			iu.activeXControlVersion = "6,1,1,0";

			//For Java applet only path to directory with JAR files should be specified (without file name).
			iu.javaAppletJarFileName = "ImageUploader6.jar";
			iu.javaAppletCodeBase = "../Scripts/imageuploader/";
			iu.javaAppletCached = true;
			iu.javaAppletVersion = "6.1.1.0";

			iu.showNonemptyResponse = "off";

			//Configure appearance.
			iu.addParam("PaneLayout", "ThreePanes");
			iu.addParam("FolderPaneHeight", "200");
			iu.addParam("ShowDebugWindow", "true");
			iu.addParam("AllowMultipleRotate", "true");
			iu.addParam("AllowMultipleRemove", "true");
			iu.addParam("BackgroundColor", "#ffffff");
			iu.addParam("AllowMultipleRotate", "true");

			//Configure License Keys
			iu.addParam("LicenseKey", "71060-4FD0B-00000-05DF7-6C6C6;72060-4FD0B-00000-0FA06-37A72");


			//Configure URL files are uploaded to.
			iu.addParam("Action", "/file.mvc/submitfiles/");

			//Configure URL where to redirect after upload.
			//iu.addParam("RedirectUrl", "gallery.asp");

			//Create installation progress.
			var ip = new InstallationProgressExtender(iu);
			ip.setProgressImageUrl("../Scripts/imageuploader/InstallationProgress.gif");
			//ip.setProgressCssClass("ScreenStyle");
			//ip.setInstructionsCssClass("ScreenStyle");

			//Tell Image Uploader writer object to generate all necessary HTML code to embed 
			//Image Uploader to the page.
			iu.writeHtml();
			//]]>
		</script>


This works fine when running visual studio's built in web server. However, if I browse to http://localhost, the uploader shows up but will not attempt to send a file. It always gives me the error "Image uploader encountered some problem". It does not hit any code on the server.

Also, in Firefox 3.5 on the mac, the uploader does not show up at all when i browse to the page by ip address.

Thanks,
Craig

Edited by user Tuesday, September 1, 2009 10:43:50 AM(UTC)  | Reason: Not specified

fregas  
#2 Posted : Tuesday, September 1, 2009 7:05:23 AM(UTC)
fregas

Rank: Newbie

Groups: Member
Joined: 8/30/2009(UTC)
Posts: 3

Also, when i have debug on in the image uploader configuration, it pops up a new IE window that says "Bad Request".
Eugene Kosmin  
#3 Posted : Tuesday, September 1, 2009 11:06:42 AM(UTC)
Eugene Kosmin

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 9/19/2006(UTC)
Posts: 446

Was thanked: 24 time(s) in 24 post(s)
Hi Craig,

The current build of Image Uploader does not work properly with Windows7’s IIS. The fix will be available on the next week within the next minor release.
Best regards,
Eugene Kosmin.
Aurigma Development Team
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.