Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
aharris1  
#1 Posted : Tuesday, July 7, 2009 3:08:38 AM(UTC)
aharris1

Rank: Newbie

Groups: Member
Joined: 6/1/2009(UTC)
Posts: 2

Version: 6.0.11.28744

I have UploadSourceFile turned off.

I am uploading Two thumbnails.

When I receive the uploaded files on the server, thumbnail2 is rotated 90Deg counterclockwise. But only if the source image is a .BMP or a .GIF.

Code:

<cc1:ImageUploader ID="ImageUploader1" runat="server" 
    Width="1050"
			Height="700" 
			PaneLayout="ThreePanes"
			ShowDebugWindow="true"
			AllowRotate="True"
			BackgroundColor="#ccccff"
                        ActiveXControlEnabled="true"

                        UploadSourceFile="false"            

			UploadThumbnail1FitMode="Fit"
			UploadThumbnail1Width="120"
			UploadThumbnail1Height="120"
			UploadThumbnail1JpegQuality="60"

                       UploadThumbnail2FitMode="ActualSize"
                        UploadThumbnail2JpegQuality="90"
             
			OnClientBeforeUpload="beforeUploadHandler"
			Action="FileUploader_Backend.aspx"
       
			
		 FilesPerOnePackageCount="1" ButtonSendText="Upload Files" DeniedFileMask="*.zip;*.exe;*.bat;" MaxConnectionCount="2" MaxFileSize="10000000" MaxFileCount="100" MaxTotalFileSize="50000000" PreserveHttpCookies="False" 
		  >
			<InstallationProgress 
				Visible="False"
				ProgressCssClass="ScreenStyle"
				InstructionsCssClass="ScreenStyle" />
    </cc1:ImageUploader>

I am not doing any manual image manipulation on the client side before the upload.

I do have the 2nd thumbnail set to ActualSize so that if the user is trying to upload a bmp image, it will convert the bmp image to a jpg.

I don't want any of the images rotated unless the user uses the rotate feature.

How can I fix this behavior?

Edited by user Tuesday, July 7, 2009 3:12:04 AM(UTC)  | Reason: Not specified

aharris1  
#2 Posted : Tuesday, July 7, 2009 3:28:46 AM(UTC)
aharris1

Rank: Newbie

Groups: Member
Joined: 6/1/2009(UTC)
Posts: 2

Ok. So any thumbnail that I have set to

FitMode="ActualSize"

has issues with bmp and gif images.

Tamila  
#3 Posted : Tuesday, July 7, 2009 2:48:18 PM(UTC)
Tamila

Rank: Advanced Member

Groups:
Joined: 3/9/2008(UTC)
Posts: 554

Was thanked: 1 time(s) in 1 post(s)
Hello,

I have reproduced your problem locally. Unfortunately, it is a bug, our developers will fix it in future releases.

Thank you for bug report.

Quote:
I do have the 2nd thumbnail set to ActualSize so that if the user is trying to upload a bmp image, it will convert the bmp image to a jpg.

It is a normal behavior, Image Uploader save thumbnails in jpeg format only.

Edited by user Tuesday, July 7, 2009 2:51:13 PM(UTC)  | Reason: Not specified

Aurigma Support Team

UserPostedImage Follow Aurigma on Twitter!

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.