Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
hyperlinked  
#1 Posted : Monday, June 9, 2008 3:58:10 PM(UTC)
hyperlinked

Rank: Advanced Member

Groups: Member
Joined: 4/24/2008(UTC)
Posts: 31

For a while, I've been having some issues with dropping files into the drag and drop area. I'm using a one pane layout. I couldn't figure out when IU would fail to register images I've dragged in and when it wouldn't. It all seemed to be happening at very random times.

I've finally figured it out. I haven't tested other browsers yet, but on the Java version on Firefox Mac, if you move the window that IU is loaded into, the drag and drop zone does not move with the window. It stays where the window originally loaded so if you try to drag to the new drop area, the file will not be added to your uploads (unless that drop area happens to overlap with the original drop area).

Is there a fix for this?

George Ulyanov  
#2 Posted : Tuesday, June 10, 2008 4:28:07 PM(UTC)
George Ulyanov

Rank: Advanced Member

Groups:
Joined: 7/26/2006(UTC)
Posts: 203

Hello,

If you use one of the standard Image Uploader samples, there are some restrictions, like maximal file size or something. Also, in most cases, there are FileMasks set to the image formats only (like *.png; *.jpg, etc).

So, if you try to drop some file, that breaks one of these restrictions - it won't be added into the upload pane. (Actually, I think that this is about FileMask property. Try to set it to "*.*" or remove it completely).

Best regards,

George Ulyanov

hyperlinked  
#3 Posted : Thursday, June 12, 2008 3:13:00 PM(UTC)
hyperlinked

Rank: Advanced Member

Groups: Member
Joined: 4/24/2008(UTC)
Posts: 31

I think I'm talking about something else, George.

Here's what's happening.

This does not work

1. I click on a link to spawn ImageUploader in a new window in FireFox

2. IU loads in a pop-up window on the left side of my monitor screen.

3. I drag the pop-up window so it's now on the right side of the screen.

4. I try to drag and drop any image into the drop zone. Nothing will drop in.

This does work

1. I click on a link to spawn ImageUploader in a new window in FireFox

2. IU loads in a pop-up window on the left side of my monitor screen.

3. Without moving the window, I drag a file into the drop zone. It works.

This works partially

1. I click on a link to spawn ImageUploader in a new window in FireFox

2. IU loads in a pop-up window on the left side of my monitor screen.

3. I move the pop-up window 200 pixels to the right on my monitor.

4. The first 200 pixels of width of the IU drop zone on the left becomes dead. I cannot drop files into the 200 pixel region on the left size of the drop zone, but any drop zone space to the right will work.

Another Way to See This Bug

1. Spawn a new instance of IU in Firefox

2. Move the window

3. Right click to change the view of the window.

4. The contextual menu appears over the area where the window spawned at, not where the window was moved to.

My invokation code is the same as in this thread:

http://forums.aurigma.co...on-Doesnt-Work.aspx#9410

hyperlinked  
#4 Posted : Tuesday, June 24, 2008 2:04:06 AM(UTC)
hyperlinked

Rank: Advanced Member

Groups: Member
Joined: 4/24/2008(UTC)
Posts: 31

Hi, I'm still having this same issue. It has nothing to do with file sizes, masks, and settings. The Java version does not work at all (Firefox 2 Mac) if the window that IU is in gets moved around on the desktop away from its original location.
George Ulyanov  
#5 Posted : Wednesday, June 25, 2008 7:02:28 PM(UTC)
George Ulyanov

Rank: Advanced Member

Groups:
Joined: 7/26/2006(UTC)
Posts: 203

Hello,

Sorry for this delay.

I've tried to reproduce such behavior, but with no success at this moment: everything worked ok.

Could you provide me the direct link or zipped archive with the html?

Best regards,

George Ulyanov

George Ulyanov  
#6 Posted : Thursday, June 26, 2008 2:28:43 PM(UTC)
George Ulyanov

Rank: Advanced Member

Groups:
Joined: 7/26/2006(UTC)
Posts: 203

Ah, alright. I got it.

It looks that the problem is in the browser... I'm trying to find out something about this FF behavior.

BTW, in FF 3.0 (MacOS of corse, under Windows - everything's ok) this bug disappeared.

Best regards,

George Ulyanov

hyperlinked  
#7 Posted : Thursday, June 26, 2008 2:41:12 PM(UTC)
hyperlinked

Rank: Advanced Member

Groups: Member
Joined: 4/24/2008(UTC)
Posts: 31

Thanks for checking into this George. I did some more testing myself and here's what I found.

Mac - Safari 3.1.1 - Can't Replicate

Mac - Camino 1.6 - Can't Replicate

Mac - Firefox 2 - Was able to replicate problem

Mac - Firefox 3 - Can't Replicate

PC - IE 7 - Can't Replicate

PC - Firefox 2 - Can't Replicate

I used your online demo to test this:

http://demo.aurigma.com/...rrentUpload/default.aspx

So it appears that Firefox 2 is the culprit. Since I was only able to replicate this in Firefox 2, I thought it might be one of my plugins. I disabled all plugins and was still able to replicate the problem.

George Ulyanov  
#8 Posted : Thursday, June 26, 2008 3:19:43 PM(UTC)
George Ulyanov

Rank: Advanced Member

Groups:
Joined: 7/26/2006(UTC)
Posts: 203

Yes, I've found this problem in FF2 only, under Mac too.

I'm trying find something about this in FF bug tracking system, but still without any hook.

This is very strange, because special logging version of the applet didn't catch any DnD events after such window movements...

Best regards,

George Ulyanov

George Ulyanov  
#9 Posted : Sunday, June 29, 2008 2:01:40 PM(UTC)
George Ulyanov

Rank: Advanced Member

Groups:
Joined: 7/26/2006(UTC)
Posts: 203

Alright, I've posted a bug report to Mozilla's Bugzilla here:

https://bugzilla.mozilla...g/show_bug.cgi?id=442204

Let's see what they'll do...

Best regards,

George Ulyanov

hyperlinked  
#10 Posted : Friday, July 4, 2008 9:24:56 AM(UTC)
hyperlinked

Rank: Advanced Member

Groups: Member
Joined: 4/24/2008(UTC)
Posts: 31

Thanks for following up on this George!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.