Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

#obsolete

Options
Go to last post Go to first unread
Dmitry  
#1 Posted : Wednesday, January 9, 2008 2:06:34 PM(UTC)
Dmitry

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 8/3/2003(UTC)
Posts: 1,070

Thanks: 1 times
Was thanked: 12 time(s) in 12 post(s)
This topic describes how to run Graphics Mill for .NET based applications on x64 workstations.
Graphics Mill for .NET does not support 64-bit mode at that time because of it includes 32-bit native code. But it can be run on x64 workstations in 32-bit emulation mode. Let’s consider how to do it for Windows Forms and Web applications.

Windows Forms applications
There are two different situations:
  • You have Windows Forms application written for .NET Framework 1.0 or 1.1. In that case you just should install .NET Framework 1.1 or 1.0 on your x64 station and run your application.
  • Your Windows Forms application is written for .NET Framework 2.0. In this case you should recompile your software for 32-bit platform. Then you should install .NET Framework 2.0 on your x64 machine and place msvcr71.dll to windows/system32 folder. You can copy this library from Windows\Microsoft .NET\Framework\v1.1* if you have .NET Framework installed on your machine or from another machine with .NET Framework1.1. After that you can run your application.

    Web applications
    IIS 6.0 supports both the 32-bit mode and the 64-bit mode. However IIS 6.0 does not support running both modes at the same time on a 64-bit version of Windows. To use Graphics Mill for .NET in your Web application you should enable ASP.NET 2.0, 32-bit mode as it is shown in the article. To run the 32-bit version of ASP.NET 2.0, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following command to enable the 32-bit mode:
    Code:
    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

    3. Type the following command to install the version of ASP.NET 2.0 (32-bit) and to install the script maps at the IIS root and under:
    Code:
    %SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i
    4. Make sure that the status of ASP.NET version 2.0.50727 (32-bit) is set to Allowed in the Web service extension list in Internet Information Services Manager.
  • Edited by moderator Sunday, June 10, 2012 8:55:44 PM(UTC)  | Reason: Not specified

    Sincerely yours,
    Dmitry Sevostyanov

    UserPostedImage Follow Aurigma on Twitter!
    GlennJ  
    #2 Posted : Friday, May 28, 2010 7:55:22 AM(UTC)
    GlennJ

    Rank: Member

    Groups: Member
    Joined: 1/20/2008(UTC)
    Posts: 10

    We're running IIS 7 on Windows Server 2008, so those instructions don't work for us.

    I have tried what I believe is the same method in IIS 7, but still no joy.

    The full error we get is


    Server Error in '/Web' Application.


    Parser Error
    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Could not load file or assembly 'Aurigma.GraphicsMill.WebControls' or one of its dependencies. The system cannot find the file specified.

    Source Error:


    Line 1: <%@ Page Language="VB" AutoEventWireup="false" CodeFile="UploadImage.aspx.vb" Inherits="Windows_UploadImage" %>
    Line 2:
    Line 3: <%@ Register Assembly="Aurigma.GraphicsMill.WebControls" Namespace="Aurigma.GraphicsMill.WebControls"
    Line 4: TagPrefix="cc1" %>
    Line 5:


    Source File: /Web/Windows/UploadImage.aspx Line: 3

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Aurigma.GraphicsMill.WebControls' could not be loaded.


    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].





    Version Information: Microsoft .NET Framework Version:2.0.50727.4927; ASP.NET Version:2.0.50727.4927
    Tamila  
    #3 Posted : Monday, May 31, 2010 2:26:06 AM(UTC)
    Tamila

    Rank: Advanced Member

    Groups: Member
    Joined: 3/9/2008(UTC)
    Posts: 554

    Was thanked: 1 time(s) in 1 post(s)
    Hi,

    I recommend you to configure especial Application Pool for your application. You can do it as decribed here:
    1. Open IIS manager
    2. Select Application Pools item in list
    3. Right-click in Application Pool list and select Add Application Pool... menu item
    4. In new window write any name of new pool, set .NET Framework version to v2.0 and click OK
    5. Select this new pool in pool list and click Advanced Settings...
    6. In new window in General section set Enable 32-bit Applications to True, click OK
    7. Find your application in tree-list, select it and click Advanced Settings...
    8. In this window in General section set your new pool and click OK
    I hope it helps.
    Aurigma Support Team

    UserPostedImage Follow Aurigma on Twitter!
    GlennJ  
    #4 Posted : Monday, June 7, 2010 5:26:26 AM(UTC)
    GlennJ

    Rank: Member

    Groups: Member
    Joined: 1/20/2008(UTC)
    Posts: 10

    I followed the instructions but still get the same error unfortunately. Works locally fine, but Server 2008 still complains. Any idea what else could be causing the issue?
    Tamila  
    #5 Posted : Monday, June 7, 2010 7:01:37 PM(UTC)
    Tamila

    Rank: Advanced Member

    Groups: Member
    Joined: 3/9/2008(UTC)
    Posts: 554

    Was thanked: 1 time(s) in 1 post(s)
    Aurigma Support Team

    UserPostedImage Follow Aurigma on Twitter!
    GlennJ  
    #6 Posted : Tuesday, June 8, 2010 8:01:53 AM(UTC)
    GlennJ

    Rank: Member

    Groups: Member
    Joined: 1/20/2008(UTC)
    Posts: 10

    Yes, we have installed that but it didn't help. BTW, we are running version 4.5.

    So far I have tried the following

    1) Set IIS7.5 to run in 32bit mode for our custom application pool
    2) Installed the C++ service pack as above
    3) Set the permissions for the IIS server to run as Administrator to see if it was a permissions problem

    Our server is Windows Server 2008 Web edition running in 64bit mode.

    I'm not normally stumped by this sort of thing, but I am this time! ;-)
    Tamila  
    #7 Posted : Tuesday, June 8, 2010 8:33:07 PM(UTC)
    Tamila

    Rank: Advanced Member

    Groups: Member
    Joined: 3/9/2008(UTC)
    Posts: 554

    Was thanked: 1 time(s) in 1 post(s)
    Hi,

    If you use Graphics Mill 4.5, please make sure that you install msvcr71.dll correctly.
    If the problem still appears, send me error message from Event Viewer (Control Panel -> Administrative Tools -> Event Viewer)
    Aurigma Support Team

    UserPostedImage Follow Aurigma on Twitter!
    GlennJ  
    #8 Posted : Wednesday, June 9, 2010 12:26:32 AM(UTC)
    GlennJ

    Rank: Member

    Groups: Member
    Joined: 1/20/2008(UTC)
    Posts: 10

    Argh, I was told I didn't need that as I was running a web app (which at the time didn't make much sense)... I will try that today, thanks.
    Tamila  
    #9 Posted : Wednesday, June 9, 2010 1:02:10 AM(UTC)
    Tamila

    Rank: Advanced Member

    Groups: Member
    Joined: 3/9/2008(UTC)
    Posts: 554

    Was thanked: 1 time(s) in 1 post(s)
    Hi,

    msvcr71.dll is necessary for Graphics Mill, no matter which application you develop - Win or Web.
    Also we investigated this problem locally and found that you should put this dll into Windows\SysWOW64 folder too.
    Please try it and let us know about your results.
    Aurigma Support Team

    UserPostedImage Follow Aurigma on Twitter!
    GlennJ  
    #10 Posted : Thursday, June 10, 2010 6:46:28 PM(UTC)
    GlennJ

    Rank: Member

    Groups: Member
    Joined: 1/20/2008(UTC)
    Posts: 10

    Hi

    I check the server and it already had the msvcr71.dll (I had tried it previously, but though I had removed it).

    What other reasons might cause this error? Or do I need to register the DLL or something??

    Please help, this is driving me insane... it works fine on my local dev machine which is Vista 64bit.

    Dmitry  
    #11 Posted : Sunday, June 13, 2010 3:39:34 PM(UTC)
    Dmitry

    Rank: Advanced Member

    Groups: Member, Administration, Moderator
    Joined: 8/3/2003(UTC)
    Posts: 1,070

    Thanks: 1 times
    Was thanked: 12 time(s) in 12 post(s)
    Hello,

    I just tried to post GM4.5 along with sample web application to our Windows Server 2008 R2. To run it I had to put msvcr71.dll to Windows\SysWOW64 folder. After I did it, everything worked okay. Please, confirm that you have msvcr71.dll in Windows\SysWOW64.
    Sincerely yours,
    Dmitry Sevostyanov

    UserPostedImage Follow Aurigma on Twitter!
    GlennJ  
    #12 Posted : Sunday, June 13, 2010 11:48:49 PM(UTC)
    GlennJ

    Rank: Member

    Groups: Member
    Joined: 1/20/2008(UTC)
    Posts: 10

    Yes, we have msvcr71.dll in Windows\SysWOW64 and still get the "The specified module could not be found. (Exception from HRESULT: 0x8007007E)" error.

    I've installed the GM4.5 software and tried the Web Demos and they error just the same.
    Dmitry  
    #13 Posted : Monday, June 14, 2010 3:50:45 PM(UTC)
    Dmitry

    Rank: Advanced Member

    Groups: Member, Administration, Moderator
    Joined: 8/3/2003(UTC)
    Posts: 1,070

    Thanks: 1 times
    Was thanked: 12 time(s) in 12 post(s)
    Hello,

    Sorry that the problem is not resolved yet.

    Let us go through installation process step by step. I just tried to perform them on my clear Windows 2008 R2 Enterprise and it allowed launching GM 4.5 there.
    1. Enable 32-bit applications in your application pool (Application Pool -> Advanced settings -> Enable 32-bit Applications).
    2. Copy msvcr71.dll to C:\Windows\SysWOW64, please take the library attached to this post.
    3. Copy web application attached to this case to C:\inetpub\wwwroot.
    4. Create web application in IIS, check that you specify application pool where you enabled 32-bit application on the 1st step.
    5. Launch the application.
    If it does not help, it seems you face some non-standard situation. The most effective way to resolve it is to give our support team remote access to your server. It will allow fixing the problem shortly. Post support ticket with details if you accept this way.

    Edited by user Monday, June 14, 2010 3:52:25 PM(UTC)  | Reason: Not specified

    File Attachment(s):
    GraphicsMillAjaxVB.zip (1,831kb) downloaded 59 time(s).
    msvcr71.zip (177kb) downloaded 71 time(s).
    Sincerely yours,
    Dmitry Sevostyanov

    UserPostedImage Follow Aurigma on Twitter!
    Dmitry.Obukhov  
    #14 Posted : Wednesday, August 4, 2010 6:21:00 PM(UTC)
    Dmitry.Obukhov

    Rank: Advanced Member

    Groups: Member
    Joined: 5/29/2010(UTC)
    Posts: 1,310

    Thanks: 8 times
    Was thanked: 111 time(s) in 111 post(s)
    How to deploy x86 Graphics Mill Windows applications under x64 operating systems you can find here.

    Edited by user Thursday, August 5, 2010 1:07:31 PM(UTC)  | Reason: Not specified

    Best regards,
    Dmitry Obukhov
    Technical Support. Aurigma, Inc.
    ChingYen  
    #15 Posted : Tuesday, August 17, 2010 2:58:31 PM(UTC)
    ChingYen

    Rank: Advanced Member

    Groups: Member
    Joined: 3/3/2008(UTC)
    Posts: 185

    Thanks: 8 times
    Hi,

    We are having similar problem...
    Windows Server 2008 64bit.. Follow all the steps above...
    But, still facing this problem
    Could not load file or assembly 'Aurigma.GraphicsMill.Codecs.AdvancedPsd, Version=5.5.3630.31904

    Please advise...
    Dmitry.Obukhov  
    #16 Posted : Tuesday, August 17, 2010 7:58:23 PM(UTC)
    Dmitry.Obukhov

    Rank: Advanced Member

    Groups: Member
    Joined: 5/29/2010(UTC)
    Posts: 1,310

    Thanks: 8 times
    Was thanked: 111 time(s) in 111 post(s)
    Hello Ching-Yen,

    To resolve you problem in timely manner could you describe it detailed? Please let me know which problem you have? Where and when it occurs? And what steps did you do to resolve it? It would be great if you send me complete error message. Also, you are able to submit new support ticket.

    Looking forward to your reply.
    Best regards,
    Dmitry Obukhov
    Technical Support. Aurigma, Inc.
    Users browsing this topic
    Forum Jump  
    You cannot post new topics in this forum.
    You cannot reply to topics in this forum.
    You cannot delete your posts in this forum.
    You cannot edit your posts in this forum.
    You cannot create polls in this forum.
    You cannot vote in polls in this forum.