Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
Fedor  
#1 Posted : Wednesday, November 8, 2006 7:52:00 AM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,550

Thanks: 5 times
Was thanked: 59 time(s) in 58 post(s)
Overview

When Image Uploader is used to upload images with non-ASCII characters in file names to the server running under IIS 5, under certain conditions the user will not be able to view those images after upload.

Reason

This happens when non-ASCII characters does not conform to a default locale used on the server. IIS 5 uses a default locale to decode a query string with non-ASCII characters, and that's why if the default server locale differs from the user's locale, some characters may not be found. Therefore the file name of the uploaded becomes incorrect.

Solution

There are two ways to handle this situation.
  1. If you experience this problem, and you are sure that all your users use the same locale, change the default server locale. To do that go to Start -> Control Panel -> Regional and Language Options -> Advanced tab, and in the Language for non-Unicode programs box select the required locale from the drop-down list. After that you need to reboot the server.
  2. If there is no guarantee that all users will use the same locale, you will have to process the names of the uploaded files in the upload script before saving them to disk and remove 'non-standard' characters from the file names.
Notes

This problem does not concern IIS 6.
Best regards,
Fedor Skvortsov
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.