Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
gaurav26  
#1 Posted : Tuesday, July 4, 2017 6:53:41 AM(UTC)
gaurav26

Rank: Newbie

Groups: Member
Joined: 6/13/2017(UTC)
Posts: 4

Thanks: 2 times
The issue is Uploading the huge file (i.e. 2GB file) using the chunk value 100MB and time taken is 2.5min(taking 28 request) which is taking more time in comparison to same file (i.e 2GB) without the chunk value is taking only 1.5 min(1 request).

According to above data, the value without chunk value is taking less time in comparison to chunk value(100MB) is taking more time, it shouldn't be happen chunk should take less time?

Is there any solution for above ?
Andrey Semenov  
#2 Posted : Wednesday, July 5, 2017 3:19:38 AM(UTC)
Andrey Semenov

Rank: Member

Groups: Member, Administration
Joined: 7/4/2017(UTC)
Posts: 27

Was thanked: 10 time(s) in 10 post(s)
Hello gaurav26,

Uploading files by chunks itself is designed as a fail-safe option. System needs to split file into chunks and then put them together after all pieces are uploaded - so some additional time is required to perform this.

To increase uploading speed for very large files you should use max connection count property, please see the following page for details:
Upload Modes Best Practices

E.g. for PHP the following settings can be used:
$uploader->getUploadSettings()->setMaxConnectionCount(4);

Regards,
Andrey
thanks 1 user thanked Andrey Semenov for this useful post.
gaurav26 on 7/5/2017(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.