Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
hugosmarques  
#1 Posted : Sunday, March 11, 2007 8:59:05 PM(UTC)
hugosmarques

Rank: Member

Groups: Member
Joined: 3/18/2006(UTC)
Posts: 5

I already resolve the problem, but now i have one more.

The component loads fine no crash, but i use 3 panes layout and i want put the Advanced Details mode in the upload pane but the images and the other information don't appear only appear in List, details or icon mode why????

See the code at the folowing URL: http://www.arealcms.com/ajaxComponent/ .

Thanks
Alex Makhov  
#2 Posted : Sunday, March 11, 2007 9:52:48 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

Advanced details mode is not implemented in Java version any way so you’d better to use some another view mode. As about this issue, I have added this bug information to our bug tracking system. Thank you for the bug report.
Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
hugosmarques  
#3 Posted : Sunday, March 11, 2007 10:03:11 PM(UTC)
hugosmarques

Rank: Member

Groups: Member
Joined: 3/18/2006(UTC)
Posts: 5

I use these mode because people after click in send Button can see the progress in the upload pane without open the default window, i have the silent mode activate because i don't want open the progress window.

Thanks
hugosmarques  
#4 Posted : Sunday, March 11, 2007 10:04:19 PM(UTC)
hugosmarques

Rank: Member

Groups: Member
Joined: 3/18/2006(UTC)
Posts: 5

And the advanced details work fine if i open the page in IE without the help of AJAX. Only if i use the AJAX method to open the page these feature dont' work!!!!

View the page is these URL:

http://www.arealcms.com/...InitComponentAlbuns1.asp

Work fine!!!
hugosmarques  
#5 Posted : Sunday, March 11, 2007 10:35:34 PM(UTC)
hugosmarques

Rank: Member

Groups: Member
Joined: 3/18/2006(UTC)
Posts: 5

Alex i found the problem. The problem is in getHtml(); - don't work and writeHtml() - WORK FINE.

I can't use writeHtml(); because if i use it he open a new document in IE and i want put the information in a div. I have the following code:

Code:
document.getElementById("comp1").innerHTML = iu.getHtml();
document.getElementById("comp2").innerHTML = t.getHtml();


The component appear fine but the AdvancedDetails mode don't work.

If i use

Code:
document.getElementById("comp1").innerHTML = iu.writeHtml();
document.getElementById("comp2").innerHTML = t.writetHtml();


Works fine but open a new document and i can't open new document, understand!!!

Edited by user Tuesday, December 18, 2007 4:29:16 PM(UTC)  | Reason: Not specified

Alex Makhov  
#6 Posted : Monday, March 12, 2007 1:38:37 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

getHtml() method returns the HTML code which should be inserted to the page to insert Image Uploader control. writeHtml() method writes this method to the current position so if you want to assign the html-code to some element as its innerHTML, you should use getHtml() method any way.
Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.