Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
nokturnal  
#1 Posted : Wednesday, May 25, 2016 11:32:12 AM(UTC)
nokturnal

Rank: Member

Groups: Member
Joined: 3/21/2016(UTC)
Posts: 22

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
Hey,

Let me walk through how I have this setup:

- Added GraphicsMill via NuGet (8.1.30) to an existing ASP.net web application.

- Added my license information in the web.config

- I attempted to use the 64bit version, but IIS Express errored:

Could not load file or assembly 'Aurigma.GraphicsMill' or one of its dependencies. An attempt was made to load a program with an incorrect format

- I switch to the 32bit version and everything worked as expected locally.

** I can also run the 64bit version IF I force IISExpress to run in 64bit **

I then tried to publish to a production server (Windows 2012):

- Published and the production server errors with the same error as before:

Could not load file or assembly 'Aurigma.GraphicsMill' or one of its dependencies. An attempt was made to load a program with an incorrect format

- I enabled 32bit applications in IIS on the production server, and I get a new error:

Could not load file or assembly 'Aurigma.GraphicsMill.DLL' or one of its dependencies. The specified module could not be found.

- The Aurigma.GraphicsMill.dll is present in the BIN directory of the production website

If I change back to the x64 version and publish I get the second error again:

Could not load file or assembly 'Aurigma.GraphicsMill.DLL' or one of its dependencies. The specified module could not be found.

What do I do now? I do have the SDK installed on my dev system, but nothing is "installed" on the webserver. Does the webserver need to have the appropriate version of the Microsoft Visual C++ Redistributable Package installed?

Edited by user Wednesday, May 25, 2016 12:09:31 PM(UTC)  | Reason: Not specified

nokturnal  
#2 Posted : Wednesday, May 25, 2016 12:43:37 PM(UTC)
nokturnal

Rank: Member

Groups: Member
Joined: 3/21/2016(UTC)
Posts: 22

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
I decided to install the Visual C++ Redistributable Packages for Visual Studio 2013 and all errors have been resolved. This is a bit concerning in the long run due to this requirement, but for now it will work for me.

Thanks, and I hope this helps someone

thanks 1 user thanked nokturnal for this useful post.
Fedor on 5/27/2016(UTC)
Fedor  
#3 Posted : Friday, May 27, 2016 3:26:46 AM(UTC)
Fedor

Rank: Advanced Member

Groups: Member, Administration, Moderator
Joined: 7/28/2003(UTC)
Posts: 1,567

Thanks: 5 times
Was thanked: 64 time(s) in 63 post(s)
Best regards,

Fedor Skvortsov

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.