Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
mohrt  
#1 Posted : Friday, January 19, 2007 12:02:24 AM(UTC)
mohrt

Rank: Member

Groups: Member
Joined: 6/2/2006(UTC)
Posts: 4

Hi, I'm using Windows XP Home SP2, I recently updated my JRE to 1.6.0, and now I get this error when starting the image uploader (firefox 2.0):
Code:
sun.plugin.cache.JarCacheVersionException: Number of attributes specified in 'cache_archive' doesn't match those in 'cache_version' 
     at sun.plugin.cache.JarCacheUtil.getJarsWithVersion(Unknown Source) 
     at sun.plugin.AppletViewer.initJarVersionMap(Unknown Source) 
     at sun.plugin.AppletViewer.createClassLoader(Unknown Source) 
     at sun.plugin.AppletViewer.appletInit(Unknown Source) 
     at sun.plugin.viewer.LifeCycleManager.initAppletPanel(Unknown Source) 
     at sun.plugin.viewer.WNetscapePluginObject$Initer.run(Unknown Source)
I tried clearing the java cache to no avail. We are using version 3.x for ActiveX, 1.x for Java (applet version 1.1.81.0). Do we need to upgrade Aurigma Image Uploader to fix this problem? Or is Java JRE 1.6.0 not supported yet? Thanks!

Edited by user Tuesday, December 18, 2007 5:27:58 PM(UTC)  | Reason: Not specified

mohrt  
#2 Posted : Friday, January 19, 2007 12:51:05 AM(UTC)
mohrt

Rank: Member

Groups: Member
Joined: 6/2/2006(UTC)
Posts: 4

An update to this post, JRE 1.5.0 update 10 doesn't show jpg images within the uploader. JRE 1.5.0 update 9 and lower all seem to work fine. Only JRE 1.6.0 has the cache error (and also the jpeg problem).
Alex Makhov  
#3 Posted : Sunday, January 21, 2007 3:18:12 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello, We have reproduced the caching problem and found the resolution: Replace the lines of code in iuembed.js file (there are two such lines of code):
Code:
r+=this._getEmbedParamHtml("cache_version",v+","+v);
with the following one:
Code:
r+=this._getEmbedParamHtml("cache_version",v);
The fixed iuembed.js script will be available with the next Image Uploader release.
Sincerely yours, Alex Makhov UserPostedImage Follow Aurigma on Twitter!
atoks  
#4 Posted : Wednesday, March 07, 2007 1:32:50 PM(UTC)
atoks

Rank: Member

Groups: Member
Joined: 3/7/2007(UTC)
Posts: 1

We tried that fix with that solution, but unfortunately we are still getting the same error again. Kindly let us know how to debug the problem. thanks, -SK
Alex Makhov  
#5 Posted : Sunday, March 11, 2007 8:53:18 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups: Member
Joined: 8/3/2003(UTC)
Posts: 998

Hello, I think you are still using the cached version of iuembed.js file instead of the right one. Also note that the specified fix will be available in the next release of Image Uploader Dual which will be published tomorrow. The version of Image Uploader for Java there is 2.1.30.0.
Sincerely yours, Alex Makhov UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.